No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Splicing a VLL with an MPLS EVPN E-Line

Example for Splicing a VLL with an MPLS EVPN E-Line

The traditional VLL is still used at the aggregation layer of a network, whereas the core network has evolved into EVPN. To allow services at different layers to run properly network wide, a VLL must be spliced with an MPLS EVPN E-Line.

Networking Requirements

On the network shown in Figure 11-31, a VLL (or VPWS) network is deployed between the UPE and NPE1, and an EVPN is deployed between NPE1 and NPE2. To implement VLL accessing EVPN, a PW-VE interface and its sub-interface must be configured on NPE1. Specifically, the VLL configurations are performed on the PW-VE interface, and the EVPN configurations are performed on the PW-VE sub-interface. An EVPL instance corresponding to an EVPN instance is bound to the PW-VE sub-interface, which is configured as a QinQ VLAN tag termination sub-interface.

Figure 11-31 Splicing a VLL with an MPLS EVPN E-Line
NOTE:

Interfaces 0 through 2 in this example refer to GE 0/1/0, GE 0/1/1, GE 0/1/2, respectively.



Table 11-5 Mapping between interfaces and IP addresses

Device Name

Interface Name

IP Address and Mask

NPE1

GE 0/1/1

31.1.1.1/24

GE 0/1/2

192.168.14.1/24

Loopback 0

1.1.1.1/32

Loopback 100

1.1.1.100/32

UPE

GE 0/1/0

-

GE 0/1/1

31.1.1.3/24

Loopback 0

2.2.2.2/32

NPE2

GE 0/1/0

-

GE 0/1/1

192.168.14.4/24

Loopback 100

2.2.2.100/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on each device. Because the VLL network (between the UPE and NPE1) and EVPN (between NPE1 and NPE2) reside at different layers, use different IGP processes to implement route communication.

  2. Configure basic MPLS LDP functions on the UPE, NPE1, and NPE2.

  3. Configure VPWS connections on the UPE and NPE1.

  4. Configure EVPN functions on NPE1 and NPE2, including creating EVPN instances and establishing a BGP EVPN peer relationship between the devices.

  5. Configure EVPL functions on NPE1 and NPE2.

  6. Bind the VSI to the PW-VE interface on NPE1; bind the EVPL instances to the PE-VE sub-interfaces of NPE1.

Data Preparation

To complete the configuration, you need the following data:

  • Interface names and IP addresses of the interfaces on NPE1, NPE2, and the UPE

  • MPLS LSR IDs on the UPE, NPE1, and NPE2

  • Names, RDs, and VPN targets of the EVPN instances created on NPE1 and NPE2

Procedure

  1. Configure IP addresses for interfaces on the UPE, NPE1, and NPE2 and configure an IGP. OSPF is used in this example.

    For detailed configurations, see "Configuration Files" in this section.

  2. Configure basic MPLS functions and MPLS LDP on NPE1, NPE2, and the UPE.

    For detailed configurations, see "Configuration Files" in this section.

  3. Configure VPWS connections on the UPE and NPE1.

    For detailed configurations, see "Configuration Files" in this section.

  4. Configure an EVPN instance on NPE1.

    # Configure NPE1.

    [~NPE1] evpn vpn-instance evpna vpws
    [*NPE1-vpws-evpn-instance-evpna] route-distinguisher 1:1
    [*NPE1-vpws-evpn-instance-evpna] vpn-target 10:10 export-extcommunity
    [*NPE1-vpws-evpn-instance-evpna] vpn-target 10:10 import-extcommunity
    [*NPE1-vpws-evpn-instance-evpna] quit
    [*NPE1] bgp 100
    [*NPE1-bgp] peer 2.2.2.100 as-number 100
    [*NPE1-bgp] peer 2.2.2.100 connect-interface LoopBack100
    [*NPE1-bgp] l2vpn-family evpn
    [*NPE1-bgp-af-evpn] peer 2.2.2.100 enable
    [*NPE1-bgp-af-evpn] quit
    [*NPE1-bgp] quit
    [*NPE1] commit

    The configuration on NPE2 is similar to that on NPE1 and is not provided here. For configuration details, see "Configuration Files" in this section.

  5. Configure EVPL functions on NPE1 and NPE2.

    # Configure NPE1.

    [~NPE1] evpl instance 1 mpls-mode
    [*NPE1-evpl-mpls1] evpn binding vpn-instance evpna
    [*NPE1-evpl-mpls1] local-service-id 100 remote-service-id 200
    [*NPE1-evpl-mpls1] quit
    [*NPE1] commit

    The configuration on NPE2 is similar to that on NPE1 and is not provided here. For configuration details, see "Configuration Files" in this section.

  6. On NPE1, bind the VSI to the PW-VE interface and the EVPN instance to the PW-VE sub-interface.

    # Configure NPE1.

    [~NPE1] mpls
    [*NPE1-mpls] mpls l2vpn
    [*NPE1-l2vpn] quit
    [*NPE1] interface PW-VE 1
    [*NPE1-PW-VE1] esi 0011.1111.0000.0000.0000
    [*NPE1-PW-VE1] mpls l2vc 2.2.2.2 1
    [*NPE1-PW-VE1] quit
    [*NPE1] interface PW-VE 1.1
    [*NPE1-PW-VE1.1] encapsulation qinq-termination
    [*NPE1-PW-VE1.1] qinq termination pe-vid 100 ce-vid 100
    [*NPE1-PW-VE1.1] evpl instance 1
    [*NPE1-PW-VE1.1] commit

  7. Verify the configuration.

    Run the display bgp evpn all routing-table command on NPE2. The command output shows the EVI AD routes received from NPE1.

    [~NPE2] display bgp evpn all routing-table
     Local AS number : 100
    
     BGP Local router ID is 192.168.14.4
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     EVPN address family:
     Number of A-D Routes: 4
     Route Distinguisher: 1:1
           Network(ESI/EthTagId)                                  NextHop
     *>i   0011.1111.0000.0000.0000:100                        1.1.1.100
     Route Distinguisher: 1.1.1.100:0
           Network(ESI/EthTagId)                                  NextHop
     *>i   0011.1111.0000.0000.0000:4294967295                    1.1.1.100
     Route Distinguisher: 2.2.2.100:0
           Network(ESI/EthTagId)                                  NextHop
     *>    0011.1111.0000.0000.1111:4294967295                    127.0.0.1
     Route Distinguisher: 2.2.2.100:10
           Network(ESI/EthTagId)                                  NextHop
     *>    0011.1111.0000.0000.1111:200                           127.0.0.1
        
    
     EVPN-Instance evpna:
     Number of A-D Routes: 3
           Network(ESI/EthTagId)                                  NextHop
       i   0011.1111.0000.0000.0000:100                        1.1.1.100
       i   0011.1111.0000.0000.0000:4294967295                    1.1.1.100
     *>    0011.1111.0000.0000.1111:200                        127.0.0.1
    
     EVPN address family:
     Number of ES Routes: 2
     Route Distinguisher: 1.1.1.100:0
           Network(ESI)                                           NextHop
     *>i   0011.1111.0000.0000.0000                               1.1.1.100
     Route Distinguisher: 2.2.2.100:0
           Network(ESI)                                           NextHop
     *>    0011.1111.0000.0000.1111                               127.0.0.1
        
    
     EVPN-Instance evpna:
     Number of ES Routes: 2
           Network(ESI)                                           NextHop
       i   0011.1111.0000.0000.0000                               1.1.1.100
     *>    0011.1111.0000.0000.1111                               127.0.0.1

Configuration Files

  • NPE1 configuration file
    #
    sysname NPE1
    #
    evpn vpn-instance evpna vpws
     route-distinguisher 1:1
     vpn-target 10:10 export-extcommunity
     vpn-target 10:10 import-extcommunity
    #
    evpl instance 1 mpls-mode
     evpn binding vpn-instance evpna
     local-service-id 100 remote-service-id 200
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 31.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     ip address 192.168.14.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface LoopBack100
     ip address 1.1.1.100 255.255.255.255
    #
    interface PW-VE1
     esi 0011.1111.0000.0000.0000
     mpls l2vc 2.2.2.2 1
    #
    interface PW-VE1.1
     encapsulation qinq-termination
     qinq termination pe-vid 100 ce-vid 100
     evpl instance 1
    #
    bgp 100
     peer 2.2.2.100 as-number 100
     peer 2.2.2.100 connect-interface LoopBack100
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.100 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 2.2.2.100 enable
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 31.1.1.0 0.0.0.255
    #
    ospf 100
     area 0.0.0.1
      network 1.1.1.100 0.0.0.0
      network 192.168.14.0 0.0.0.255
    #
    evpn source-address 1.1.1.100
    #               
    return
  • UPE configuration file

    #
    sysname UPE
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls l2vpn      
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     mpls l2vc 1.1.1.1 1  
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 31.1.1.3 255.255.255.0
     mpls 
     mpls ldp
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 31.1.1.0 0.0.0.255
    #
    return
  • NPE2 configuration file

    #
    sysname NPE2
    #
    evpn vpn-instance evpna vpws
     route-distinguisher 2.2.2.100:10
     vpn-target 10:10 export-extcommunity
     vpn-target 10:10 import-extcommunity
    #
    evpl instance 1 mpls-mode
     evpn binding vpn-instance evpna
     local-service-id 200 remote-service-id 100
    #
    mpls lsr-id 2.2.2.100
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 192.168.14.4 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     esi 0011.1111.0000.0000.1111
    #
    interface GigabitEthernet0/1/2 mode l2
     encapsulation qinq vid 100 ce-vid 100
     evpl instance 1
    #
    interface LoopBack100
     ip address 2.2.2.100 255.255.255.255
    #
    bgp 100
     peer 1.1.1.100 as-number 100
     peer 1.1.1.100 connect-interface LoopBack100
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.100 enable
     #              
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.100 enable
    #
    ospf 100
     area 0.0.0.1
      network 2.2.2.100 0.0.0.0
      network 192.168.14.0 0.0.0.255
    #
    evpn source-address 2.2.2.100
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 31898

Downloads: 59

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next