No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VPN to Access a Common EVPN E-LAN

Example for Configuring a VPN to Access a Common EVPN E-LAN

This section provides an example for configuring a VPN to Access a Common EVPN E-LAN.

Networking Requirements

On the network shown in Figure 11-24, Site 1 and Site 2 reside on Layer 2 networks. To allow Site 1 and Site 2 to communicate over the backbone network, configure EVPN. Specifically, create EVPN instances on the PEs to store EVPN routes sent from CEs or remote PEs and configure an RR to reflect EVPN routes. To ensure high transmission efficiency, configure the All-Active redundancy mode on PE1 and PE2 to implement load balancing.

Figure 11-24 EVPN networking
NOTE:

Interfaces 1 through 3 in this example are GE 0/1/0, GE 0/2/0, and GE 0/3/0 respectively.

Functions, such as rapid convergence, split horizon, and DF election that are required in the EVPN dual-homing scenario fail to take effect in a single homing scenario. In such a scenario, configuring the ESI is optional on a dual-homing PE.



Precautions

When configuring a VPN to access a common EVPN E-LAN, note the following:

  • On the same EVPN, the export VPN target list of a site shares VPN targets with the import VPN target lists of the other sites; the import VPN target list of a site shares VPN targets with the export VPN target lists of the other sites.

  • It is recommended that you configure a PE's local loopback interface address as the EVPN source address.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on the backbone network to allow PEs and the RR to communicate.

  2. Configure basic MPLS functions and MPLS LDP, and establish MPLS LSPs on the backbone network.

  3. Configure an EVPN instance on each PE.

  4. Configure an EVPN source address on each PE.

  5. Bind each PE interface that connects to a CE to the EVPN instance.

  6. Configure an ESI for each PE interface that connects to a CE.

  7. Configure BGP EVPN peer relationships between PEs and the RR, and configure the PEs as RR clients.

  8. Configure a redundancy mode on PE1 and PE2.

  9. Configure CEs and PEs to communicate.

  10. Associate BFD sessions with the AC interfaces on PE1 and PE2 to accelerate DF switching during an AC link fault.

Data Preparation

To complete the configuration, you need the following data:

  • EVPN instance name (evpna)

  • EVPN instance RDs (100:1, 200:1, and 300:1) and RTs (1:1) on PEs

Procedure

  1. Assign an IP address to each interface on the RR and PEs according to Figure 11-24. For configuration details, see Configuration Files in this section.
  2. Configure an IGP on the backbone network to allow PEs and the RR to communicate. OSPF is used as the IGP in this example.

    # Configure PE1.

    [~PE1] ospf 1
    [*PE1-ospf-1] area 0
    [*PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*PE1-ospf-1-area-0.0.0.0] commit
    [~PE1-ospf-1-area-0.0.0.0] quit
    [~PE1-ospf-1] quit

    # Configure PE2.

    [~PE2] ospf 1
    [*PE2-ospf-1] area 0
    [*PE2-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*PE2-ospf-1-area-0.0.0.0] commit
    [~PE2-ospf-1-area-0.0.0.0] quit
    [~PE2-ospf-1] quit

    # Configure PE3.

    [~PE3] ospf 1
    [*PE3-ospf-1] area 0
    [*PE3-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*PE3-ospf-1-area-0.0.0.0] network 4.4.4.4 0.0.0.0
    [*PE3-ospf-1-area-0.0.0.0] commit
    [~PE3-ospf-1-area-0.0.0.0] quit
    [~PE3-ospf-1] quit

    # Configure the RR.

    [~RR] ospf 1
    [*RR-ospf-1] area 0
    [*RR-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*RR-ospf-1-area-0.0.0.0] commit
    [~RR-ospf-1-area-0.0.0.0] quit
    [~RR-ospf-1] quit

    After the configuration is complete, PE1, PE2, and PE3 can establish OSPF neighbor relationships with the RR. Run the display ospf peer command. The command output shows that State is Full. Run the display ip routing-table command. The command output shows that the RR and PEs have learned the routes to Loopback1 of each other.

    The following example uses the command output on PE1.

    [~PE1] display ospf peer
              OSPF Process 1 with Router ID 10.1.1.1
                    Neighbors
    
     Area 0.0.0.0 interface 10.1.1.1 (GE0/2/0)'s neighbors
     Router ID: 3.3.3.3          Address: 10.1.1.2
       State: Full      Mode:Nbr is Slave    Priority: 1
       DR: 10.1.1.1         BDR: 10.1.1.2         MTU: 0
       Dead timer due in  35  sec
       Retrans timer interval: 5
       Neighbor is up for 00h00m30s
       Authentication Sequence: [ 0 ]
    [~PE1] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 13       Routes : 13
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  Direct  0    0             D   127.0.0.1       LoopBack0
            2.2.2.2/32  OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
            3.3.3.3/32  OSPF    10   1             D   10.1.1.2        GigabitEthernet0/2/0
            4.4.4.4/32  OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
          10.1.1.0/24   Direct  0    0             D   10.1.1.1        GigabitEthernet0/2/0
          10.1.1.1/32   Direct  0    0             D   127.0.0.1       GigabitEthernet0/2/0
        10.1.1.255/32   Direct  0    0             D   127.0.0.1       GigabitEthernet0/2/0
          10.2.1.0/24   OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
          10.3.1.0/24   OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

  3. Configure basic MPLS functions, enable MPLS LDP, and establish LDP LSPs on the MPLS backbone network.

    # Configure PE1.

    [~PE1] mpls lsr-id 1.1.1.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface gigabitethernet 0/2/0
    [*PE1-GigabitEthernet0/2/0] mpls
    [*PE1-GigabitEthernet0/2/0] mpls ldp
    [*PE1-GigabitEthernet0/2/0] commit
    [~PE1-GigabitEthernet0/2/0] quit

    # Configure PE2.

    [~PE2] mpls lsr-id 2.2.2.2
    [*PE2] mpls
    [*PE2-mpls] quit
    [*PE2] mpls ldp
    [*PE2-mpls-ldp] quit
    [*PE2] interface gigabitethernet 0/2/0
    [*PE2-GigabitEthernet0/2/0] mpls
    [*PE2-GigabitEthernet0/2/0] mpls ldp
    [*PE2-GigabitEthernet0/2/0] commit
    [~PE2-GigabitEthernet0/2/0] quit

    # Configure the RR.

    [~RR] mpls lsr-id 3.3.3.3
    [*RR] mpls
    [*RR-mpls] quit
    [*RR] mpls ldp
    [*RR-mpls-ldp] quit
    [*RR] interface gigabitethernet 0/1/0
    [*RR-GigabitEthernet0/1/0] mpls
    [*RR-GigabitEthernet0/1/0] mpls ldp
    [*RR-GigabitEthernet0/1/0] quit
    [*RR] interface gigabitethernet 0/2/0
    [*RR-GigabitEthernet0/2/0] mpls
    [*RR-GigabitEthernet0/2/0] mpls ldp
    [*RR-GigabitEthernet0/2/0] quit
    [*RR] interface gigabitethernet 0/3/0
    [*RR-GigabitEthernet0/3/0] mpls
    [*RR-GigabitEthernet0/3/0] mpls ldp
    [*RR-GigabitEthernet0/3/0] commit
    [~RR-GigabitEthernet0/3/0] quit

    # Configure PE3.

    [~PE3] mpls lsr-id 4.4.4.4
    [*PE3] mpls
    [*PE3-mpls] quit
    [*PE3] mpls ldp
    [*PE3-mpls-ldp] quit
    [*PE3] interface gigabitethernet 0/1/0
    [*PE3-GigabitEthernet0/1/0] mpls
    [*PE3-GigabitEthernet0/1/0] mpls ldp
    [*PE3-GigabitEthernet0/1/0] commit
    [~PE3-GigabitEthernet0/1/0] quit

    After the configuration is complete, LDP sessions are established between PEs and the RR. Run the display mpls ldp session command. The command output shows that Status is Operational. Run the display mpls ldp lsp command. The command output shows LDP LSP configurations.

    The following example uses the command output on PE1.

    [~PE1] display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
    --------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge       KASent/Rcv
    --------------------------------------------------------------------------
     3.3.3.3:0          Operational DU   Passive  0000:00:00   5/4
    --------------------------------------------------------------------------
    TOTAL: 1 Session(s) Found.
    [~PE1] display mpls ldp lsp
     LDP LSP Information
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop          OutInterface
     -------------------------------------------------------------------------------
     1.1.1.1/32         3/NULL         3.3.3.3         127.0.0.1        Loop0
    *1.1.1.1/32         Liberal/32828                  DS/3.3.3.3
     2.2.2.2/32         NULL/32829     -               10.1.1.2         GE0/2/0
     2.2.2.2/32         32829/32829    3.3.3.3         10.1.1.2         GE0/2/0
     3.3.3.3/32         NULL/3         -               10.1.1.2         GE0/2/0
     3.3.3.3/32         32828/3        3.3.3.3         10.1.1.2         GE0/2/0
     4.4.4.4/32         NULL/32830     -               10.1.1.2         GE0/2/0
     4.4.4.4/32         32830/32830    3.3.3.3         10.1.1.2         GE0/2/0
     -------------------------------------------------------------------------------
     TOTAL: 7 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 FRR LSP(s) Found.
     A '*' before an LSP means the LSP is not established
     A '*' before a Label means the USCB or DSCB is stale
     A '*' before a UpstreamPeer means the session is stale
     A '*' before a DS means the session is stale
     A '*' before a NextHop means the LSP is FRR LSP
    An asterisk (*) before an LSP means the LSP is not established
     An asterisk (*) before a Label means the USCB or DSCB is stale
     An asterisk (*) before an UpstreamPeer means the session is stale
     An asterisk (*) before a DS means the session is stale
     An asterisk (*) before a NextHop means the LSP is FRR LSP
    

  4. Configure an EVPN instance on each PE.

    # Configure PE1.

    [~PE1] evpn vpn-instance evpna
    [*PE1-evpn-instance-evpna] route-distinguisher 100:1
    [*PE1-evpn-instance-evpna] vpn-target 1:1
    [*PE1-evpn-instance-evpna] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] evpn vpn-instance evpna
    [*PE2-evpn-instance-evpna] route-distinguisher 200:1
    [*PE2-evpn-instance-evpna] vpn-target 1:1
    [*PE2-evpn-instance-evpna] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] evpn vpn-instance evpna
    [*PE3-evpn-instance-evpna] route-distinguisher 300:1
    [*PE3-evpn-instance-evpna] vpn-target 1:1
    [*PE3-evpn-instance-evpna] quit
    [*PE3] commit

  5. Configure an EVPN source address on each PE.

    # Configure PE1.

    [~PE1] evpn source-address 1.1.1.1
    [*PE1] commit

    # Configure PE2.

    [~PE2] evpn source-address 2.2.2.2
    [*PE2] commit

    # Configure PE3.

    [~PE3] evpn source-address 4.4.4.4
    [*PE3] commit

  6. Configure an ESI for PE1 and PE2 interface that connects to a CE. (In this example, an ESI is dynamically generated. For details on how to configure a static ESI, see Configuring an ESI.)

    # Configure PE1.

    [~PE1] lacp e-trunk priority 1
    [*PE1] lacp e-trunk system-id 00E0-FC00-0000
    [*PE1] e-trunk 1
    [*PE1-e-trunk-1] priority 10
    [*PE1-e-trunk-1] peer-address 2.2.2.2 source-address 1.1.1.1
    [*PE1-e-trunk-1] quit
    [*PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] mode lacp-static
    [*PE1-Eth-Trunk10] e-trunk 1
    [*PE1-Eth-Trunk10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] lacp e-trunk priority 1
    [*PE2] lacp e-trunk system-id 00E0-FC00-0000
    [*PE2] e-trunk 1
    [*PE2-e-trunk-1] priority 20
    [*PE2-e-trunk-1] peer-address 1.1.1.1 source-address 2.2.2.2
    [*PE2-e-trunk-1] quit
    [*PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] mode lacp-static
    [*PE2-Eth-Trunk10] e-trunk 1
    [*PE2-Eth-Trunk10] quit
    [*PE2] commit

  7. Bind each PE interface that connects to a CE to the EVPN instance.

    # Configure PE1.

    [~PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] e-trunk mode force-master
    [*PE1-Eth-Trunk10] evpn binding vpn-instance evpna
    [*PE1-Eth-Trunk10] commit
    [~PE1-Eth-Trunk10] quit
    [~PE1] interface gigabitethernet 0/1/0
    [*PE1-GigabitEthernet0/1/0] eth-trunk 10
    [*PE1-GigabitEthernet0/1/0] commit
    [~PE1-GigabitEthernet0/1/0] quit

    # Configure PE2.

    [~PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] e-trunk mode force-master
    [*PE2-Eth-Trunk10] evpn binding vpn-instance evpna
    [*PE2-Eth-Trunk10] commit
    [~PE2-Eth-Trunk10] quit
    [~PE2] interface gigabitethernet 0/1/0
    [*PE2-GigabitEthernet0/1/0] eth-trunk 10
    [*PE2-GigabitEthernet0/1/0] commit
    [~PE2-GigabitEthernet0/1/0] quit

    # Configure PE3.

    [~PE3] interface gigabitethernet 0/2/0
    [*PE3-GigabitEthernet0/2/0] evpn binding vpn-instance evpna
    [*PE3-GigabitEthernet0/2/0] commit
    [~PE3-GigabitEthernet0/2/0] quit

  8. Configure BGP EVPN peer relationships between PEs and the RR, and configure the PEs as RR clients.

    # Configure PE1.

    [~PE1] bgp 100
    [*PE1-bgp] peer 3.3.3.3 as-number 100
    [*PE1-bgp] peer 3.3.3.3 connect-interface loopback 0
    [*PE1-bgp] l2vpn-family evpn
    [*PE1-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE1-bgp-af-evpn] quit
    [*PE1-bgp] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] bgp 100
    [*PE2-bgp] peer 3.3.3.3 as-number 100
    [*PE2-bgp] peer 3.3.3.3 connect-interface loopback 0
    [*PE2-bgp] l2vpn-family evpn
    [*PE2-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE2-bgp-af-evpn] quit
    [*PE2-bgp] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] bgp 100
    [*PE3-bgp] peer 3.3.3.3 as-number 100
    [*PE3-bgp] peer 3.3.3.3 connect-interface loopback 0
    [*PE3-bgp] l2vpn-family evpn
    [*PE3-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE3-bgp-af-evpn] quit
    [*PE3-bgp] quit
    [*PE3] commit

    # Configure the RR.

    [~RR] bgp 100
    [*RR-bgp] peer 1.1.1.1 as-number 100
    [*RR-bgp] peer 1.1.1.1 connect-interface loopback 0
    [*RR-bgp] peer 2.2.2.2 as-number 100
    [*RR-bgp] peer 2.2.2.2 connect-interface loopback 0
    [*RR-bgp] peer 4.4.4.4 as-number 100
    [*RR-bgp] peer 4.4.4.4 connect-interface loopback 0
    [*RR-bgp] l2vpn-family evpn
    [*RR-bgp-af-evpn] peer 1.1.1.1 enable
    [*RR-bgp-af-evpn] peer 1.1.1.1 reflect-client
    [*RR-bgp-af-evpn] peer 2.2.2.2 enable
    [*RR-bgp-af-evpn] peer 2.2.2.2 reflect-client
    [*RR-bgp-af-evpn] peer 4.4.4.4 enable
    [*RR-bgp-af-evpn] peer 4.4.4.4 reflect-client
    [*RR-bgp-af-evpn] quit
    [*RR-bgp] quit
    [*RR] commit

    After the configuration is complete, run the display bgp evpn peer command on the RR. The command output shows that BGP peer relationships have been established between the PEs and RR and are in the Established state.

    [~RR] display bgp evpn peer
     BGP local router ID : 3.3.3.3
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      1.1.1.1         4         100        5        4     0 00:00:26 Established        1
      2.2.2.2         4         100        5        4     0 00:00:27 Established        1
      4.4.4.4         4         100        8        4     0 00:00:28 Established        4

  9. Configure CEs and PEs to communicate.

    # Configure CE1.

    [~CE1] interface Eth-Trunk1
    [*CE1-Eth-Trunk1] mode lacp-static
    [*CE1-Eth-Trunk1] quit
    [*CE1] interface gigabitethernet0/1/0
    [*CE1-GigabitEthernet0/1/0] eth-trunk 1
    [*CE1-GigabitEthernet0/1/0] quit
    [*CE1] interface gigabitethernet0/2/0
    [*CE1-GigabitEthernet0/2/0] eth-trunk 1
    [*CE1-GigabitEthernet0/2/0] commit
    [~CE1-GigabitEthernet0/2/0] quit
    NOTE:

    If PE1 and PE2 work in Single-Active redundancy mode, GE 0/1/0 and GE 0/2/0 on CE1 must join different Eth-Trunk interfaces.

    # Configure CE2.

    [~CE2] interface Eth-Trunk1
    [*CE2-Eth-Trunk1] quit
    [*CE2] interface gigabitethernet0/1/0
    [*CE2-GigabitEthernet0/1/0] eth-trunk 1
    [*CE2-GigabitEthernet0/1/0] commit
    [~CE2-GigabitEthernet0/1/0] quit

  10. Associate BFD sessions with the AC interfaces on PE1 and PE2 to accelerate DF switching during an AC link fault.

    # Configure PE1.

    [~PE1] bfd
    [*PE1-bfd] quit
    [*PE1] bfd bfd1 bind peer-ip 2.2.2.2 track-interface interface Eth-Trunk10
    [*PE1-bfd-session-bfd1] discriminator local 10
    [*PE1-bfd-session-bfd1] discriminator remote 20
    [*PE1-bfd-session-bfd1] quit
    [*PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] es track bfd bfd1
    [*PE1-Eth-Trunk10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] bfd
    [*PE2-bfd] quit
    [*PE2] bfd bfd1 bind peer-ip 1.1.1.1 track-interface interface Eth-Trunk10
    [*PE2-bfd-session-bfd1] discriminator local 20
    [*PE2-bfd-session-bfd1] discriminator remote 10
    [*PE2-bfd-session-bfd1] quit
    [*PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] es track bfd bfd1
    [*PE2-Eth-Trunk10] quit
    [*PE2] commit

  11. Verify the configuration.

    Run the display bgp evpn all routing-table mac-route command on PE3. The command output shows MAC/IP advertisement routes destined for CE1.

    [~PE3] display bgp evpn all routing-table mac-route
    
     Local AS number : 100
    
     BGP Local router ID is 4.4.4.4
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     EVPN address family:
     Number of Mac Routes: 2
    
     Route Distinguisher: 100:1
           Network(EthTagId/MacAddrLen/MacAddr/IpAddrLen/IpAddr)  NextHop
     *>i   1:48:0001-0001-0001:0:0.0.0.0                          1.1.1.1
    
     Route Distinguisher: 200:1
           Network(EthTagId/MacAddrLen/MacAddr/IpAddrLen/IpAddr)  NextHop
     *>i   1:48:0001-0001-0001:0:0.0.0.0                          2.2.2.2
    
    
     EVPN-Instance evpna:
     Number of Mac Routes: 2
           Network(EthTagId/MacAddrLen/MacAddr/IpAddrLen/IpAddr)  NextHop
     *>i   1:48:0001-0001-0001:0:0.0.0.0                          1.1.1.1
     * i                                                          2.2.2.2

    Run the display bgp evpn all routing-table mac-route mac-route command on PE3. The command output shows that MAC/IP advertisement routes destined for CE1 work in load balancing mode.

    [~PE3] display bgp evpn all routing-table mac-route 1:48:0001-0001-0001:0:0.0.0.0
    
     BGP local router ID : 4.4.4.4
     Local AS number : 100
    
     Total routes of Route Distinguisher(100:1): 1
     BGP routing table entry information of 1:48:0001-0001-0001:0:0.0.0.0:
     Label information (Received/Applied): 32831/NULL
     From: 3.3.3.3 (3.3.3.3)
     Route Duration: 0d00h26m50s
     Relay IP Nexthop: 10.3.1.1
     Relay Tunnel Out-Interface: LDP LSP
     Original nexthop: 1.1.1.1
     Qos information : 0x0
     Ext-Community:RT <1 : 1>
     AS-path Nil, origin incomplete, localpref 100, pref-val 0, valid, internal, best, select, pre 255
     Originator: 10.1.1.1
     Cluster list: 3.3.3.3
     Route Type: 2 (MAC Advertisement Route)
     Ethernet Tag ID: 1, MAC Address/Len: 0001-0001-0001/48, IP Address/Len: 0.0.0.0/0, ESI:0138.ba56.b790.0201.2100
     Not advertised to any peer yet
    
    
     Total routes of Route Distinguisher(200:1): 1
     BGP routing table entry information of 1:48:0001-0001-0001:0:0.0.0.0:
     Label information (Received/Applied): 32831/NULL
     From: 3.3.3.3 (3.3.3.3)
     Route Duration: 0d00h20m28s
     Relay IP Nexthop: 10.3.1.1
     Relay Tunnel Out-Interface: LDP LSP
     Original nexthop: 2.2.2.2
     Qos information : 0x0
     Ext-Community:RT <1 : 1>
     AS-path Nil, origin incomplete, localpref 100, pref-val 0, valid, internal, best, select, pre 255
     Originator: 10.2.1.1
     Cluster list: 3.3.3.3
     Route Type: 2 (MAC Advertisement Route)
     Ethernet Tag ID: 1, MAC Address/Len: 0001-0001-0001/48, IP Address/Len: 0.0.0.0/0, ESI:0138.ba56.b790.0201.2100
     Not advertised to any peer yet
    
    
    
     EVPN-Instance evpna:
     BGP routing table entry information of 1:48:0001-0001-0001:0:0.0.0.0:
     Remote-Cross route
     Label information (Received/Applied): 32831/NULL
     From: 3.3.3.3 (3.3.3.3)
     Route Duration: 0d00h26m51s
     Relay Tunnel Out-Interface: LDP LSP
     Original nexthop: 1.1.1.1
     Qos information : 0x0
     Ext-Community:RT <1 : 1>
     AS-path Nil, origin incomplete, localpref 100, pref-val 0, valid, internal, best, select, pre 255
     Originator: 10.1.1.1
     Cluster list: 3.3.3.3
     Route Type: 2 (MAC Advertisement Route)
     Ethernet Tag ID: 1, MAC Address/Len: 0001-0001-0001/48, IP Address/Len: 0.0.0.0/0, ESI:0138.ba56.b790.0201.2100
     Not advertised to any peer yet
    
     BGP routing table entry information of 1:48:0001-0001-0001:0:0.0.0.0:
     Remote-Cross route
     Label information (Received/Applied): 32831/NULL
     From: 3.3.3.3 (3.3.3.3)
     Route Duration: 0d00h20m29s
     Relay Tunnel Out-Interface: LDP LSP
     Original nexthop: 2.2.2.2
     Qos information : 0x0
     Ext-Community:RT <1 : 1>
     AS-path Nil, origin incomplete, localpref 100, pref-val 0, valid, internal, select, pre 255, not preferred for router ID
     Originator: 10.2.1.1
     Cluster list: 3.3.3.3
     Route Type: 2 (MAC Advertisement Route)
     Ethernet Tag ID: 1, MAC Address/Len: 0001-0001-0001/48, IP Address/Len: 0.0.0.0/0, ESI:0138.ba56.b790.0201.2100
     Not advertised to any peer yet

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    evpn vpn-instance evpna
     route-distinguisher 100:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    e-trunk 1
     priority 10
     peer-address 2.2.2.2 source-address 1.1.1.1
    #
    interface Eth-Trunk10
     mode lacp-static
     e-trunk 1
     e-trunk mode force-master
     evpn binding vpn-instance evpna
     es track bfd bfd1
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     eth-trunk 10
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bfd bfd1 bind peer-ip 2.2.2.2 track-interface interface Eth-Trunk10
     discriminator local 10
     discriminator remote 20
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    evpn source-address 1.1.1.1
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    evpn vpn-instance evpna
     route-distinguisher 200:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    e-trunk 1
     priority 20
     peer-address 1.1.1.1 source-address 2.2.2.2
    #
    interface Eth-Trunk10
     mode lacp-static
     e-trunk 1
     e-trunk mode force-master
     evpn binding vpn-instance evpna
     es track bfd bfd1
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     eth-trunk 10
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bfd bfd1 bind peer-ip 1.1.1.1 track-interface interface Eth-Trunk10
     discriminator local 20
     discriminator remote 10
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    evpn source-address 2.2.2.2
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    evpn vpn-instance evpna
     route-distinguisher 300:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     evpn binding vpn-instance evpna
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.3.1.0 0.0.0.255
    #
    evpn source-address 4.4.4.4
    #
    return
  • RR configuration file

    #
    sysname RR
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 10.3.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #
     l2vpn-family evpn
      peer 1.1.1.1 enable
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 reflect-client
      peer 4.4.4.4 enable
      peer 4.4.4.4 reflect-client
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
  • CE1 configuration file

    #
    sysname CE1
    #
    interface Eth-Trunk1
     mode lacp-static
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     eth-trunk 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     eth-trunk 1
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    interface Eth-Trunk1
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     eth-trunk 1
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 27345

Downloads: 53

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next