No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Static VPLS

Example for Configuring Static VPLS

This section provides an example for configuring static VPLS.

Networking Requirements

On the network shown in Figure 9-19, VPLS is enabled on PE1 and PE2. CE1 connects to PE1, CE2 connects to PE2, and CE1 and CE2 reside on the same VPLS network. If PE1 and PE2 are unable to support large numbers of LDP sessions or you want to manually manage and allocate VC labels, configure a static VPLS PW for CE1 and CE2 to communicate.

Figure 9-19 Networking diagram for configuring static VPLS
NOTE:
  • Interface1, subinterface1.1, inerface2 and subinterface2.1 in this example are GE 0/1/0, GE0/1/0.1, GE0/2/0 and GE0/2/0.1, respectively.



Precautions

PEs belonging to the same L2VPN must have the same VSI ID.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol on the backbone network so that devices can communicate.

  2. Establish an MPLS tunnel between the PEs to transmit service data.

  3. Enable MPLS L2VPN on the PEs.

  4. Create a VSI on each PE, configure static VPLS, and bind the VSI to the AC interface.

Data Preparation

To complete the configuration, you need the following data:

  • VSI name and ID

  • Peer IP addresses and the tunnel policy used for establishing peer relationships

  • AC interface names

Procedure

  1. Assign an IP address to each interface on PEs and the P shown in Figure 9-19 and configure an IGP. This example uses OSPF as the IGP.

    When configuring OSPF, be sure to advertise the 32-bit loopback interface addresses of PE1, PE2, and the P. These loopback interface addresses serve as the LSR IDs of these routers.

    For details, see "Configuration Files" in this section.

    After the configuration is complete, run the display ip routing-table command on PEs and the P. The command output shows the routes that the devices have learned from each other.

  2. Configure basic MPLS functions and LDP.

    For details, see "Configuration Files" in this section.

    After the configuration is complete, run the display mpls ldp session command on PEs and the P. The command output shows that Status of the peer relationships between PE1 and the P and between PE2 and the P is Operational, which indicates that the peer relationships have been established. You can run the display mpls lsp command to check whether the LSP has been established.

  3. Enable MPLS L2VPN on PEs.

    # Configure PE1.

    [~PE1] mpls l2vpn
    [*PE1-l2vpn] commit

    # Configure PE2.

    [*PE2] mpls l2vpn
    [*PE2-l2vpn] commit

  4. Configure a VSI on each PE.

    # Configure PE1.

    [~PE1] vsi a2
    [*PE1-vsi-a2] pwsignal ldp
    [*PE1-vsi-a2-ldp] vsi-id 2
    [*PE1-vsi-a2-ldp] peer 3.3.3.9 static-upe trans 100 recv 100
    [*PE1-vsi-a2-ldp] quit
    [*PE1-vsi-a2] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] vsi a2
    [*PE2-vsi-a2] pwsignal ldp
    [*PE2-vsi-a2-ldp] vsi-id 2
    [*PE2-vsi-a2-ldp] peer 1.1.1.9 static-upe trans 100 recv 100
    [*PE2-vsi-a2-ldp] quit
    [*PE2-vsi-a2] quit
    [*PE2] commit

  5. Bind the VSI on each PE to the AC interface on the PE.

    # Configure PE1.

    [~PE1] interface gigabitethernet0/1/0.1
    [*PE1-GigabitEthernet0/1/0.1] shutdown
    [*PE1-GigabitEthernet0/1/0.1] vlan-type dot1q 10
    [*PE1-GigabitEthernet0/1/0.1] l2 binding vsi a2
    [*PE1-GigabitEthernet0/1/0.1] undo shutdown
    [*PE1-GigabitEthernet0/1/0.1] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] interface gigabitethernet0/2/0.1
    [*PE2-GigabitEthernet0/2/0.1] shutdown
    [*PE2-GigabitEthernet0/2/0.1] vlan-type dot1q 10
    [*PE2-GigabitEthernet0/2/0.1] l2 binding vsi a2
    [*PE2-GigabitEthernet0/2/0.1] undo shutdown
    [*PE2-GigabitEthernet0/2/0.1] quit
    [*PE2] commit

  6. Configure the CEs.

    # Configure CE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] interface gigabitethernet0/1/0.1
    [*CE1-GigabitEthernet0/1/0.1] vlan-type dot1q 10
    [*CE1-GigabitEthernet0/1/0.1] ip address 10.1.1.1 255.255.255.0
    [*CE1-GigabitEthernet0/1/0.1] quit
    [*CE1] commit

    # Configure CE2.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE2
    [*HUAWEI] commit
    [~CE2] interface gigabitethernet0/1/0.1
    [*CE2-GigabitEthernet0/1/0.1] vlan-type dot1q 10
    [*CE2-GigabitEthernet0/1/0.1] ip address 10.1.1.2 255.255.255.0
    [*CE2-GigabitEthernet0/1/0.1] quit
    [*CE2] commit

  7. Verify the configuration.

    After the configuration is complete, run the display vsi name a2 verbose command on PE1. The command output shows that the VSI named a2 has established a PW with PE2, and the VSI status is Up.

    [~PE1] display vsi name a2 verbose
     ***VSI Name               : a2
        Administrator VSI      : no
        Isolate Spoken         : disable
        VSI Index              : 1
        PW Signaling           : --
        Member Discovery Style : --
        Bridge-domain Mode     : disable
        PW MAC Learning Style  : unqualify
        Encapsulation Type     : vlan
        MTU                    : 1500
        Diffserv Mode          : uniform
        Service Class          : --
        Color                  : --
        DomainId               : 255
        Domain Name            :
        Ignore AcState         : disable
        P2P VSI                : disable
        Multicast Fast Swicth  : disable
        Create Time            : 0 days, 0 hours, 7 minutes, 10 seconds
        VSI State              : up
    
        VSI ID                 : 2
       *Peer Router ID         : 3.3.3.9
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 100
        Peer Type              : static
        Session                : up
        Tunnel ID              : 0x0000000001004c4b44
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : --
        CKey                   : 1
        NKey                   : 1610612838
        Stp Enable             : 0
        PwIndex                : 0
    
        Interface Name         : GigabitEthernet0/1/0.1
        State                  : up
        Access Port            : false
        Last Up Time           : 2012/09/10 10:14:46
        Total Up Time          : 0 days, 0 hours, 2 minutes, 14 seconds
    
      **PW Information:
    
       *Peer Ip Address        : 3.3.3.9
        PW State               : up
        Local VC Label         : 100
        Remote VC Label        : 100
        PW Type                : MEHVPLS
        Tunnel ID              : 0x0000000001004c4b44
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : --
        Ckey                   : 1
        Nkey                   : 1610612838
        Main PW Token          : 0x0
        Slave PW Token         : 0x0
        Tnl Type               : ldp
        OutInterface           : GigabitEthernet0/2/0
        Backup OutInterface    : --
        Stp Enable             : 0
        Mac Flapping           : 0
        PW Last Up Time        : 2012/09/10 10:16:03
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 19 seconds 

    # CE1 at 10.1.1.1 can ping CE2 at 10.1.1.2.

    <CE1> ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=90 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=77 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=34 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=46 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=94 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/68/94 ms 

Configuration Files

  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet0/1/0.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.1.1.1 255.255.255.0
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet0/1/0.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.1.1.2 255.255.255.0
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
     mpls l2vpn
    #
    vsi a2
     pwsignal ldp 
      vsi-id 2    
      peer 3.3.3.9 static-upe trans 100 recv 100
    # 
    mpls ldp
    #
    interface GigabitEthernet0/1/0.1
     undo shutdown
     vlan-type dot1q 10
     l2 binding vsi a2
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 192.168.10.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 192.168.10.0 0.0.0.255
    #
    return
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.10.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.20.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.20.0 0.0.0.255
      network 2.2.2.9 0.0.0.0
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
     mpls lsr-id 3.3.3.9
     mpls
    #
     mpls l2vpn
    #
    vsi a2
     pwsignal ldp  
      vsi-id 2     
      peer 1.1.1.9 static-upe trans 100 recv 100
    # 
    mpls ldp
    # 
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.20.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0.1
     undo shutdown
     vlan-type dot1q 10
     l2 binding vsi a2
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 192.168.20.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 27804

Downloads: 53

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next