No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring TDMoPSN

Example for Configuring TDMoPSN

Time Division Multiplex (TDM) transparent frame transport provides a new choice for wireless operators. By means of TDM transparent frame transport, services between the BTSs and BSCs in the same city can be transparently transmitted in a Metro Ethernet (ME) network. Data of the fractional E1 interface can be transmitted from the GSM BTS to BSC in the mode of structuralized TDM circuit emulation.

Networking Requirements

Generally, on a 2G RAN, one to three E1 interfaces on a BTS are connected to a BSC. Some mobile operators do not own fixed network infrastructure, and have to rent E1 lines from fixed-line network operators at a high price. By deploying TDMoPSN service, that is, TDM transparent transmission on a 2G RAN, these mobile operators can achieve transparent transmission of 2G services between the BTSs and BSCs in the same city over TDM links in a Metro Ethernet (ME) network, which is both simple and cost-saving.

On the network shown in Figure 7-39, it is required that the BTS and PE1 be connected through two E1 links, and the BSC and PE2 be connected through the CPOS interface. On the channelized serial interface of E1 links, the encapsulation protocol is configured as TDM. Then, a PW is set up between PE1 and PE2 to transparently transmit TDM frames.

Figure 7-39 Networking diagram of configuring TDMoPSN
NOTE:
  • Interface1, Interface2, and Interface3 in this example are GE 0/1/0, GE 0/2/0, and CPOS0/3/0, respectively.


Router

Interface

IP Address

PE1

GE 0/1/0

Loopback0

10.1.1.1/24

192.168.2.2/32

P

GE 0/1/0

GE 0/2/0

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE 0/2/0

Loopback0

10.2.1.2/24

192.168.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Run an IGP on the backbone network so that devices can communicate with each other.

  2. Configure basic MPLS functions on the backbone network, and configure MPLS L2VPN functions on PEs. Establish the remote MPLS LDP peer relationship between PEs at both ends of the PW.

  3. Configure parameters for the TDM interface.

  4. Configure the PW template.

  5. Establish MPLS L2VC connections on PEs.

Data Preparation

To complete the configuration, you need the following data:

  • Same L2VC ID at both ends of the PW
  • MPLS LSR IDs of the PEs and P router
  • IP addresses assigned to the remote peers of PEs
  • Coding mode and frame format of the E1/CE1 interface

Procedure

  1. Run an IGP on the backbone network so that devices can communicate with each other. For configuration details, see Configuration Files in this section.
  2. Configure basic MPLS functions on the backbone network, and configure MPLS L2VPN functions on PEs. Then, establish the remote MPLS LDP peer relationship between PEs at both ends of the PW. For configuration details, see Configuration Files in this section.

    The remote MPLS LDP peer relationship is required only for the dynamic PW.

  3. Configure parameters for the TDM interface.

    1. Configure PE1.

      # Configure the channelized mode, AMI code, and CRC4 frames for CE1 0/2/11 and CE1 0/2/2 on PE1.

      [~PE1] controller e1 0/2/1
      [*PE1-E1 0/2/1] using ce1
      [*PE1-E1 0/2/1] code ami
      [*PE1-E1 0/2/1] frame-format crc4
      [*PE1-E1 0/2/1] channel-set 1 timeslot-list 1-15
      [*PE1-E1 0/2/1] commit
      [~PE1-E1 0/2/1] quit
      [~PE1] controller e1 0/2/2
      [~PE1-E1 0/2/2] using ce1
      [*PE1-E1 0/2/2] code ami
      [*PE1-E1 0/2/2] frame-format crc4
      [*PE1-E1 0/2/2] channel-set 1 timeslot-list 16-31
      [*PE1-E1 0/2/2] commit
      [~PE1-E1 0/2/2] quit
      
    2. Configure PE2.

      # Set parameters for the CPOS interface on PE2.

      [~PE2] controller cpos 0/3/1
      [~PE2-Cpos0/3/1] e1 1 channel-set 1 timeslot-list 1-15
      [*PE2-Cpos0/3/1] e1 2 channel-set 2 timeslot-list 16-31
      [*PE2-Cpos0/3/1] quit
      [*PE2] commit

  4. Configure the encapsulation protocol on the serial interface as TDM.

    1. Configure PE1.

      [~PE1] interface serial0/2/1:1
      [~PE1-Serial0/2/1:1] link-protocol tdm
      [*PE1-Serial0/2/1:1] commit
      [~PE1-Serial0/2/1:1] quit
      [~PE1] interface serial0/2/2:1
      [~PE1-Serial0/2/2:1] link-protocol tdm
      [*PE1-Serial0/2/2:1] commit
      [*PE1-Serial0/2/2:1] quit
      
    2. Configure PE2.

      [~PE2] interface serial0/3/1:1
      [~PE2-Serial0/3/1:1] link-protocol tdm
      [*PE2-Serial0/3/1:1] commit
      [~PE2-Serial0/3/1:1] quit
      [~PE2] interface serial0/3/1:2
      [~PE2-Serial0/3/1:2] link-protocol tdm
      [*PE2-Serial0/3/1:2] commit
      [~PE2-Serial0/3/1:2] quit
      

  5. Configuring the PW.

    1. Configure PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 20
      [*PE1-pw-template-1to3] tdm-encapsulation-number 40
      [*PE1-pw-template-1to3] idle-code 33
      [*PE1-pw-template-1to3] commit
      [~PE1-pw-template-1to3] quit
      [~PE1] interface serial0/2/1:1
      [~PE1-Serial0/2/1:1] mpls l2vc pw-template 1to3 100
      [*PE1-Serial0/2/1:1] commit
      [*PE1] interface serial0/2/2:1
      [*PE1-Serial0/2/2:1] commit
      [*PE1-Serial0/2/2:1] mpls l2vc pw-template 1to3 200
      
    2. Configure PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 20
      [*PE2-pw-template-3to1] tdm-encapsulation-number 40
      [*PE2-pw-template-3to1] idle-code 33
      [*PE2-pw-template-3to1] commit
      [~PE2-pw-template-3to1] quit
      [~PE2] interface serial0/3/1:1
      [~PE2-Serial0/3/1:1] mpls l2vc pw-template 3to1 100
      [*PE2-Serial0/3/1:1] undo shutdown
      [*PE2-Serial0/3/1:1] commit
      [~PE2-Serial0/3/1:1] quit
      [~PE2] interface serial0/3/1:2
      [*PE2-Serial0/3/1:2] mpls l2vc pw-template 3to1 200
      [*PE2-Serial0/3/1:2] undo shutdown
      [*PE2-Serial0/3/1:2] commit
      [*PE2-Serial0/3/1:2] quit
      

  6. Verify the configuration.

    Run the display mpls l2vc command on PEs. You can view that the status of the PW is Up.

    The following example uses the command output on PE1.

    <~PE1> display mpls l2vc interface serial0/2/1:1
    *client interface       : Serial0/2/1:1 is up
      session state          : up
      AC status              : up
      VC state               : up
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0 
      remote group ID        : 0
      local VC label         : 146432
      remote VC label        : 145287
      TDM encapsulation number : 40
      jitter-buffer            : 20
      idle-code                : 33
      rtp-header               : disable
      local AC OAM State     : up
      local PSN State        : up
      local forwarding state : forwarding
      local status code      : 0x0
      remote AC OAM state    : up
      remote PSN state       : up
      remote forwarding state: forwarding
      remote statuscode      : 0x0   
      BFD for PW             : unavailable
      manual fault           : not set
      active state           : active
      forwarding entry       : not exist
      link state             : up
      local VC MTU           : 1500
      remote VC MTU          : 1500
      local VCCV             : alert lsp-ping bfd
      remote VCCV            : none
      local control word     : disable
      remote control word    : disable
      tunnel policy name     : --
      traffic behavior name  : --
      PW template name       : --
      primary or secondary   : primary
      VC tunnel/token info  : 1 tunnels/tokens
      NO.0 TNL type : lsp , TNL ID : 0x208000
      create time            : 0 days, 4 hours, 48 minutes, 51 seconds
      up time                : 0 days, 3 hours, 43 minutes, 49 seconds
      last change time       : 0 days, 0 hours, 39 minutes, 29 seconds
      VC last up time        : 2008/12/26 12:02:49
      VC total up time       : 0 days, 3 hours, 43 minutes, 49 seconds
      CKey                   : 11
      NKey                   : 10
      PW redundancy mode     : frr
      AdminPw interface      : --
      AdminPw link state     : --
      Forward state          : send inactive, receive inactive 
      Diffserv Mode          : uniform
      Service Class          : --
      Color                  : --
      DomainId               : --
      Domain Name            : --
    

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 20
     tdm-encapsulation-number 40
     idle-code 33
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    controller e1 0/2/1
    using ce1
    code ami
    frame-format crc4
    channel-set 1 timeslot-list 1-15
    undo shutdown
    #
    controller e1 0/2/2
    using ce1
    code ami
    frame-format crc4
    channel-set 1 timeslot-list 16-31
    undo shutdown
    #
    interface serial0/2/1:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 100
    undo shutdown
    #
    interface serial0/2/2:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 200
    undo shutdown
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 20
     tdm-encapsulation-number 40
     idle-code 33
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    controller cpos 0/3/1
    e1 1 channel-set 1 timeslot-list 1-15
    e1 2 channel-set 1 timeslot-list 16-31
    #
    interface serial0/3/1:1
    link-protocol tdm
    mpls l2vc pw-template 3to1 100
    undo shutdown
    #
    interface serial0/3/1:2
    link-protocol tdm
    mpls l2vc pw-template 3to1 200
    undo shutdown
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 28190

Downloads: 53

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next