No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Eth-Trunk Sub-interfaces to Access a Common EVPN E-LAN in Active-Active Mode

Example for Configuring Eth-Trunk Sub-interfaces to Access a Common EVPN E-LAN in Active-Active Mode

This section provides an example for configuring EVPN with a CEdual-homed to PEs through Eth-Trunk sub-interfaces.

Networking Requirements

On the network shown in Figure 11-25, Site1 and Site2 reside on Layer 2 networks. To allow Site1 and Site2 to communicate over the backbone network, configure EVPN functions. Specifically, create EVPN instances on the PEs to store EVPN routes sent from CEs or remote PEs and configure a route reflector (RR) to reflect EVPN routes. To have the BUM traffic balanced along the links between CE1 and PE1 and between CE1 and PE2, configure Eth-Trunk sub-interfaces on PE1 and PE2 to connect to CE1 and then configure VLAN-based DF election.

To improve reliability for the EVPN, configure also the following functions in this example:
  • Function that the AC status influences DF election

  • EVPN BGP peer status tracking

  • Delay after which ES routes are advertised

  • Per-ES AD route division based on RTs

Figure 11-25 EVPN networking
NOTE:

Interface1, interface2, and interface3 stand for Ethernet0/1/0, Ethernet0/2/0, and Ethernet0/3/0, respectively.

In a single-homing scenario, fast convergence, split horizon, and DF election required in a dual-homing scenario do not take effect. Therefore, configuring an ESI in a single-homing scenario is optional.



Precautions

When configuring Eth-Trunk sub-interfaces to access a common EVPN E-LAN in active-active mode, note the following:

  • On the same EVPN, the export VPN target list of a site shares VPN targets with the import VPN target lists of the other sites; the import VPN target list of a site shares VPN targets with the export VPN target lists of the other sites.

  • Using the local loopback interface address of a PE as the source address is recommended.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on the backbone network to allow PEs and the RR to communicate.

  2. Configure basic MPLS functions and MPLS LDP, and establish MPLS LSPs on the backbone network.

  3. Configure EVPN instances on the PEs.

  4. Configure a source address on each PE.

  5. Configure each PE's sub-interface connecting to a CE.

  6. Bind each PE's sub-interface connecting to a CE to an EVPN instance on each PE.

  7. Configure an ESI for each PE interface connecting to a CE.

  8. Configure EVPN BGP peer relationships between PEs and the RR, and configure the PEs as RR clients.

  9. Configure CEs and PEs to communicate.

  10. Configure VLAN-based DF election and the function that the AC status influences DF election.

  11. Configure EVPN BGP peer status tracking and set a delay after which ES routes are advertised.

  12. Associate BFD sessions with the AC interfaces on PE1 and PE2 to accelerate DF switching during an AC link fault.

Data Preparation

To complete the configuration, you need the following data:

  • EVPN instance name (evpna and evpnb)

  • EVPN instance evpna's RDs (100:1, 200:1, and 300:1) and RTs (1:1) on PEs EVPN instance evpnb's RDs (100:2, 200:2, 300:2) and RTs (2:2) on PEs

Procedure

  1. Assign an IP address to each interface on the RR and PEs according to Figure 11-25. For configuration details, see Configuration Files in this section.
  2. Configure an IGP on the backbone network to allow PEs and the RR to communicate. OSPF is used as the IGP in this example.

    # Configure PE1.

    [~PE1] ospf 1
    [*PE1-ospf-1] area 0
    [*PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*PE1-ospf-1-area-0.0.0.0] commit
    [~PE1-ospf-1-area-0.0.0.0] quit
    [~PE1-ospf-1] quit

    # Configure PE2.

    [~PE2] ospf 1
    [*PE2-ospf-1] area 0
    [*PE2-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*PE2-ospf-1-area-0.0.0.0] commit
    [~PE2-ospf-1-area-0.0.0.0] quit
    [~PE2-ospf-1] quit

    # Configure PE3.

    [~PE3] ospf 1
    [*PE3-ospf-1] area 0
    [*PE3-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*PE3-ospf-1-area-0.0.0.0] network 4.4.4.4 0.0.0.0
    [*PE3-ospf-1-area-0.0.0.0] commit
    [~PE3-ospf-1-area-0.0.0.0] quit
    [~PE3-ospf-1] quit

    # Configure the RR.

    [~RR] ospf 1
    [*RR-ospf-1] area 0
    [*RR-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*RR-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*RR-ospf-1-area-0.0.0.0] commit
    [~RR-ospf-1-area-0.0.0.0] quit
    [~RR-ospf-1] quit

    After completing the configurations, PE1, PE2, and PE3 can establish OSPF neighbor relationships with the RR. Run the display ospf peer command. The command output shows that State is Full. Run the display ip routing-table command. The command output shows that the RR and PEs have learned the routes to Loopback1 of each other.

    The following example uses the command output on PE1.

    [~PE1] display ospf peer
    (M) Indicates MADJ neighbor
    
    
              OSPF Process 1 with Router ID 1.1.1.1
                    Neighbors
    
     Area 0.0.0.0 interface 10.1.1.1 (Eth0/2/0)'s neighbors
     Router ID: 3.3.3.3              Address: 10.1.1.2         
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: 10.1.1.1          BDR: 10.1.1.2          MTU: 0
       Dead timer due in  38  sec
       Retrans timer interval: 5
       Neighbor is up for 00h01m12s
       Authentication Sequence: [ 0 ]
    [~PE1] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 13       Routes : 13
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  Direct  0    0             D   127.0.0.1       LoopBack0
            2.2.2.2/32  OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
            3.3.3.3/32  OSPF    10   1             D   10.1.1.2        GigabitEthernet0/2/0
            4.4.4.4/32  OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
          10.1.1.0/24   Direct  0    0             D   10.1.1.1        GigabitEthernet0/2/0
          10.1.1.1/32   Direct  0    0             D   127.0.0.1       GigabitEthernet0/2/0
        10.1.1.255/32   Direct  0    0             D   127.0.0.1       GigabitEthernet0/2/0
          10.2.1.0/24   OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
          10.3.1.0/24   OSPF    10   2             D   10.1.1.2        GigabitEthernet0/2/0
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

  3. Configure basic MPLS functions, enable MPLS LDP, and establish LDP LSPs on the MPLS backbone network.

    # Configure PE1.

    [~PE1] mpls lsr-id 1.1.1.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface ethernet 0/2/0
    [*PE1-Ethernet0/2/0] mpls
    [*PE1-Ethernet0/2/0] mpls ldp
    [*PE1-Ethernet0/2/0] commit
    [~PE1-Ethernet0/2/0] quit

    # Configure PE2.

    [~PE2] mpls lsr-id 2.2.2.2
    [*PE2] mpls
    [*PE2-mpls] quit
    [*PE2] mpls ldp
    [*PE2-mpls-ldp] quit
    [*PE2] interface ethernet 0/2/0
    [*PE2-Ethernet0/2/0] mpls
    [*PE2-Ethernet0/2/0] mpls ldp
    [*PE2-Ethernet0/2/0] commit
    [~PE2-Ethernet0/2/0] quit

    # Configure the RR.

    [~RR] mpls lsr-id 3.3.3.3
    [*RR] mpls
    [*RR-mpls] quit
    [*RR] mpls ldp
    [*RR-mpls-ldp] quit
    [*RR] interface ethernet 0/1/0
    [*RR-Ethernet0/1/0] mpls
    [*RR-Ethernet0/1/0] mpls ldp
    [*RR-Ethernet0/1/0] quit
    [*RR] interface ethernet 0/2/0
    [*RR-Ethernet0/2/0] mpls
    [*RR-Ethernet0/2/0] mpls ldp
    [*RR-Ethernet0/2/0] quit
    [*RR] interface ethernet 0/3/0
    [*RR-Ethernet0/3/0] mpls
    [*RR-Ethernet0/3/0] mpls ldp
    [*RR-Ethernet0/3/0] commit
    [~RR-Ethernet0/3/0] quit

    # Configure PE3.

    [~PE3] mpls lsr-id 4.4.4.4
    [*PE3] mpls
    [*PE3-mpls] quit
    [*PE3] mpls ldp
    [*PE3-mpls-ldp] quit
    [*PE3] interface ethernet 0/1/0
    [*PE3-Ethernet0/1/0] mpls
    [*PE3-Ethernet0/1/0] mpls ldp
    [*PE3-Ethernet0/1/0] commit
    [~PE3-Ethernet0/1/0] quit

    After the configurations are complete, LDP sessions are established between PEs and the RR. Run the display mpls ldp session command. The command output shows that Status is Operational. Run the display mpls ldp lsp command. The command output shows LDP LSP configurations.

    The following example uses the command output on PE1.

    [~PE1] display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     --------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge       KASent/Rcv
     --------------------------------------------------------------------------
     3.3.3.3:0          Operational DU   Passive  0000:00:05   22/22
     --------------------------------------------------------------------------
     TOTAL: 1 Session(s) Found.
    [~PE1] display mpls ldp lsp
     LDP LSP Information
     -------------------------------------------------------------------------------
     Flag after Out IF: (I) - RLFA Iterated LSP, (I*) - Normal and RLFA Iterated LSP
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop          OutInterface
     -------------------------------------------------------------------------------
     1.1.1.1/32         3/NULL         3.3.3.3         127.0.0.1        Loop1
    *1.1.1.1/32         Liberal/32828                  DS/3.3.3.3       
     2.2.2.2/32         NULL/32829     -               10.1.1.2         Eth0/2/0
     2.2.2.2/32         32829/32829    3.3.3.3         10.1.1.2         Eth0/2/0
     3.3.3.3/32         NULL/3         -               10.1.1.2         Eth0/2/0
     3.3.3.3/32         32828/3        3.3.3.3         10.1.1.2         Eth0/2/0
     4.4.4.4/32         NULL/32830     -               10.1.1.2         Eth0/2/0
     4.4.4.4/32         32830/32830    3.3.3.3         10.1.1.2         Eth0/2/0
     -------------------------------------------------------------------------------
     TOTAL: 7 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 FRR LSP(s) Found.
     An asterisk (*) before an LSP means the LSP is not established
     An asterisk (*) before a Label means the USCB or DSCB is stale
     An asterisk (*) before an UpstreamPeer means the session is stale
     An asterisk (*) before a DS means the session is stale
     An asterisk (*) before a NextHop means the LSP is FRR LSP

  4. Configure EVPN instances on the PEs.

    # Configure PE1.

    [~PE1] evpn vpn-instance evpna
    [*PE1-evpn-instance-evpna] route-distinguisher 100:1
    [*PE1-evpn-instance-evpna] vpn-target 1:1
    [*PE1-evpn-instance-evpna] quit
    [*PE1] evpn vpn-instance evpnb
    [*PE1-evpn-instance-evpnb] route-distinguisher 100:2
    [*PE1-evpn-instance-evpnb] vpn-target 2:2
    [*PE1-evpn-instance-evpnb] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] evpn vpn-instance evpna
    [*PE2-evpn-instance-evpna] route-distinguisher 200:1
    [*PE2-evpn-instance-evpna] vpn-target 1:1
    [*PE2-evpn-instance-evpna] quit
    [*PE2] evpn vpn-instance evpnb
    [*PE2-evpn-instance-evpnb] route-distinguisher 200:2
    [*PE2-evpn-instance-evpna] vpn-target 2:2
    [*PE2-evpn-instance-evpna] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] evpn vpn-instance evpna
    [*PE3-evpn-instance-evpna] route-distinguisher 300:1
    [*PE3-evpn-instance-evpna] vpn-target 1:1
    [*PE3-evpn-instance-evpna] quit
    [*PE3] evpn vpn-instance evpnb
    [*PE3-evpn-instance-evpnb] route-distinguisher 300:2
    [*PE3-evpn-instance-evpnb] vpn-target 2:2
    [*PE3-evpn-instance-evpnb] quit
    [*PE3] evpn redundancy-mode single-active
    [*PE3] commit

  5. Configure a source address on each PE.

    # Configure PE1.

    [~PE1] evpn source-address 1.1.1.1
    [*PE1] commit

    # Configure PE2.

    [~PE2] evpn source-address 2.2.2.2
    [*PE2] commit

    # Configure PE3.

    [~PE3] evpn source-address 4.4.4.4
    [*PE3] commit

  6. Configure an Eth-Trunk sub-interface on each PE connecting to a CE.

    # Configure PE1.

    [~PE1] e-trunk 1
    [*PE1-e-trunk-1] peer-address 2.2.2.2  source-address 1.1.1.1
    [*PE1-e-trunk-1] quit
    [*PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] e-trunk 1
    [*PE1-Eth-Trunk10] e-trunk mode force-master
    [*PE1-Eth-Trunk10] quit
    [*PE1] interface eth-trunk 10.1
    [*PE1-Eth-Trunk10.1] vlan-type dot1q 1
    [*PE1-Eth-Trunk10.1] quit
    [*PE1] interface eth-trunk 10.2
    [*PE1-Eth-Trunk10.2] vlan-type dot1q 2
    [*PE1-Eth-Trunk10.2] quit
    [*PE1] interface ethernet 0/1/0
    [*PE1-Ethernet0/1/0] eth-trunk 10
    [*PE1-Ethernet0/1/0] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] e-trunk 1
    [*PE2-e-trunk-1] peer-address 1.1.1.1  source-address 2.2.2.2
    [*PE2-e-trunk-1] quit
    [*PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] e-trunk 1
    [*PE2-Eth-Trunk10] e-trunk mode force-master
    [*PE2-Eth-Trunk10] quit
    [*PE2] interface eth-trunk 10.1
    [*PE2-Eth-Trunk10.1] vlan-type dot1q 1
    [*PE2-Eth-Trunk10.1] quit
    [*PE2] interface eth-trunk 10.2
    [*PE2-Eth-Trunk10.2] vlan-type dot1q 2
    [*PE2-Eth-Trunk10.2] quit
    [*PE2] interface ethernet 0/1/0
    [*PE2-Ethernet0/1/0] eth-trunk 10
    [*PE2-Ethernet0/1/0] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] interface eth-trunk 10
    [*PE3-Eth-Trunk10] quit
    [*PE3] interface eth-trunk 10.1
    [*PE3-Eth-Trunk10.1] vlan-type dot1q 1
    [*PE3-Eth-Trunk10.1] quit
    [*PE3] interface eth-trunk 10.2
    [*PE3-Eth-Trunk10.2] vlan-type dot1q 2
    [*PE3-Eth-Trunk10.2] quit
    [*PE3] interface ethernet 0/1/0
    [*PE3-Ethernet0/1/0] eth-trunk 10
    [*PE3-Ethernet0/1/0] quit
    [*PE3] commit

  7. Bind each sub-interface to the EVPN instances on each PE.

    # Configure PE1.

    [~PE1] interface eth-trunk 10.1
    [*PE1-Eth-Trunk10.1] evpn binding vpn-instance evpna
    [*PE1-Eth-Trunk10.1] quit
    [*PE1] interface eth-trunk 10.2
    [*PE1-Eth-Trunk10.2] evpn binding vpn-instance evpnb
    [*PE1-Eth-Trunk10.2] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] interface eth-trunk 10.1
    [*PE2-Eth-Trunk10.1] evpn binding vpn-instance evpna
    [*PE2-Eth-Trunk10.1] quit
    [*PE2] interface eth-trunk 10.2
    [*PE2-Eth-Trunk10.2] evpn binding vpn-instance evpnb
    [*PE2-Eth-Trunk10.2] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] interface eth-trunk 10.1
    [*PE3-Eth-Trunk10] evpn binding vpn-instance evpna
    [*PE3-Eth-Trunk10] quit
    [*PE3] interface eth-trunk 10.2
    [*PE3-Eth-Trunk10] evpn binding vpn-instance evpnb
    [*PE3-Eth-Trunk10] quit
    [*PE3] commit

  8. Configure ESIs on PE1's and PE2's interfaces connecting to a CE.

    # Configure PE1.

    [~PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] esi 0000.1111.2222.1111.1111
    [*PE1-Eth-Trunk10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] esi 0000.1111.2222.1111.1111
    [*PE2-Eth-Trunk10] quit
    [*PE2] commit

  9. Configure EVPN BGP peer relationships between PEs and the RR, and configure the PEs as RR clients.

    # Configure PE1.

    [~PE1] bgp 100
    [*PE1-bgp] peer 3.3.3.3 as-number 100
    [*PE1-bgp] peer 3.3.3.3 connect-interface loopback 1
    [*PE1-bgp] l2vpn-family evpn
    [*PE1-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE1-bgp-af-evpn] quit
    [*PE1-bgp] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] bgp 100
    [*PE2-bgp] peer 3.3.3.3 as-number 100
    [*PE2-bgp] peer 3.3.3.3 connect-interface loopback 1
    [*PE2-bgp] l2vpn-family evpn
    [*PE2-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE2-bgp-af-evpn] quit
    [*PE2-bgp] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] bgp 100
    [*PE3-bgp] peer 3.3.3.3 as-number 100
    [*PE3-bgp] peer 3.3.3.3 connect-interface loopback 1
    [*PE3-bgp] l2vpn-family evpn
    [*PE3-bgp-af-evpn] peer 3.3.3.3 enable
    [*PE3-bgp-af-evpn] quit
    [*PE3-bgp] quit
    [*PE3] commit

    # Configure the RR.

    [~RR] bgp 100
    [*RR-bgp] peer 1.1.1.1 as-number 100
    [*RR-bgp] peer 1.1.1.1 connect-interface loopback 1
    [*RR-bgp] peer 2.2.2.2 as-number 100
    [*RR-bgp] peer 2.2.2.2 connect-interface loopback 1
    [*RR-bgp] peer 4.4.4.4 as-number 100
    [*RR-bgp] peer 4.4.4.4 connect-interface loopback 1
    [*RR-bgp] l2vpn-family evpn
    [*RR-bgp-af-evpn] peer 1.1.1.1 enable
    [*RR-bgp-af-evpn] peer 1.1.1.1 reflect-client
    [*RR-bgp-af-evpn] peer 2.2.2.2 enable
    [*RR-bgp-af-evpn] peer 2.2.2.2 reflect-client
    [*RR-bgp-af-evpn] peer 4.4.4.4 enable
    [*RR-bgp-af-evpn] peer 4.4.4.4 reflect-client
    [*RR-bgp-af-evpn] quit
    [*RR-bgp] quit
    [*RR] commit

    After completing the configurations, run the display bgp evpn peer command on the RR. The command output shows that BGP peer relationships have been established between the PEs and RR and are in the Established state.

    [~RR] display bgp evpn peer
     
     BGP local router ID : 3.3.3.3
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      1.1.1.1         4         100       10       18     0 00:00:11 Established        6
      2.2.2.2         4         100       10       20     0 00:00:12 Established        6
      4.4.4.4         4         100        6       18     0 00:00:13 Established        2

  10. Configure CEs and PEs to communicate.

    # Configure CE1.

    [~CE1] vlan batch 1 2
    [*CE1] interface Eth-Trunk20
    [*CE1-Eth-Trunk20] portswitch
    [*CE1-Eth-Trunk20] port link-type trunk
    [*CE1-Eth-Trunk20] port trunk allow-pass vlan 1 to 2
    [*CE1-Eth-Trunk20] quit
    [*CE1] interface ethernet0/1/0
    [*CE1-Ethernet0/1/0] eth-trunk 20
    [*CE1-Ethernet0/1/0] quit
    [*CE1] interface ethernet0/2/0
    [*CE1-Ethernet0/2/0] eth-trunk 20
    [*CE1-Ethernet0/2/0] quit
    [*CE1] commit

    # Configure CE2.

    [~CE2] vlan batch 1 2
    [*CE2] interface Eth-Trunk 10
    [*CE2-Eth-Trunk10] portswitch
    [*CE2-Eth-Trunk10] port link-type trunk
    [*CE2-Eth-Trunk10] port trunk allow-pass vlan 1 to 2
    [*CE2-Eth-Trunk10] quit
    [*CE2] interface ethernet0/1/0
    [*CE2-Ethernet0/1/0] eth-trunk 10
    [*CE2-Ethernet0/1/0] quit
    [*CE2] commit

  11. Configure VLAN-based DF election and the function that the AC status influences DF election on PE1 and PE2.

    Run the display evpn vpn-instance name evpna df result and display evpn vpn-instance name evpnb df result commands on PE1 to check the DF election result.

    [~PE1] display evpn vpn-instance name evpna df result
    ESI Count: 1
    
    ESI: 0000.1111.2222.1111.1111
    
     Eth-Trunk10.1:
      Current State: IFSTATE_UP
      DF Result    : Primary
    [~PE1] display evpn vpn-instance name evpnb df result
    ESI Count: 1
    
    ESI: 0000.1111.2222.1111.1111
    
     Eth-Trunk10.2:
      Current State: IFSTATE_UP
      DF Result    : Primary

    The preceding command output shows that PE1 is elected to be the primary DF in both evpna and evpnb. Therefore, PE1 will forward the BUM traffic.

    # Configure PE1.

    [~PE1] evpn
    [*PE1-evpn] df-election type vlan
    [*PE1-evpn] df-election ac-influence enable
    [*PE1-evpn] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] evpn
    [*PE2-evpn] df-election type vlan
    [*PE2-evpn] df-election ac-influence enable
    [*PE2-evpn] quit
    [*PE2] commit

    Run the display evpn vpn-instance name evpna df result and display evpn vpn-instance name evpnb df result commands on PE1 to check the DF election result.

    [~PE1] display evpn vpn-instance name evpna df result
    ESI Count: 1
    
    ESI: 0000.1111.2222.1111.1111
    
     Eth-Trunk10.1:
      Current State: IFSTATE_UP
      DF Result    : Backup
    [~PE1] display evpn vpn-instance name evpnb df result
    ESI Count: 1
    
    ESI: 0000.1111.2222.1111.1111
    
     Eth-Trunk10.2:
      Current State: IFSTATE_UP
      DF Result    : Primary

    After VLAN-based DF election is configured, PE2 is elected to be the primary DF in evpna while PE1 is elected to be the primary DF in evpnb. In this case, PE1 and PE2 will forward the BUM traffic in load balancing mode.

  12. Configure EVPN BGP peer status tracking and set a delay after which ES routes are advertised on PE1 and PE2.

    # Configure PE1.

    [~PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] es track evpn-peer 3.3.3.3
    [*PE1-Eth-Trunk10] timer es-recovery 30
    [*PE1-Eth-Trunk10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] es track evpn-peer 3.3.3.3
    [*PE2-Eth-Trunk10] timer es-recovery 30
    [*PE2-Eth-Trunk10] quit
    [*PE2] commit

  13. Associate BFD sessions with the AC interfaces on PE1 and PE2 to accelerate DF switching during an AC link fault.

    # Configure PE1.

    [~PE1] bfd
    [*PE1-bfd] quit
    [*PE1] bfd bfd1 bind peer-ip 2.2.2.2 track-interface interface Eth-Trunk10
    [*PE1-bfd-session-bfd1] discriminator local 10
    [*PE1-bfd-session-bfd1] discriminator remote 20
    [*PE1-bfd-session-bfd1] quit
    [*PE1] interface eth-trunk 10
    [*PE1-Eth-Trunk10] es track bfd bfd1
    [*PE1-Eth-Trunk10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] bfd
    [*PE2-bfd] quit
    [*PE2] bfd bfd1 bind peer-ip 1.1.1.1 track-interface interface Eth-Trunk10
    [*PE2-bfd-session-bfd1] discriminator local 20
    [*PE2-bfd-session-bfd1] discriminator remote 10
    [*PE2-bfd-session-bfd1] quit
    [*PE2] interface eth-trunk 10
    [*PE2-Eth-Trunk10] es track bfd bfd1
    [*PE2-Eth-Trunk10] quit
    [*PE2] commit

  14. Verify the configuration.

    Run the display bgp evpn all routing-table command on PE3. The command output shows that EVPN routes are sent from the remote PEs (PE1 and PE2).

    [~PE3] display bgp evpn all routing-table
    
     Local AS number : 100
    
     BGP Local router ID is 4.4.4.4
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     EVPN address family:
     Number of A-D Routes: 4
     Route Distinguisher: 100:1
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:0                             1.1.1.1         
     Route Distinguisher: 100:2
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:0                             1.1.1.1         
     Route Distinguisher: 1.1.1.1:0
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:4294967295                    1.1.1.1         
     Route Distinguisher: 2.2.2.2:0
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:4294967295                    2.2.2.2         
        
    
     EVPN-Instance evpna:
     Number of A-D Routes: 3
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:0                             1.1.1.1         
     *>i   0000.1111.2222.1111.1111:4294967295                    1.1.1.1         
     * i                                                          2.2.2.2         
        
    
     EVPN-Instance evpnb:
     Number of A-D Routes: 3
           Network(ESI/EthTagId)                                  NextHop
     *>i   0000.1111.2222.1111.1111:0                             1.1.1.1         
     *>i   0000.1111.2222.1111.1111:4294967295                    1.1.1.1         
     * i                                                          2.2.2.2         
    
     EVPN address family:
     Number of Inclusive Multicast Routes: 6
     Route Distinguisher: 100:1
           Network(EthTagId/IpAddrLen/OriginalIp)                 NextHop
     *>i   0:32:1.1.1.1                                           1.1.1.1         
     *>i   0:32:2.2.2.2                                           2.2.2.2         
     *>    0:32:4.4.4.4                                           127.0.0.1       
     Route Distinguisher: 100:2
           Network(EthTagId/IpAddrLen/OriginalIp)                 NextHop
     *>i   0:32:1.1.1.1                                           1.1.1.1         
     *>i   0:32:2.2.2.2                                           2.2.2.2         
     *>    0:32:4.4.4.4                                           127.0.0.1       
        
    
     EVPN-Instance evpna:
     Number of Inclusive Multicast Routes: 3
           Network(EthTagId/IpAddrLen/OriginalIp)                 NextHop
     *>i   0:32:1.1.1.1                                           1.1.1.1         
     *>i   0:32:2.2.2.2                                           2.2.2.2         
     *>    0:32:4.4.4.4                                           127.0.0.1       
        
    
     EVPN-Instance evpnb:
     Number of Inclusive Multicast Routes: 3
           Network(EthTagId/IpAddrLen/OriginalIp)                 NextHop
     *>i   0:32:1.1.1.1                                           1.1.1.1         
     *>i   0:32:2.2.2.2                                           2.2.2.2         
     *>    0:32:4.4.4.4                                           127.0.0.1       
                    
     EVPN address family:
     Number of ES Routes: 2
     Route Distinguisher: 1.1.1.1:0
           Network(ESI)                                           NextHop
     *>i   0000.1111.2222.1111.1111                               1.1.1.1         
     Route Distinguisher: 2.2.2.2:0
           Network(ESI)                                           NextHop
     *>i   0000.1111.2222.1111.1111                               2.2.2.2

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    evpn
     df-election type vlan
     df-election ac-influence enable
    #
    evpn vpn-instance evpna
     route-distinguisher 100:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    evpn vpn-instance evpnb
     route-distinguisher 100:2
     vpn-target 2:2 export-extcommunity
     vpn-target 2:2 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
    #
    e-trunk 1
     peer-address 2.2.2.2 source-address 1.1.1.1
    #
    interface Eth-Trunk10
     e-trunk 1
     e-trunk mode force-master
     esi 0000.1111.2222.1111.1111
     es track bfd bfd1
     es track evpn-peer 3.3.3.3
     timer es-recovery 30
     port ignore-lacp-state enable
    #
    interface Eth-Trunk10.1
     vlan-type dot1q 1
     evpn binding vpn-instance evpna
    #
    interface Eth-Trunk10.2
     vlan-type dot1q 2
     evpn binding vpn-instance evpnb
    #
    interface Ethernet0/1/0
     undo shutdown
     port-tx-enabling-delay 30000
     carrier up-hold-time 30000
     eth-trunk 10
    #
    interface Ethernet0/2/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    bfd bfd1 bind peer-ip 2.2.2.2 track-interface interface Eth-Trunk10
     discriminator local 10
     discriminator remote 20
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    evpn source-address 1.1.1.1
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    evpn
     df-election type vlan
     df-election ac-influence enable
    #
    evpn vpn-instance evpna
     route-distinguisher 100:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    evpn vpn-instance evpnb
     route-distinguisher 100:2
     vpn-target 2:2 export-extcommunity
     vpn-target 2:2 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
    #
    e-trunk 1
     peer-address 1.1.1.1 source-address 2.2.2.2
    #
    interface Eth-Trunk10
     e-trunk 1
     e-trunk mode force-master
     esi 0000.1111.2222.1111.1111
     es track bfd bfd1
     es track evpn-peer 3.3.3.3
     timer es-recovery 30
     port ignore-lacp-state enable
    #
    interface Eth-Trunk10.1
     vlan-type dot1q 1
     evpn binding vpn-instance evpna
    #
    interface Eth-Trunk10.2
     vlan-type dot1q 2
     evpn binding vpn-instance evpnb
    #
    interface Ethernet0/1/0
     undo shutdown
     port-tx-enabling-delay 30000
     carrier up-hold-time 30000
     eth-trunk 10
    #
    interface Ethernet0/2/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    bfd bfd1 bind peer-ip 1.1.1.1 track-interface interface Eth-Trunk10
     discriminator local 20
     discriminator remote 10
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 3.3.3.3 enable
    #               
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    evpn source-address 2.2.2.2
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    evpn redundancy-mode single-active
    #
    evpn vpn-instance evpna
     route-distinguisher 100:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
    evpn vpn-instance evpnb
     route-distinguisher 100:2
     vpn-target 2:2 export-extcommunity
     vpn-target 2:2 import-extcommunity
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
    #
    mpls ldp
    #
    interface Eth-Trunk10
    #
    interface Eth-Trunk10.1
     vlan-type dot1q 1
     evpn binding vpn-instance evpna
    #
    interface Eth-Trunk10.2
     vlan-type dot1q 2
     evpn binding vpn-instance evpnb
    #
    interface Ethernet0/1/0
     undo shutdown
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Ethernet0/2/0
     undo shutdown
     eth-trunk 10   
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.3.1.0 0.0.0.255
    #
    evpn source-address 4.4.4.4
    #
    return
  • RR configuration file

    #
    sysname RR
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
    #
    interface Ethernet0/1/0
     undo shutdown
     ip address 10.3.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Ethernet0/2/0
     undo shutdown  
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Ethernet0/3/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 reflect-client
      peer 4.4.4.4 enable
      peer 4.4.4.4 reflect-client
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 1 to 2
    #
    interface Eth-Trunk20
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 1 to 2
    #
    interface Ethernet0/1/0
     undo shutdown
     eth-trunk 20   
    #
    interface Ethernet0/2/0
     undo shutdown
     eth-trunk 20
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 1 to 2
    #
    interface Eth-Trunk10
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 1 to 2
    #
    interface Ethernet0/1/0
     undo shutdown
     eth-trunk 10   
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 31723

Downloads: 57

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next