No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - VPN
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Carrier's Carrier in the Same AS

Example for Configuring Carrier's Carrier in the Same AS

This section provides an example on how to configure the second carrier to provide BGP/MPLS IP VPN services when first carrier and the second carrier are in the same AS.

Networking Requirements

The Level 1 carrier and the Level 2 carrier are in the same AS. The Level 2 carrier provides the BGP/MPLS IP VPN service for its customers.

In Figure 5-35:

  • PE1 and PE2 are PEs of the Level 1 carrier's backbone.

  • CE1 and CE2 belong to the Level 2 carrier and access the backbone of Level 1 carrier.

  • PE3 and PE4 belong to the Level 2 carrier and provide access service for Level 2 carrier's customer.

  • CE3 and CE4 are the Level 2 carrier's customer.

Figure 5-35 Networking diagram of carrier's carrier configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the two types of route exchange as follows:

    • The exchange of the internal route of the level 2 carrier on the backbone network of level 1 carrier: configure the level 2 carrier to access the level 1 carrier as the level 1 carrier's CE.

    • The exchange of the external route of the level 2 carrier between the PE devices of the level 2 carrier: set up the MP-IBGP peer relationship between the PE devices (PE3 and PE4) of the level 2 carrier.

  2. Configure the carrier's carrier of the same AS and configure IGP and LDP between the PE of the level 1 carrier and the CE of the level 1 carrier.

Data Preparation

To configure the carrier's carrier in the same AS, you need the following data:

  • MPLS LSR ID on the PE of the level 1 carrier, MPLS LSR ID on the PE and the CE of the level 2 carrier

  • Data for configuring IGP (The IS-IS process number of the IGP protocol running on the PE of the level 2 carrier and the CE of the level 1 carrier is the same with that used when the CE of the level 1 carrier accesses the level 1 carrier. However, it is different from that on the PE of the level 1 carrier.)

  • The name of the VPN instance configured on the PE, RD and the VPN-target

Procedure

  1. Configure the BGP/MPLS IP VPN on Level 1 carrier's backbone.

    Adopt IS-IS as the IGP. Enable LDP between PE1 and PE2 and establish MP-IBGP peer relationship between them.

    # Configure PE1

    <~HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface loopback 1
    [*PE1-LoopBack1] ip address 3.3.3.9 32
    [*PE1-LoopBack1] commit
    [~PE1-LoopBack1] quit
    [~PE1] mpls lsr-id 3.3.3.9
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1] commit
    [~PE1-mpls-ldp] quit
    [~PE1] isis 1
    [*PE1-isis-1] network-entity 10.0000.0000.0004.00
    [*PE1-isis-1] quit
    [*PE1] interface loopback 1
    [*PE1-LoopBack1] isis enable 1
    [*PE1-LoopBack1] quit
    [*PE1] interface gigabitethernet 0/2/0
    [*PE1-GigabitEthernet0/2/0] ip address 30.1.1.1 24
    [*PE1-GigabitEthernet0/2/0] isis enable 1
    [*PE1-GigabitEthernet0/2/0] mpls
    [*PE1-GigabitEthernet0/2/0] mpls ldp
    [*PE1-GigabitEthernet0/2/0] commit
    [~PE1-GigabitEthernet0/2/0] quit
    [~PE1] bgp 100
    [*PE1-bgp] peer 4.4.4.9 as-number 100
    [*PE1-bgp] peer 4.4.4.9 connect-interface loopback 1
    [*PE1-bgp] ipv4-family vpnv4
    [*PE1-bgp-af-vpnv4] peer 4.4.4.9 enable
    [*PE1-bgp-af-vpnv4] quit
    [*PE1-bgp] commit
    NOTE:

    The configuration of PE2 is similar to that of PE1 and is not mentioned here.

    After the configuration, run the display mpls ldp session command on PE1 or PE2, to find that the LDP session has been established successfully. Run the display bgp peer command to find that the BGP peer relationship has been established. Run the display isis peer command to find that the IS-IS neighbor has been set up.

    Consider PE1 as an example:

    [~PE1] display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ----------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ----------------------------------------------------------------
     4.4.4.9:0      Operational   DU   Active   0000:00:01  8/8
     ----------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    [~PE1] display bgp peer
     BGP local router ID : 3.3.3.9
     Local AS number : 100
     Total number of peers : 1          Peers in established state : 1
      Peer        V   AS  MsgRcvd  MsgSent  OutQ  Up/Down         State   PrefRcv
      4.4.4.9     4 100         7         8      0 00:02:47 Established         0
    [~PE1] display isis peer
                              Peer information for ISIS(1)
      System Id     Interface          Circuit Id       State HoldTime Type     PRI
    -------------------------------------------------------------------------------
    0000.0000.0005  GigabitEthernet0/2/0           0000.0000.0005.01 Up   7s       L1(L1L2) 64
    0000.0000.0005  GigabitEthernet0/2/0           0000.0000.0005.01 Up   7s       L2(L1L2) 64
    
    Total Peer(s): 2

  2. Configure Level 2 carrier's network.

    Adopt IS-IS as IGP and enable LDP between PE3 and CE1, PE4 and CE2 respectively.

    # Configure PE3.

    <~HUAWEI> system-view
    [~HUAWEI] sysname PE3
    [*HUAWEI] commit
    [~PE3] interface loopback 1
    [*PE3-LoopBack1] ip address 1.1.1.9 32
    [*PE3-LoopBack1] quit
    [*PE3] mpls lsr-id 1.1.1.9
    [*PE3] mpls
    [*PE3-mpls] quit
    [*PE3] mpls ldp
    [*PE3-mpls-ldp] quit
    [*PE3] isis 2
    [*PE3-isis-2] network-entity 10.0000.0000.0001.00
    [*PE3-isis-2] quit
    [*PE3] interface loopback 1
    [*PE3-LoopBack1] isis enable 2
    [*PE3-LoopBack1] quit
    [*PE3] interface gigabitethernet 0/2/0
    [*PE3-GigabitEthernet0/2/0] ip address 40.1.1.1 24
    [*PE3-GigabitEthernet0/2/0] isis enable 2
    [*PE3-GigabitEthernet0/2/0] mpls
    [*PE3-GigabitEthernet0/2/0] mpls ldp
    [*DevicePE3-GigabitEthernet0/2/0] commit
    [~PE3-GigabitEthernet0/2/0] quit

    # Configure CE1.

    <~HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] interface loopback 1
    [*CE1-LoopBack1] ip address 2.2.2.9 32
    [*CE1-LoopBack1] quit
    [*CE1] mpls lsr-id 2.2.2.9
    [*CE1] mpls
    [*CE1-mpls] quit
    [*CE1] mpls ldp
    [*CE1-mpls-ldp] quit
    [*CE1] isis 2
    [*CE1-isis-2] network-entity 10.0000.0000.0002.00
    [*CE1-isis-2] quit
    [*CE1] interface loopback 1
    [*CE1-LoopBack1] isis enable 2
    [*CE1-LoopBack1] quit
    [*CE1] interface gigabitethernet 0/1/0
    [*CE1-Gigabitethernet0/1/0] ip address 40.1.1.2 24
    [*CE1-Gigabitethernet0/1/0] isis enable 2
    [*CE1-Gigabitethernet0/1/0] mpls
    [*CE1-Gigabitethernet0/1/0] mpls ldp
    [*CE1-Gigabitethernet0/1/0] commit
    [~CE1-Gigabitethernet0/1/0] quit

    After the configuration, the LDP session and IS-IS neighbor relationship should be established between the PE3 and the CE1.

    NOTE:

    The configurations of PE4 and CE2 are similar to that of PE3 and CE1. Their configurations are not mentioned here.

  3. Configure CEs of the Level 1 carrier to access PEs of the Level 1 carrier.

    # Configure PE1.

    [~PE1] ip vpn-instance vpn1
    [*PE1-vpn-instance-vpn1] ipv4-family
    [*PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 200:1
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE1-vpn-instance-vpn1-af-ipv4] quit
    [*PE1-vpn-instance-vpn1] quit
    [*PE1] bgp 100
    [*PE1-bgp] ipv4-family vpn-instance vpn1
    [*PE1-bgp-vpn1] import-route isis 2
    [*PE1-bgp-vpn1] quit
    [*PE1-bgp] quit
    [*PE1] mpls ldp vpn-instance vpn1
    [*PE1-mpls-ldp-vpn-instance-vpn1] quit
    [*PE1] isis 2 vpn-instance vpn1
    [*PE1-isis-2] network-entity 10.0000.0000.0003.00
    [*PE1-isis-2] import-route bgp
    [*PE1-isis-2] quit
    [*PE1] interface gigabitethernet 0/1/0
    [*PE1-Gigabitethernet0/1/0] ip binding vpn-instance vpn1
    [*PE1-Gigabitethernet0/1/0] ip address 11.1.1.2 24
    [*PE1-Gigabitethernet0/1/0] isis enable 2
    [*PE1-Gigabitethernet0/1/0] mpls
    [*PE1-Gigabitethernet0/1/0] mpls ldp
    [*PE1-Gigabitethernet0/1/0] mpls ldp transport-address interface
    [*PE1-Gigabitethernet0/1/0] commit

    # Configure CE1.

    [~CE1] interface gigabitethernet 0/2/0
    [*CE1-GigabitEthernet0/2/0] ip address 11.1.1.1 24
    [*CE1-GigabitEthernet0/2/0] isis enable 2
    [*CE1-GigabitEthernet0/2/0] mpls
    [*CE1-GigabitEthernet0/2/0] mpls ldp
    [*CE1-GigabitEthernet0/2/0] mpls ldp transport-address interface
    [*CE1-GigabitEthernet0/2/0] commit
    [~CE1-GigabitEthernet0/2/0] quit

    After the configuration, the LDP session and IS-IS neighbor relationship should be established between PE1 and CE1.

    NOTE:

    The configuration of PE2 and CE2 are similar to that of PE1 and CE1. Their configurations are not mentioned here.

  4. Configure the Level 2 carrier's CE and PE so that the CE can access the PE.

    # Configure CE3.

    <~HUAWEI> system-view
    [~HUAWEI] sysname CE3
    [*HUAWEI] commit
    [~CE3] interface gigabitethernet 0/1/0
    [*CE3-GigabitEthernet0/1/0] ip address 172.16.1.1 24
    [*CE3-GigabitEthernet0/1/0] quit
    [*CE3] bgp 65410
    [*CE3-bgp] peer 172.16.1.2 as-number 100
    [*CE3-bgp] import-route direct
    [*CE3-bgp] commit
    [~DeviceCE3-bgp] quit

    # Configure PE3.

    [~PE3] ip vpn-instance vpn1
    [*PE3-vpn-instance-vpn1] ipv4-family
    [*PE3-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:1
    [*PE3-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE3-vpn-instance-vpn1-af-ipv4] quit
    [*PE3-vpn-instance-vpn1] quit
    [*PE3] interface gigabitethernet 0/1/0
    [*PE3-GigabitEthernet0/1/0] ip binding vpn-instance vpn1
    [*PE3-GigabitEthernet0/1/0] ip address 172.16.1.2 24
    [*PE3-GigabitEthernet0/1/0] quit
    [*PE3] bgp 100
    [*PE3-bgp] ipv4-family vpn-instance vpn1
    [*PE3-bgp-vpn1] peer 172.16.1.1 as-number 65410
    [*PE3-bgp-vpn1] import-route direct
    [*PE3-bgp-vpn1] commit
    [~PE3-bgp-vpn1] quit
    [~PE3-bgp] quit

    After the configuration, you can view that the BGP peer is set up between CE3 and PE3 and the peer status is "Established".

    NOTE:

    The configurations of PE4 and CE4 are similar to that of PE3 and CE3. Their configurations are not mentioned here.

  5. Establish MP-IBGP peers between Level 2 carrier's PEs to exchange VPN routes of Level 2 carrier's CEs.

    # Configure PE3.

    [~PE3] bgp 100
    [*PE3-bgp] peer 6.6.6.9 as-number 100
    [*PE3-bgp] peer 6.6.6.9 connect-interface loopback 1
    [*PE3-bgp] ipv4-family vpnv4
    [*PE3-bgp-af-vpnv4] peer 6.6.6.9 enable
    [*PE3-bgp-af-vpnv4] commit
    [~PE3-bgp-af-vpnv4] quit
    [~PE3-bgp] quit
    NOTE:

    The configuration of the PE4 is similar to that of the PE3 and is not mentioned here.

  6. Verify the configuration.

    After all the configurations, run the display ip routing-table command on PE1 and PE2 to find that the public routing table on PE1 and PE2 contain only the Level 1 carrier's routes.

    Consider PE1 as an example:

    [~PE1] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
      Destination/Mask  Proto  Pre  Cost      Flags  NextHop      Interface
            3.3.3.9/32  Direct 0    0             D  127.0.0.1    InLoopBack0
            4.4.4.9/32  ISIS   15   10            D  30.1.1.2     GigabitEthernet0/2/0
           30.1.1.0/24  Direct 0    0             D  30.1.1.1     GigabitEthernet0/2/0
           30.1.1.1/32  Direct 0    0             D  127.0.0.1    GigabitEthernet0/2/0
           30.1.1.2/32  Direct 0    0             D  30.1.1.2     GigabitEthernet0/2/0
          127.0.0.0/8   Direct 0    0             D  127.0.0.1    InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1    InLoopBack0 

    Run the display ip routing-table vpn-instance command on PE1 and PE2, to find that the VPN routing table does not contain the external but the internal routes of the Level 2 carrier.

    Consider PE1 as an example:

    [~PE1] display ip routing-table vpn-instance vpn1
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: vpn1
             Destinations : 10        Routes : 10
      Destination/Mask  Proto  Pre  Cost      Flags  NextHop       Interface
            1.1.1.9/32  ISIS   15   20            D  11.1.1.1      Gigabitethernet0/1/0
            2.2.2.9/32  ISIS   15   10            D  11.1.1.1      Gigabitethernet0/1/0
            5.5.5.9/32  IBGP   255  0            RD  4.4.4.9       GigabitEthernet0/2/0
            6.6.6.9/32  IBGP   255  0            RD  4.4.4.9       GigabitEthernet0/2/0
           40.1.1.0/24  ISIS   15   20            D  11.1.1.1      Gigabitethernet0/1/0
           11.1.1.0/24  Direct 0    0             D  11.1.1.1      Gigabitethernet0/1/0
           11.1.1.1/32  Direct 0    0             D  11.1.1.2      Gigabitethernet0/1/0
           11.1.1.2/32  Direct 0    0             D  127.0.0.1     Gigabitethernet0/1/0
           20.1.1.0/24  IBGP   255  0            RD  4.4.4.9       GigabitEthernet0/2/0
           21.1.1.0/24  IBGP   255  0            RD  4.4.4.9       GigabitEthernet0/2/0

    Run the display ip routing-table command on CE1 and CE2 to find that the public routing table does not contain external but internal routes of the Level 2 carrier.

    Consider CE1 as an example:

    [~CE1] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 14       Routes : 14
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
            1.1.1.9/32  ISIS   15   10             D  40.1.1.2        Gigabitethernet0/1/0
            2.2.2.9/32  Direct 0    0              D  127.0.0.1       InLoopBack0
            5.5.5.9/32  ISIS   15   74             D  11.1.1.2        GigabitEthernet0/2/0
            6.6.6.9/32  ISIS   15   74             D  11.1.1.2        GigabitEthernet0/2/0
           40.1.1.0/24  Direct 0    0              D  40.1.1.2        Gigabitethernet0/1/0
           40.1.1.1/32  Direct 0    0              D  40.1.1.1        Gigabitethernet0/1/0
           40.1.1.2/32  Direct 0    0              D  127.0.0.1       GigabitEthernet0/2/0
           11.1.1.0/24  Direct 0    0              D  11.1.1.1        GigabitEthernet0/2/0
           11.1.1.1/32  Direct 0    0              D   11.1.1.2       GigabitEthernet0/2/0
           11.1.1.2/32  Direct 0    0              D   127.0.0.1      Gigabitethernet2/0/
           20.1.1.0/24  ISIS   15   74             D  11.1.1.2        GigabitEthernet0/2/0
           21.1.1.0/24  ISIS   15   74             D  11.1.1.2        GigabitEthernet0/2/0
          127.0.0.0/8   Direct 0    0              D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0              D  127.0.0.1       InLoopBack0 

    Run the display ip routing-table command on PE3 and PE4 to find that the internal routes of the Level 2 carrier are contained in the public routing table.

    Consider PE3 as an example:

    [~PE3] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 13       Routes : 13
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
            1.1.1.9/32  Direct 0    0              D  127.0.0.1       InLoopBack0
            2.2.2.9/32  ISIS   15   10             D  40.1.1.2        GigabitEthernet0/2/0
            5.5.5.9/32  ISIS   15   84             D  40.1.1.2        GigabitEthernet0/2/0
            6.6.6.9/32  ISIS   15   84             D  40.1.1.2        GigabitEthernet0/2/0
           40.1.1.0/24  Direct 0    0              D  40.1.1.1        GigabitEthernet0/2/0
           40.1.1.1/32  Direct 0    0              D  127.0.0.1       GigabitEthernet0/2/0
           40.1.1.2/32  Direct 0    0              D  40.1.1.2        GigabitEthernet0/2/0
           11.1.1.0/24  ISIS   15   20             D  40.1.1.2        GigabitEthernet0/2/0
           20.1.1.0/24  ISIS   15   84             D  40.1.1.2        GigabitEthernet0/2/0
           20.1.1.1/32  EBGP   255   0            RD  6.6.6.9         GigabitEthernet0/2/0
           21.1.1.0/24  ISIS   15   84             D  40.1.1.2        GigabitEthernet0/2/0
          127.0.0.0/8   Direct 0    0              D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0              D  127.0.0.1       InLoopBack0

    Run the display ip routing-table vpn-instance command on PE3 and PE4 to find that the routes of the remote CEs, that is, the external routes of the Level 2 carrier, are contained in the VPN routing table.

    Consider PE3 as an example:

    [~PE3] display ip routing-table vpn-instance vpn1
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: vpn1
             Destinations : 3        Routes : 3
      Destination/Mask  Proto  Pre  Cost      Flags  NextHop        Interface
          172.16.1.0/24 Direct 0    0             D  172.16.1.2     GigabitEthernet0/1/0
          172.16.1.2/32 Direct 0    0             D  127.0.0.1      GigabitEthernet0/1/0
          172.16.2.0/24 EBGP   255  0            RD  6.6.6.9        GigabitEthernet0/2/0

    PE3 and PE4 can ping through each other:

    [~PE3] ping 20.1.1.2
      PING 20.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 20.1.1.2: bytes=56 Sequence=1 ttl=252 time=127 ms
        Reply from 20.1.1.2: bytes=56 Sequence=2 ttl=252 time=97 ms
        Reply from 20.1.1.2: bytes=56 Sequence=3 ttl=252 time=83 ms
        Reply from 20.1.1.2: bytes=56 Sequence=4 ttl=252 time=70 ms
        Reply from 20.1.1.2: bytes=56 Sequence=5 ttl=252 time=60 ms
      --- 20.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 60/87/127 ms

    CE3 and CE4 can ping through each other:

    [~CE3] ping 172.16.2.1
      PING 172.16.2.1: 56  data bytes, press CTRL_C to break
        Reply from 172.16.2.1: bytes=56 Sequence=1 ttl=252 time=102 ms
        Reply from 172.16.2.1: bytes=56 Sequence=2 ttl=252 time=69 ms
        Reply from 172.16.2.1: bytes=56 Sequence=3 ttl=252 time=105 ms
        Reply from 172.16.2.1: bytes=56 Sequence=4 ttl=252 time=88 ms
        Reply from 172.16.2.1: bytes=56 Sequence=5 ttl=252 time=87 ms
      --- 172.16.2.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 69/90/105 ms 

Configuration Files

  • Configuration file of CE3

    #
     sysname CE3
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
    #
    bgp 65410
     peer 172.16.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 172.16.1.2 enable
    #
    return
  • Configuration file of PE3

    #
     sysname PE3
    #
     sysname PE3
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
    mpls ldp
    #
    isis 2
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 172.16.1.2 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip address 40.1.1.1 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
     #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 2
    #
    bgp 100
     peer 6.6.6.9 as-number 100
     peer 6.6.6.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 6.6.6.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 6.6.6.9 enable  
     #
     ipv4-family vpn-instance vpn1
      peer 172.16.1.1 as-number 65410
      import-route direct
    #
    return
  • Configuration file of CE1

    #
     sysname CE1
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    isis 2
     network-entity 10.0000.0000.0002.00
    #
    interface Gigabitethernet0/1/0
     
     undo shutdown
     ip address 40.1.1.2 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip address 11.1.1.1 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
     mpls ldp transport-address interface
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 2
    #
    return
  • Configuration file of PE1

    #
     sysname PE1
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 200:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 3.3.3.9
     mpls
    #
    mpls ldp
    #
    mpls ldp vpn-instance vpn1
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    isis 2 vpn-instance vpn1
     network-entity 10.0000.0000.0003.00
     import-route bgp
    #
    interface Gigabitethernet0/1/0
     
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 11.1.1.2 255.255.255.0
     isis enable 2
     mpls
     mpls ldp 
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip address 30.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 4.4.4.9 as-number 100
     peer 4.4.4.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 4.4.4.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 4.4.4.9 enable
     #
     ipv4-family vpn-instance vpn1
      import-route isis 2
    #
    return
  • Configuration file of PE2

    #
     sysname PE2
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 200:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 4.4.4.9
     mpls
    #
    mpls ldp
    #
    mpls ldp vpn-instance vpn1
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    isis 2 vpn-instance vpn1
     network-entity 10.0000.0000.0006.00
     import-route bgp
    #
    interface Gigabitethernet0/1/0
     
     undo shutdown
     ip address 30.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 21.1.1.1 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
    #
     ipv4-family vpn-instance vpn1
      import-route isis 2
    #
    return
  • Configuration file of CE2

    #
     sysname CE2
    #
     mpls lsr-id 5.5.5.9
     mpls
    #
    mpls ldp
    #
    isis 2
     network-entity 10.0000.0000.0007.00
    #
    interface Gigabitethernet0/1/0
     
     undo shutdown
     ip address 21.1.1.2 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
     mpls ldp transport-address interface
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip address 20.1.1.1 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
     isis enable 2
    #
    return
  • Configuration file of PE4

    #
     sysname PE4
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 6.6.6.9
     mpls
    #
    mpls ldp
    #
    isis 2
     network-entity 10.0000.0000.0008.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 172.16.2.2 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     
     undo shutdown
     ip address 20.1.1.2 255.255.255.0
     isis enable 2
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
     isis enable 2
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
    #
     ipv4-family vpn-instance vpn1
      peer 172.16.2.1 as-number 65420
      import-route direct
    #
    return
  • Configuration file of CE4

    #
     sysname CE4
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.2.1 255.255.255.0
    #
    bgp 65420
     peer 172.16.2.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 172.16.2.2 enable
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058925

Views: 29980

Downloads: 54

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next