No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPF Multi-Area Adjacency

Example for Configuring OSPF Multi-Area Adjacency

This section provides an example for configuring OSPF multi-area adjacency, which includes configuration of enabling OSPF on each device, physical interface, and OSPF multi-area adjacency interface.

Networking Requirements

In Figure 5-21, all ME devices run OSPF, and the AS consists of two areas: area 1 and area 2. The link between ME device A and ME device B in area 1 is a high-speed link. Because intra-area links take precedence over inter-area links during OSPF route selection, traffic from ME device A to ME device B in area 2 is forwarded along the low-speed link of ME device A -> ME device C -> ME device D -> ME device B, even though high-speed link between ME device A and ME device B exists. However, it is required that traffic from ME device A to ME device B in area 2 be forwarded along the high-speed link between ME device A and ME device B. In this case, configure OSPF multi-area adjacency on ME device A and ME device B and add their multi-area adjacency interfaces to area 2.

Figure 5-21 Networking for configuring OSPF multi-area adjacency
NOTE:

Interface 1 and interface 2 in this example stand for GE 1/0/0 and GE 2/0/0, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable OSPF on each ME device.

  2. Enable OSPF on physical interfaces.

  3. Enable OSPF on multi-area adjacency interfaces.

Data Preparation

To complete the configuration, you need the following data:
  • OSPF process ID: 1
  • OSPF areas: area 1 and area 2

Procedure

  1. Configure an IP address for each interface. The configuration details are not provided here.
  2. Configure basic OSPF functions.

    # Configure Device A.

    [~DeviceA] ospf 1
    [*DeviceA-ospf-1] area 1
    [*DeviceA-ospf-1-area-0.0.0.1] quit
    [*DeviceA-ospf-1] quit
    [*DeviceA] interface gigabitethernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] ospf enable 1 area 1
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] ospf 1
    [*DeviceA-ospf-1] area 2
    [*DeviceA-ospf-1-area-0.0.0.2] quit
    [*DeviceA-ospf-1] quit
    [*DeviceA] interface gigabitethernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] ospf enable 1 area 2
    [*DeviceA-GigabitEthernet2/0/0] quit
    [*DeviceA] commit

    # Configure Device B.

    [~DeviceB] ospf 1
    [*DeviceB-ospf-1] area 1
    [*DeviceB-ospf-1-area-0.0.0.1] quit
    [*DeviceB-ospf-1] quit
    [*DeviceB] interface gigabitethernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] ospf enable 1 area 1
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] ospf 1
    [*DeviceB-ospf-1] area 2
    [*DeviceB-ospf-1-area-0.0.0.2] quit
    [*DeviceB-ospf-1] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] ospf enable 1 area 2
    [*DeviceB-GigabitEthernet2/0/0] quit
    [*DeviceB] commit

    # Configure Device C.

    [~DeviceC] ospf 1
    [*DeviceC-ospf-1] area 2
    [*DeviceC-ospf-1-area-0.0.0.2] quit
    [*DeviceC-ospf-1] quit
    [*DeviceC] interface gigabitethernet 1/0/0
    [*DeviceC-GigabitEthernet1/0/0] ospf enable 1 area 2
    [*DeviceC-GigabitEthernet1/0/0] quit
    [*DeviceC] interface gigabitethernet 2/0/0
    [*DeviceC-GigabitEthernet2/0/0] ospf enable 1 area 2
    [*DeviceC-GigabitEthernet2/0/0] quit
    [*DeviceC] commit

    # Configure Device D.

    [~DeviceD] ospf 1
    [*DeviceD-ospf-1] area 2
    [*DeviceD-ospf-1-area-0.0.0.2] quit
    [*DeviceD-ospf-1] quit
    [*DeviceD] interface gigabitethernet 1/0/0
    [*DeviceD-GigabitEthernet1/0/0] ospf enable 1 area 2
    [*DeviceD-GigabitEthernet1/0/0] quit
    [*DeviceD] interface gigabitethernet 2/0/0
    [*DeviceD-GigabitEthernet2/0/0] ospf enable 1 area 2
    [*DeviceD-GigabitEthernet2/0/0] quit
    [*DeviceD] commit

    # Run the display ospf peer brief command to check brief information about OSPF neighbors. Device A is used as an example. The following command output shows that the OSPF neighbor relationships between Device A and Device B and between Device A and Device C are established.

    [~DeviceA] display ospf peer brief
    (M) Indicates MADJ neighbor
    
    
              OSPF Process 1 with Router ID 1.1.1.1
                       Peer Statistic Information
    Total number of peer(s): 2       
     Peer(s) in full state: 2       
    -----------------------------------------------------------------------------
     Area Id         Interface                  Neighbor id          State       
     0.0.0.1         GigabitEthernet1/0/0       10.1.1.2             Full        
     0.0.0.2         GigabitEthernet2/0/0       10.1.1.1             Full        
    -----------------------------------------------------------------------------

    # Run the display ip routing-table command to check information about the IP routing table. Device A is used as an example. The following command output shows that the outbound interface of the route destined for 1.1.1.1 is GigabitEthernet 2/0/0.

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 13       Routes : 13        
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  OSPF    10   3             D   10.1.2.2        GigabitEthernet2/0/0
           10.1.1.0/24  Direct  0    0             D   10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0             D   127.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct  0    0             D   127.0.0.1       GigabitEthernet1/0/0
           10.1.2.0/24  Direct  0    0             D   10.1.2.1        GigabitEthernet2/0/0
           10.1.2.1/32  Direct  0    0             D   127.0.0.1       GigabitEthernet2/0/0
         10.1.2.255/32  Direct  0    0             D   127.0.0.1       GigabitEthernet2/0/0
           10.1.3.0/24  OSPF    10   3             D   10.1.2.2        GigabitEthernet2/0/0
           10.1.4.0/24  OSPF    10   2             D   10.1.2.2        GigabitEthernet2/0/0
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

    The preceding command output shows that traffic from ME device A to ME device B in area 2 is forwarded along the low-speed link of ME device A -> ME device C -> ME device D -> ME device B.

  3. Enable OSPF on multi-area adjacency interfaces.

    # Configure Device A.

    [~DeviceA] interface gigabitethernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] ospf enable multi-area 2
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] commit

    # Configure Device B.

    [~DeviceB] interface gigabitethernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] ospf enable multi-area 2
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] commit

  4. Verify the configuration.

    # Run the display ospf peer brief command to check brief information about OSPF neighbors. Device A is used as an example. The following command output shows that the OSPF neighbor relationships between Device A and Device B and between Device A and Device C are established and that an OSPF multi-area adjacency is established between Device A and Device B.

    [~DeviceA] display ospf peer brief
    (M) Indicates MADJ neighbor
    
    
              OSPF Process 1 with Router ID 1.1.1.1
                       Peer Statistic Information
    Total number of peer(s): 3       
     Peer(s) in full state: 3       
    -----------------------------------------------------------------------------
     Area Id         Interface                  Neighbor id          State       
     0.0.0.1         GigabitEthernet1/0/0       10.1.1.2             Full        
     0.0.0.2         GigabitEthernet1/0/0       10.1.1.2(M)          Full        
     0.0.0.2         GigabitEthernet2/0/0       10.1.1.1             Full        
    -----------------------------------------------------------------------------

    # Run the display ip routing-table command to check information about the IP routing table. Device A is used as an example. The following command output shows that the outbound interface of the route destined for 1.1.1.1 is GigabitEthernet 1/0/0.

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 13       Routes : 13        
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  OSPF    10   1             D   10.1.1.2        GigabitEthernet1/0/0
           10.1.1.0/24  Direct  0    0             D   10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0             D   127.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct  0    0             D   127.0.0.1       GigabitEthernet1/0/0
           10.1.2.0/24  Direct  0    0             D   10.1.2.1        GigabitEthernet2/0/0
           10.1.2.1/32  Direct  0    0             D   127.0.0.1       GigabitEthernet2/0/0
         10.1.2.255/32  Direct  0    0             D   127.0.0.1       GigabitEthernet2/0/0
           10.1.3.0/24  OSPF    10   2             D   10.1.1.2        GigabitEthernet1/0/0
           10.1.4.0/24  OSPF    10   2             D   10.1.2.2        GigabitEthernet2/0/0
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

    The preceding command output shows that traffic from ME device A to ME device B in area 2 is forwarded along the high-speed link between ME device A and ME device B.

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #               
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.1 255.255.255.0
     ospf enable 1 area 0.0.0.1
     ospf enable multi-area 0.0.0.2
    #               
    interface GigabitEthernet2/0/0
     undo shutdown  
     ip address 10.1.2.1 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #               
    ospf 1          
     area 0.0.0.1   
     area 0.0.0.2   
    #               
    return   
  • Device B configuration file

    #
    sysname DeviceB
    #               
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.2 255.255.255.0
     ospf enable 1 area 0.0.0.1
     ospf enable multi-area 0.0.0.2
    #               
    interface GigabitEthernet2/0/0
     undo shutdown  
     ip address 10.1.3.1 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #               
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     ospf enable 1 area 0.0.0.2
    #               
    ospf 1          
     area 0.0.0.1   
     area 0.0.0.2   
    #               
    return         
  • Device C configuration file

    #
    sysname DeviceC
    #               
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.4.1 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #               
    interface GigabitEthernet2/0/0
     undo shutdown  
     ip address 10.1.2.2 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #               
    ospf 1          
     area 0.0.0.2   
    #               
    return      
  • Device D configuration file

    #
    sysname DeviceD
    #               
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.4.2 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #
    interface GigabitEthernet2/0/0
     undo shutdown  
     ip address 10.1.3.2 255.255.255.0
     ospf enable 1 area 0.0.0.2
    #               
    ospf 1          
     area 0.0.0.2   
    #               
    return          
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20573

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next