No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPF IP FRR

Example for Configuring OSPF IP FRR

This section describes how to configure OSPF IP FRR with an example, including how to block FRR on certain interfaces to prevent the links connected to these interfaces from functioning as backup links and how to bind OSPF IP FRR to a BFD session.

Networking Requirements

When a fault occurs on the primary link T, traffic is switched to a backup link. In such a scenario, two problems arise:
  • It takes hundreds of milliseconds for the traffic to be switched to a backup link. During this period, services are interrupted.
  • Traffic may be switched to the link that passes through Device A. Device A is an ASBR and is not expected to function as a backup device.

If a fault occurs on the network, OSPF IP FRR can fast switch traffic to the backup link without waiting for route convergence. This ensures uninterrupted traffic transmission. In addition, you can also prevent the link which passes through Device A from functioning as the backup link.

On the network shown in Figure 5-18:
  • All routers run OSPF.
  • The link cost meets the OSPF IP FRR traffic protection inequality.
  • If the primary link T fails, Device S immediately switches traffic to the backup link which passes through Device N.

  • Based on the network planning, the link which passes through Device A does not function as an FRR backup link.
Figure 5-18 Networking for configuring OSPF IP FRR
NOTE:

Interface 1, interface 2, interface 3, interface 4 in this example are GE 1/0/0, GE 2/0/0, GE 3/0/0, GE 1/0/1, respectively.


Precautions

When configuring OSPF IP FRR, note the following points:

Before configuring OSPF IP FRR, block FRR on certain interfaces to prevent the links connected to these interfaces from functioning as backup links. After that, the link where the interface resides is not calculated as a backup link during FRR calculation.

During the configuration of OSPF IP FRR, the lower layer needs to fast respond to a link change so that traffic can be rapidly switched to the backup link. After the bfd all-interfaces frr-binding command is run, the BFD session status is associated with the link status of an interface so that link faults can be rapidly detected.

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic OSPF functions on each ME device.

  2. Configure BFD for OSPF on all the devices in Area 0.

  3. Set the costs of links to ensure that link T is selected to transmit traffic.

  4. Block FRR on a specified interface of Device S.

  5. Enable OSPF IP FRR on Device S to protect the traffic forwarded by Device S.

Data Preparation

To complete the configuration, you need the following data.

Device

Router ID

Interface

IP Address

Device S

1.1.1.1

GE 1/0/0

10.1.1.1/24

GE 2/0/0

10.1.2.1/24

GE 3/0/0

10.1.3.1/24

Device A

2.2.2.2

GE 1/0/0

10.1.1.2/24

GE 2/0/0

10.2.1.2/24

Device N

3.3.3.3

GE 1/0/0

10.1.3.2/24

GE 2/0/0

10.2.3.2/24

Device E

4.4.4.4

GE 1/0/0

10.2.1.1/24

GE 2/0/0

10.1.2.2/24

GE 3/0/0

10.2.3.1/24

GE 1/0/1

172.17.1.1/24

Procedure

  1. Assign an IP address to each interface. For configuration details, see Configuration Files in this section.
  2. Configure basic OSPF functions. For details, see Example for Configuring Basic OSPF Functions.
  3. Configure BFD for OSPF on all the devices in Area 0. For details, see Example for Configuring BFD for OSPF.
  4. Set the costs of links to ensure that link T is selected to transmit traffic.

    # Configure Device S.

    [~DeviceS] interface gigabitethernet1/0/0
    [~DeviceS-GigabitEthernet1/0/0] ospf cost 10
    [*DeviceS-GigabitEthernet1/0/0] quit
    [~DeviceS] interface gigabitethernet2/0/0
    [~DeviceS-GigabitEthernet2/0/0] ospf cost 15
    [*DeviceS-GigabitEthernet2/0/0] quit
    [~DeviceS] interface gigabitethernet3/0/0
    [~DeviceS-GigabitEthernet3/0/0] ospf cost 10
    [*DeviceS-GigabitEthernet3/0/0] quit
    [*DeviceS] commit

    # Configure Device A.

    [~DeviceA] interface gigabitethernet2/0/0
    [~DeviceA-GigabitEthernet2/0/0] ospf cost 15
    [*DeviceA-GigabitEthernet2/0/0] quit
    [*DeviceA] commit

    # Configure Device N.

    [~DeviceN] interface gigabitethernet2/0/0
    [~DeviceN-GigabitEthernet2/0/0] ospf cost 10
    [*DeviceN-GigabitEthernet2/0/0] quit
    [*DeviceN] commit

  5. Block FRR on a specified interface of Device S.

    [~DeviceS] interface gigabitethernet1/0/0
    [~DeviceS-GigabitEthernet1/0/0] ospf frr block
    [*DeviceS-GigabitEthernet1/0/0] quit
    [*DeviceS] commit

  6. Enable OSPF IP FRR on Device S.

    # Enable OSPF IP FRR on Device S.

    [~DeviceS] ospf
    [*DeviceS-ospf-1] frr
    [*DeviceS-ospf-1-frr] loop-free-alternate
    [*DeviceS-ospf] commit

  7. Verify the configuration.

    # Run the display ospf routing router-id command on Device S to view routing information.

    [~DeviceS-ospf-1-frr] display ospf routing router-id 4.4.4.4
    
              OSPF Process 1 with Router ID 1.1.1.1
    
     Destination :    4.4.4.4             Route Type :       Intra-area
     Area        :    0.0.0.1             AdvRouter  :       4.4.4.4
     Type        :    ASBR                
     URT Cost    :    59
     NextHop     :    10.2.2.1.           Interface  :       GE2/0/0
     Backup Nexthop : 10.1.3.2         Backup Interface : GE3/0/0
     Backup Type : LFA LINK          

    The preceding display shows that a backup route is generated on Device S.

Configuration Files

  • Device S configuration file

    #
     sysname DeviceS
    #
     bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     ospf cost 5
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.2.1 255.255.255.0
     ospf cost 15
    #
    interface GigabitEthernet3/0/0
     ip address 10.1.3.1 255.255.255.0
     ospf frr block
     ospf cost 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1 router-id 1.1.1.1
     bfd all-interfaces enable
     bfd all-interfaces frr-binding
     frr
      loop-free-alternate
     area 0.0.0.1
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    return
  • Device A configuration file

    #
     sysname DeviceA
    #  
     bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     ospf cost 5
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.2 255.255.255.0
     ospf cost 5
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1 router-id 2.2.2.2
     bfd all-interfaces enable
     bfd all-interfaces frr-binding
     frr
      loop-free-alternate
     area 0.0.0.1
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
  • Device N configuration file

    #
     sysname DeviceN
    #
     bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.3.2 255.255.255.0
     ospf cost 10
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.3.2 255.255.255.0
     ospf cost 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1 router-id 3.3.3.3
     bfd all-interfaces enable
     bfd all-interfaces frr-binding
     frr
     area 0.0.0.1
      network 10.1.3.0 0.0.0.255
      network 10.2.3.0 0.0.0.255
    #
    return
  • Device E configuration file

    #
     sysname DeviceE
    #
     bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 10.2.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     ip address 172.17.1.1 255.255.255.0
     ospf cost 5
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1 router-id 4.4.4.4
     bfd all-interfaces enable
     bfd all-interfaces frr-binding
     area 0.0.0.1
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 172.17.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20870

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next