No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BFD for BGP

Example for Configuring BFD for BGP

After BFD for BGP is configured, BFD can fast detect the link fault between BGP peers and notify it to BGP so that service traffic can be transmitted along the backup link.

Networking Requirements

Voice and video services have high requirements for network reliability and stability. If a fault occurs on a network, quick service recovery is required (within 50 ms). BFD for BGP can meet this requirement.

In Figure 10-49, a primary link and a backup link are deployed on the network to ensure service transmission reliability. EBGP peer relationships are established between indirectly connected Device A and Device B, and between indirectly connected Device A and Device C. In most cases, traffic is transmitted along the primary link between Device A and Device B. If the primary link fails, it is required that BGP quickly detect this failure and switch traffic to the backup link (Device A -> Device C -> Device B).

BFD for BGP can be configured to speed up the link switchover. If the primary link between Device A and Device B fails, BFD can quickly detect the change in the BGP peer relationship and notify BGP of the change. Service traffic then will be switched to the backup link for transmission.

Figure 10-49 Configuring BFD for BGP
NOTE:

Interfaces 1 through 3 in this example are GE 1/0/0, GE 2/0/0, GE 3/0/0, respectively.



NOTE:

If two routers establish an EBGP peer relationship over a direct link, BFD for BGP is not required because the ebgp-interface-sensitive command is enabled by default for directly connected EBGP peers.

Precautions

When configuring BFD for BGP, note the following rules:

  • Before configuring BFD for BGP, enable BFD globally.

  • When configuring BFD for BGP, ensure that parameters configured on the two ends of a BFD session are consistent.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic BGP functions on each ME device.

  2. Configure the MED attribute to control route selection.

  3. Enable BFD on Device A and Device B

Data Preparation

To complete the configuration, you need the following data:

  • Router IDs and AS numbers of Device A, Device B, and Device C

  • Peer IP address to be detected by BFD

  • Minimum interval at which BFD Control packets are received and sent and the local detection multiplier

Procedure

  1. Configure an IP address for each interface on the ME devices. For configuration details, see Configuration Files in this section.
  2. Configure basic BGP functions, establish EBGP connections between Device A and Device B, and between Device A and Device C, and establish an IBGP connection between Device B and Device C.

    # Configure Device A.

    [~DeviceA] bgp 100
    [*DeviceA-bgp] router-id 1.1.1.1
    [*DeviceA-bgp] peer 200.1.1.2 as-number 200
    [*DeviceA-bgp] peer 200.1.1.2 ebgp-max-hop
    [*DeviceA-bgp] peer 200.1.2.2 as-number 200
    [*DeviceA-bgp] peer 200.1.2.2 ebgp-max-hop
    [*DeviceA-bgp] commit
    [~DeviceA-bgp] quit

    # Configure Device B.

    [~DeviceB] bgp 200
    [*DeviceB-bgp] router-id 2.2.2.2
    [*DeviceB-bgp] peer 200.1.1.1 as-number 100
    [*DeviceB-bgp] peer 200.1.1.1 ebgp-max-hop
    [*DeviceB-bgp] peer 9.1.1.2 as-number 200
    [*DeviceB-bgp] network 172.16.1.0 255.255.255.0
    [*DeviceB-bgp] commit
    [~DeviceB-bgp] quit

    # Configure Device C.

    [~Devicec] bgp 200
    [*Devicec-bgp] router-id 3.3.3.3
    [*Devicec-bgp] peer 200.1.2.1 as-number 100
    [*Devicec-bgp] peer 200.1.2.1 ebgp-max-hop
    [*Devicec-bgp] peer 9.1.1.1 as-number 200
    [*Devicec-bgp] commit
    [~Devicec-bgp] quit

    # Display peer information on Device A. The following command output shows that the BGP peer relationship has been established.

    <DeviceA> display bgp peer
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 2                 Peers in established state : 2
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
      200.1.1.2       4   200        2        5     0 00:01:25 Established       0
      200.1.2.2       4   200        2        4     0 00:00:55 Established       0

  3. Configure the MED attribute.

    # Configure a route-policy to set the MED value for the routes that Device B and Device C send to Device A.

    # Configure Device B.

    [~DeviceB] route-policy 10 permit node 10
    [*DeviceB-route-policy] apply cost 100
    [*DeviceB-route-policy] commit
    [~DeviceB-route-policy] quit
    [~DeviceB] bgp 200
    [*DeviceB-bgp] peer 200.1.1.1 route-policy 10 export
    [*DeviceB-bgp] commit

    # Configure Device C.

    [~DeviceC] route-policy 10 permit node 10
    [*DeviceC-route-policy] apply cost 150
    [*DeviceC-route-policy] commit
    [~DeviceC-route-policy] quit
    [~DeviceC] bgp 200
    [*DeviceC-bgp] peer 200.1.2.1 route-policy 10 export
    [*DeviceC-bgp] commit

    # Display the BGP routing table of Device A.

    <DeviceA> display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
     Total Number of Routes: 2
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>   172.16.1.0/24     200.1.1.2       100                   0      200i
     *                      200.1.2.2       150                   0      200i

    The command output shows that the next hop address of the route to 172.16.1.0/24 is 200.1.1.2 and that traffic is transmitted on the primary link Device A→Device B.

  4. Configure BFD, and set the interval at which BFD Control packets are received and sent and the local detection multiplier.

    # Enable BFD on Device A, set the minimum interval at which BFD Control packets are received and sent to 100 ms, and set the local detection multiplier to 4.

    [~DeviceA] bfd
    [*DeviceA-bfd] quit
    [*DeviceA] bgp 100
    [*DeviceA-bgp] peer 200.1.1.2 bfd enable
    [*DeviceA-bgp] peer 200.1.1.2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [*DeviceA-bgp] commit

    # Enable BFD on Device B, set the minimum interval at which BFD Control packets are received and sent to 100 ms, and set the local detection multiplier to 4.

    [~DeviceB] bfd
    [*DeviceB-bfd] quit
    [*DeviceB] bgp 200
    [*DeviceB-bgp] peer 200.1.1.1 bfd enable
    [*DeviceB-bgp] peer 200.1.1.1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [*DeviceB-bgp] commit

    # Check all the BFD sessions established on Device A.

    <DeviceA> display bgp bfd session all
    --------------------------------------------------------------------------------
      Local_Address      Peer_Address       Interface
      200.1.1.1          200.1.1.2          GigibitEthernet1/0/0
      Tx-interval(ms)    Rx-interval(ms)    Multiplier  Session-State
      100                100                4           Up
      Wtr-interval(m)
      10
    --------------------------------------------------------------------------------

  5. Verify the configuration.

    # Run the shutdown command on GE 2/0/0 of Device B to simulate a fault on the primary link.

    [~DeviceB] interface gigabitethernet 2/0/0
    [~DeviceB-GigabitEthernet2/0/0] shutdown
    [*DeviceB-GigabitEthernet2/0/0] commit

    # Display the BGP routing table of Device A.

    <DeviceA> display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>   172.16.1.0/24      200.1.2.2       150                   0      200i      

    The command output shows that the backup link Device A→Device C→Device B takes effect after the primary link fails and that the next hop address of the route to 172.16.1.0/24 has become 200.1.2.2.

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 200.1.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 200.1.1.1 255.255.255.0
    #
    bgp 100
     router-id 1.1.1.1
     peer 200.1.1.2 as-number 200
     peer 200.1.1.2 ebgp-max-hop 255
     peer 200.1.1.2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 200.1.1.2 bfd enable
     peer 200.1.2.2 as-number 200
     peer 200.1.2.2 ebgp-max-hop 255
     #
     ipv4-family unicast
      undo synchronization
      peer 200.1.1.2 enable
      peer 200.1.2.2 enable
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 9.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 200.1.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
    #
    bgp 200
     router-id 2.2.2.2
     peer 9.1.1.2 as-number 200
     peer 200.1.1.1 as-number 100
     peer 200.1.1.1 ebgp-max-hop 255
     peer 200.1.1.1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 200.1.1.1 bfd enable
     #
     ipv4-family unicast
      undo synchronization
      network 172.16.1.0 255.255.255.0
      peer 9.1.1.2 enable
      peer 200.1.1.1 enable
      peer 200.1.1.1 route-policy 10 export
    #
    route-policy 10 permit node 10
     apply cost 100
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 200.1.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
    undo shutdown
     ip address 9.1.1.2 255.255.255.0
    #
    bgp 200
     router-id 3.3.3.3
     peer 9.1.1.1 as-number 200
     peer 200.1.2.1 as-number 100
     peer 200.1.2.1 ebgp-max-hop 255
     #
     ipv4-family unicast
      undo synchronization
      peer 9.1.1.1 enable
      peer 200.1.2.1 enable
      peer 200.1.2.1 route-policy 10 export
    #
    route-policy 10 permit node 10
     apply cost 150
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20268

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next