No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS Route Summarization

Example for Configuring IS-IS Route Summarization

This section provides an example showing how to configure route summarization.

Networking Requirements

The IS-IS routing table of a device on a medium or large IS-IS network contains a large number of routing entries. Calculating and managing the routing table consumes a large number of memory resources. To solve this problem, summarize routes that share the same next hop and in the same network segment into one route. This function reduces the number of routes in a routing table and minimizes system resource consumption.

Figure 9-24 shows route summarization networking.

  • Device A, Device B, and Device C run IS-IS to communicate with each other.

  • Device A belongs to area 20. Device B and Device C belong to area 10.

  • Device A is a Level-2 device, Device B is a Level-1-2 device, and Device C is a Level-1 device.

  • Device B maintains both the Level-1 and Level-2 LSDBs. The routes to network segments 172.1.1.0/24, 172.1.2.0/24, and 172.1.3.0/24 in the Level-1 area can leak to the Level-2 area. If the interface with the IP address 172.1.1.1/24 on Device C regularly alternates between Up and Down, LSPs in the Level-2 area will be frequently flooded and Device A will frequently calculate routes using the SPF algorithm, which consumes a large number of CPU resources of Device A and may even cause route flapping on the network.

    To solve this problem, configure Device B to summarize routes to the three network segments into the route 172.1.0.0/16. This summarization reduces the number of routes to be maintained by Device B and prevents interface-state alteration in the Level-1 area from affecting route convergence in the Level-2 area.

Figure 9-24 IS-IS route summarization networking

Device Name

Interface

IP Address

Device A

GE1/0/0

172.2.1.1/24

Device B

GE1/0/0

172.1.4.2/24

GE2/0/0

172.2.1.2/24

Device C

GE1/0/0

172.1.4.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IS-IS on each ME device and check the IS-IS routing table.

  2. Configure Device B to summarize routes and check the IS-IS routing table.

Data Preparation

To complete the configuration, you need area ID of Device A (20), area ID of Device B and Device C (10), and system IDs starting from 0000.0000.0001.

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure basic IS-IS functions.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-2
    [*DeviceA-isis-1] network-entity 20.0000.0000.0001.00
    [*DeviceA-isis-1] quit
    [*DeviceA] interface gigabitethernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] isis enable 1
    [*DeviceA-GigabitEthernet2/0/0] commit
    [~DeviceA-GigabitEthernet2/0/0] quit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] isis enable 1
    [*DeviceB-GigabitEthernet2/0/0] quit
    [*DeviceB] interface gigabitethernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] isis enable 1
    [*DeviceB-GigabitEthernet1/0/0] commit
    [~DeviceB-GigabitEthernet1/0/0] quit

    # Configure Device C.

    [~DeviceC] isis 1
    [*DeviceC-isis-1] is-level level-1
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] quit
    [*DeviceC] interface gigabitethernet 1/0/0
    [*DeviceC-GigabitEthernet1/0/0] isis enable 1
    [*DeviceC-GigabitEthernet1/0/0] commit
    [~DeviceC-GigabitEthernet1/0/0] quit

    The configurations of GE 2/0/0, GE 3/0/0, and GE 1/0/1 are similar to those of GE 1/0/0. For configuration details, see Configuration Files in this section.

    # Display the IS-IS routing information on Device A.

    [~DeviceA] display isis route
                             Route information for ISIS(1)
                             -----------------------------
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     IPV4 Destination     IntCost    ExtCost ExitInterface  NextHop          Flags
    ----------------------------------------------------------------------------
     172.1.1.0/24         30         NULL    GE2/0/0        172.2.1.2      A/-/L/-
     172.1.2.0/24         30         NULL    GE2/0/0        172.2.1.2      A/-/L/-
     172.1.3.0/24         30         NULL    GE2/0/0        172.2.1.2      A/-/L/-
     172.1.4.0/24         20         NULL    GE2/0/0        172.2.1.2      A/-/L/-
     172.2.1.0/24         10         NULL    GE2/0/0        Direct         D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set

  3. Configure route summarization on Device B.

    # Summarize route 172.1.1.0/24, 172.1.2.0/24, 172.1.3.0./24, and 172.1.4.0/24 into 172.1.0.0/16 on Device B.

    [~DeviceB] isis 1
    [~DeviceB-isis-1] summary 172.1.0.0 255.255.0.0 level-1-2
    [*DeviceB-isis-1] commit
    [~DeviceB-isis-1] quit

  4. Verify the configuration.

    # Display the routing table of Device A. The following command output shows that routes 172.1.1.0/24, 172.1.2.0/24, 172.1.3.0/24, and 172.1.4.0/24 have been summarized into 172.1.0.0/16.

    [~DeviceA] display isis route
                             Route information for ISIS(1)
                             -----------------------------
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    ----------------------------------------------------------------------------
     172.1.0.0/16         20         NULL    GE2/0/0        172.2.1.2      A/-/L/-
     172.2.1.0/24         10         NULL    GE2/0/0        Direct         D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0001.00
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
    #
    return
  • Device B configuration file

    #
     sysname DeviceB
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     summary 172.1.0.0 255.255.0.0 level-1-2
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.1.4.2 255.255.255.0
     isis enable 1
    #
    return
  • Device C configuration file

    #
     sysname DeviceC
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.1.4.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 172.1.2.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 172.1.3.1 255.255.255.0
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20738

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next