No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Public Network IPv4 FRR

Example for Configuring Public Network IPv4 FRR

With public network IPv4 FRR, traffic can be rapidly switched to a backup link if the primary link fails.

Networking Requirements

On the network shown in Figure 2-9, it is required that the backup outbound interface and backup next hop be configured on Device T to ensure that Link B functions as a backup of Link A. If Link A fails, traffic is rapidly switched to the backup link (Link B).

Figure 2-9 Networking for configuring public network IPv4 FRR
NOTE:

Interfaces 1 through 3 in this example are GE 1/0/0, GE 2/0/0, GE 3/0/0, respectively.



Precautions

Before configuring public network IPv4 FRR, there must be at least two routes of different routing protocols but destined for the same IP address.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPF functions on Device T, Device A, and Device C ( OSPFv3 process ID is 1 ).

  2. Configure basic IS-IS functions on Device T, Device B, and Device C.

  3. Enable public network IPv4 FRR on Device T, and check the backup outbound interface and backup next hop.

  4. Disable IPv4 FRR, and check the backup outbound interface and backup next hop.

Data Preparation

To complete the configuration, you need the following data:

  • OSPF process IDs of Device T, Device A, and Device C

  • IS-IS area addresses of Device T, Device B, and Device C

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure OSPF on Device T, Device A, and Device C. For configuration details, see Configuration Files in this section.
  3. Configure IS-IS on Device T, Device B, and Device C. For configuration details, see Configuration Files in this section.
  4. Check routing information.

    # Check the routes to 172.11.1.0 on Device T.

    <DeviceT> display ip routing-table 172.11.1.0 verbose
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 1        Routes : 2
    
    Destination: 172.11.1.0/24
         Protocol: OSPF            Process ID: 1
       Preference: 10                    Cost: 3
          NextHop: 192.158.10.2     Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h00m07s
              Tag: 0                 Priority: low
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x40000041
     RelayNextHop: 0.0.0.0          Interface: GigabitEthernet2/0/0
         TunnelID: 0x0                  Flags: D
    
    Destination: 172.11.1.0/24
         Protocol: ISIS            Process ID: 1
       Preference: 15                    Cost: 30
          NextHop: 192.158.20.2     Neighbour: 0.0.0.0
            State: Inactive Adv           Age: 00h01m26s
              Tag: 0                 Priority: high
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x80000081
     RelayNextHop: 0.0.0.0          Interface: GigabitEthernet3/0/0
         TunnelID: 0x0                  Flags: 0

    In the routing table, you can view that there are two routes to 172.11.1.0/24. The route with 192.158.10.2 as the next hop is optimal because the OSPF route priority is higher than the IS-IS route priority.

  5. Enable public network IPv4 FRR.

    # Enable IPv4 FRR on Device T.

    [~DeviceT] ip frr
    [*DeviceT] commit

    # Check the backup outbound interface and backup next hop on Device T.

    <DeviceT> display ip routing-table 172.11.1.0 verbose
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 1        Routes : 2
    
    Destination: 172.11.1.0/24
         Protocol: OSPF            Process ID: 1
       Preference: 10                    Cost: 3
          NextHop: 192.158.10.2     Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h01m36s
              Tag: 0                 Priority: low
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x40000041
     RelayNextHop: 0.0.0.0          Interface: GigabitEthernet2/0/0
         TunnelID: 0x0                  Flags: D
        BkNextHop: 192.158.20.2   BkInterface: GigabitEthernet3/0/0
          BkLabel: NULL           SecTunnelID: 0x0
     BkPETunnelID: 0x0        BkPESecTunnelID: 0x0
     BkIndirectID: 0x80000081
    
    Destination: 172.11.1.0/24
         Protocol: ISIS            Process ID: 1
       Preference: 15                    Cost: 30
          NextHop: 192.158.20.2     Neighbour: 0.0.0.0
            State: Inactive Adv           Age: 00h02m55s
              Tag: 0                 Priority: high
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x80000081
     RelayNextHop: 0.0.0.0          Interface: GigabitEthernet3/0/0
         TunnelID: 0x0                  Flags: 0

    The routing table shows that the route to 172.11.1.0/24 has the backup outbound interface and backup next hop and that the IS-IS route is the backup route.

  6. Verify the configuration.

    # Simulate a link fault on Device T.

    [~DeviceT] interface gigabitethernet 2/0/0
    [~DeviceT-GigabitEthernet2/0/0] shutdown
    [*DeviceT-GigabitEthernet2/0/0] commit
    [~DeviceT-GigabitEthernet2/0/0] quit

    # Check the routes to 172.11.1.0/24 on Device T.

    <DeviceT> display ip routing-table 172.11.1.0 verbose
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 1        Routes : 1
    
    Destination: 172.11.1.0/24
         Protocol: ISIS            Process ID: 1
       Preference: 15                    Cost: 30
          NextHop: 192.158.20.2     Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h57m30s
              Tag: 0                 Priority: high
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x80000081
     RelayNextHop: 0.0.0.0          Interface: GigabitEthernet3/0/0
         TunnelID: 0x0                  Flags: D
    

    The preceding command output shows that traffic has been switched to the backup link (Link B).

Configuration Files

  • Device T configuration file

    #
    sysname DeviceT
    #
    ip frr
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    # 
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.10.1.1 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.158.10.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.158.20.1 255.255.255.0
     isis enable 1
    #
    ospf 1
     area 0.0.0.0
      network 192.158.10.0 0.0.0.255
     area 0.0.0.1
      network 172.10.1.0 0.0.0.255
    #
    return
  • Device A configuration file

    #
    sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.158.10.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.158.11.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.158.10.0 0.0.0.255
      network 192.158.11.0 0.0.0.255
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    isis 1
     network-entity 10.0000.0000.0002.00 
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.158.20.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.158.21.2 255.255.255.0
     isis enable 1
    #
    return
  • Device C configuration file

    sysname DeviceC
    #
    isis 1
     network-entity 10.0000.0000.0003.00 
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.11.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.158.11.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.158.21.1 255.255.255.0
     isis enable 1
    #
    ospf 1
     area 0.0.0.0
      network 192.158.11.0 0.0.0.255
      network 192.158.21.0 0.0.0.255
     area 0.0.0.2
      network 172.11.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20446

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next