No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic RIP Functions

Example for Configuring Basic RIP Functions

This section describes how to configure basic RIP functions, including how to enable RIP and configure the RIP version number on each device.

Networking Requirements

On the network shown in Figure 7-7, it is required that RIP be enabled on all interfaces of Device A, Device B, Device C, and Device D and that the Devices communicate with each other through RIP-2.

Figure 7-7 Configuring basic RIP functions
NOTE:

Interface 1, interface 2, interface 3 in this example are GE 1/0/0, GE 2/0/0, GE 3/0/0, respectively.



Precautions

During the configuration, note the following rules:

  • Different network segments on the same physical interface must be configured in the same RIP process.

  • If a RIP process is bound to a VPN instance, the interfaces in this RIP process also need to be bound to this VPN instance.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces to ensure that neighboring nodes are reachable at the network layer.

  2. Enable RIP on each ME device and configure basic RIP functions.

  3. Configure RIP-2 on each ME device and view the subnet masks.

Data Preparation

To complete the configuration, you need the following data:

  • RIP network segment 192.168.1.0 on Device A

  • RIP network segments 192.168.1.0, 172.16.0.0, and 10.0.0.0 on Device B

  • RIP network segment 172.16.0.0 on Device C

  • RIP network segment 10.0.0.0 on Device D

  • RIP-2 on Device A, Device B, Device C, and Device D

Procedure

  1. Configure an IP address for each interface.

    For configuration details, see Configuration Files in this section.

  2. Configure the network segments to be enabled with RIP.

    # Configure Device A.

    [~DeviceA] rip
    [*DeviceA-rip-1] network 192.168.1.0
    [*DeviceA-rip-1] commit
    [~DeviceA-rip-1] quit

    # Configure Device B.

    [~DeviceB] rip
    [*DeviceB-rip-1] network 192.168.1.0
    [*DeviceB-rip-1] network 172.16.0.0
    [*DeviceB-rip-1] network 10.0.0.0
    [*DeviceB-rip-1] commit
    [~DeviceB-rip-1] quit

    # Configure Device C.

    [~DeviceC] rip
    [*DeviceC-rip-1] network 172.16.0.0
    [*DeviceC-rip-1] commit
    [~DeviceC-rip-1] quit

    # Configure Device D.

    [~DeviceD] rip
    [*DeviceD-rip-1] network 10.0.0.0
    [*DeviceD-rip-1] commit
    [~DeviceD-rip-1] quit

    # Check the RIP routing table of Device A.

    [~DeviceA] display rip 1 route
     Route Flags: R - RIP, T - TRIP
                  P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on GigabitEthernet1/0/0
          Destination/Mask        Nexthop     Cost   Tag     Flags   Sec
             10.0.0.0/8        192.168.1.2      1    0        RA      14
            172.16.0.0/16      192.168.1.2      1    0        RA      14
            192.168.1.0/24     192.168.1.2      1    0        RA      14

    The preceding command output shows that the routes advertised by RIP-1 use natural masks.

  3. Configure the RIP version number.

    # Configure RIP-2 on Device A.

    [~DeviceA] rip
    [~DeviceA-rip-1] version 2
    [*DeviceA-rip-1] commit
    [~DeviceA-rip-1] quit

    # Configure RIP-2 on Device B.

    [~DeviceB] rip
    [~DeviceB-rip-1] version 2
    [*DeviceB-rip-1] commit
    [~DeviceB-rip-1] quit

    # Configure RIP-2 on Device C.

    [~DeviceC] rip
    [~DeviceC-rip-1] version 2
    [*DeviceC-rip-1] commit
    [~DeviceC-rip-1] quit

    # Configure RIP-2 on Device D.

    [~DeviceD] rip
    [~DeviceD-rip-1] version 2
    [*DeviceD-rip-1] commit
    [~DeviceD-rip-1] quit

  4. Verify the configuration.

    # Check the RIP routing table of Device A.

    [~DeviceA] display rip 1 route
    Route Flags: R - RIP
              A - Aging, S - Suppressed, G - Garbage-collect 
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on GigabitEthernet1/0/0
          Destination/Mask        Nexthop       Cost   Tag     Flags   Sec
             10.1.1.0/24         192.168.1.2      1    0        RA      32
            172.16.1.0/24        192.168.1.2      1    0        RA      32
            192.168.1.0/24       192.168.1.2      1    0        RA      14

    The preceding command output shows that the routes advertised by RIP-2 contain accurate subnet masks.

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    rip 1
     version 2
     network 10.0.0.0
     network 172.16.0.0
     network 192.168.1.0
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.1.2 255.255.255.0
    #
    rip 1
     version 2
     network 172.16.0.0
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    rip 1
     version 2
     network 10.0.0.0
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20431

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next