No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - IP Routing 01

This is ME60 V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BGP to Interact with an IGP

Example for Configuring BGP to Interact with an IGP

Configuring BGP to interact with an IGP can enrich routing tables.

Networking Requirements

As the Internet grows, devices in different networks need to access each other, data needs to be reliably transmitted, and the traffic interruption time needs to be minimized. This requires that routing information be transmitted widely and network convergence be accelerated. BGP can transmit routing information efficiently and widely. BGP, however, does not calculate routes by itself. An IGP can implement rapid route convergence, but it transmits routing information with a low efficiency in a limited scope. After BGP is configured to interact with an IGP, IGP routes can be imported into BGP routing tables and transmitted efficiently, and BGP routes can also be imported to IGP routing tables so that ASs can access each other.

The network shown in Figure 10-38 is divided into AS 65008 and AS 65009. In AS 65009, an IGP is used to calculate routes. In this example, OSPF is used as an IGP. BGP can be configured to enable the two ASs to access each other. Interaction between BGP and the IGP can be configured on edge ME devices in the two ASs so that the two ASs can exchange routes efficiently.

Figure 10-38 Configuring BGP to interact with an IGP
NOTE:

Interfaces 1 through 2 in this example are GE 1/0/0, GE 2/0/0, respectively.



Precautions

None.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure OSPF on Device B and Device C.

  2. Establish an EBGP connection between Device A and Device B.

  3. Configure BGP and OSPF to import routes from each other on Device B and then check the routes.

  4. Configure BGP route summarization on Device B to simplify the BGP routing table.

Data Preparation

To complete the configuration, you need the following data:

  • Router ID and AS number of Device A

  • Router IDs and AS numbers of Device B and Device C

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure OSPF.

    # Configure Device B.

    [~DeviceB] ospf 1
    [*DeviceB-ospf-1] area 0
    [*DeviceB-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [*DeviceB-ospf-1-area-0.0.0.0] commit
    [~DeviceB-ospf-1-area-0.0.0.0] quit
    [~DeviceB-ospf-1] quit

    # Configure Device C.

    [~DeviceC] ospf 1
    [*DeviceC-ospf-1] area 0
    [*DeviceC-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] network 9.1.2.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] commit
    [~DeviceC-ospf-1-area-0.0.0.0] quit
    [~DeviceC-ospf-1] quit

  3. Configure an EBGP connection.

    # Configure Device A.

    [~DeviceA] bgp 65008
    [*DeviceA-bgp] router-id 1.1.1.1
    [*DeviceA-bgp] peer 3.1.1.1 as-number 65009
    [*DeviceA-bgp] ipv4-family unicast
    [*DeviceA-bgp-af-ipv4] network 8.1.1.0 255.255.255.0
    [*DeviceA-bgp-af-ipv4] commit

    # Configure Device B.

    [~DeviceB] bgp 65009
    [*DeviceB-bgp] router-id 2.2.2.2
    [*DeviceB-bgp] peer 3.1.1.2 as-number 65008
    [*DeviceB-bgp] commit

  4. Configure BGP to interact with an IGP.

    # Configure BGP to import OSPF routes on Device B.

    [~DeviceB-bgp] ipv4-family unicast
    [*DeviceB-bgp-af-ipv4] import-route ospf 1
    [*DeviceB-bgp-af-ipv4] commit
    [~DeviceB-bgp-af-ipv4] quit
    [~DeviceB-bgp] quit

    # Check the routing table of Device A.

    [~DeviceA] display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
     Total Number of Routes: 3
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>   8.1.1.0/24         0.0.0.0         0                     0      i
     *>   9.1.1.0/24         3.1.1.1         1                     0      65009?
     *>   9.1.2.0/24         3.1.1.1         2                     0      65009?

    # Configure OSPF to import BGP routes on Device B.

    [~DeviceB] ospf
    [*DeviceB-ospf-1] import-route bgp
    [*DeviceB-ospf-1] commit
    [~DeviceB-ospf-1] quit

    # Check the routing table of Device C.

    [~DeviceC] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables : _public_
             Destinations : 12        Routes : 12
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
            8.1.1.0/24  O_ASE  150  1             D  9.1.1.1         GigabitEthernet1/0/0
            9.1.1.0/24  Direct 0    0             D  9.1.1.2         GigabitEthernet1/0/0
            9.1.1.1/32  Direct 0    0             D  9.1.1.1         GigabitEthernet1/0/0
            9.1.1.2/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
          9.1.1.255/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
            9.1.2.0/24  Direct 0    0             D  9.1.2.1         GigabitEthernet2/0/0
            9.1.2.1/32  Direct 0    0             D  127.0.0.1       GigabitEthernet2/0/0
          9.1.2.255/32  Direct 0    0             D  127.0.0.1       GigabitEthernet2/0/0
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    

  5. Configure automatic route summarization.

    # Configure Device B.

    [~DeviceB] bgp 65009
    [*DeviceB-bgp] ipv4-family unicast
    [*DeviceB-bgp-af-ipv4] summary automatic
    [*DeviceB-bgp-af-ipv4] commit

    # Check the BGP routing table of Device A.

    [~DeviceA] display bgp routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
     Total Number of Routes: 2
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>   8.1.1.0/24         0.0.0.0         0                     0      i
     *>   9.0.0.0            3.1.1.1                               0      65009?

    # Verify the configuration by using the ping command.

    [*DeviceA] ping -a 8.1.1.1 9.1.2.1
      PING 9.1.2.1: 56  data bytes, press CTRL_C to break
        Reply from 9.1.2.1: bytes=56 Sequence=1 ttl=254 time=15 ms
        Reply from 9.1.2.1: bytes=56 Sequence=2 ttl=254 time=31 ms
        Reply from 9.1.2.1: bytes=56 Sequence=3 ttl=254 time=47 ms
        Reply from 9.1.2.1: bytes=56 Sequence=4 ttl=254 time=46 ms
        Reply from 9.1.2.1: bytes=56 Sequence=5 ttl=254 time=47 ms
      --- 9.1.2.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 15/37/47 ms

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 8.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 3.1.1.2 255.255.255.0
    #
    bgp 65008
     router-id 1.1.1.1
     peer 3.1.1.1 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      network 8.1.1.0 255.255.255.0
      peer 3.1.1.1 enable
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 9.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 3.1.1.1 255.255.255.0
    #
    bgp 65009
     router-id 2.2.2.2
     peer 3.1.1.2 as-number 65008
     #
     ipv4-family unicast
      undo synchronization
      summary automatic
      import-route ospf 1
      peer 3.1.1.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 9.1.1.0 0.0.0.255
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 9.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 9.1.2.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 9.1.1.0 0.0.0.255
      network 9.1.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059437

Views: 20399

Downloads: 15

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next