No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Static VXLAN Active-Active Scenario (Layer 3 Communication)

Example for Configuring the Static VXLAN Active-Active Scenario (Layer 3 Communication)

In the scenario where a data center is interconnected with an enterprise site, a CE is dual-homed to a VXLAN network. In this way, carriers can enhance VXLAN access reliability to improve the stability of user services so that rapid convergence can be implemented in case of a fault.

Networking Requirements

In Figure 17-24, the CPE establishes static VXLAN tunnels with PE1 and PE2. An EVPN peer relationship and a bypass VXLAN tunnel are established between PE1 and PE2. CE1 is dual-homed to PE1 and PE2. When a PE fails, traffic can rapidly switch to the other PE.

Figure 17-24 Networking diagram for configuring the static VXLAN active-active scenario (Layer 3 communication)
NOTE:

Interface 1, interface 2, and interface 3 stand for GigabitEthernet1/0/1, GigabitEthernet1/0/2 , and GigabitEthernet1/0/3, respectively.



Table 17-9 Interface IP address

Device

Interface

IP Address

PE1

GigabitEthernet 1/0/1

10.1.20.1/24

GigabitEthernet 1/0/2

192.168.1.1/24

GigabitEthernet 1/0/3

10.1.1.1/24

LoopBack1

1.1.1.1/24

LoopBack2

3.3.3.3/32

PE2

GigabitEthernet 1/0/1

10.1.20.2/24

GigabitEthernet 1/0/2

192.168.2.1/24

GigabitEthernet 1/0/3

10.1.2.1/24

LoopBack1

2.2.2.2/32

LoopBack2

3.3.3.3/32

CE

GigabitEthernet 1/0/1

192.168.1.2/24

GigabitEthernet 1/0/2

192.168.2.2/24

LoopBack1

5.5.5.5/32

CPE

GigabitEthernet 1/0/1

10.1.1.2/24

GigabitEthernet 1/0/2

10.1.2.2/24

GigabitEthernet 1/0/3

192.168.3.1/24

LoopBack1

4.4.4.4/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on the PEs and CPE to implement Layer 3 network connectivity.
  2. Configure CE1 to import routes from the VPN instances of the PEs through BGP. Configure CE1 to be dual-homed to PE1 and PE2.
  3. Configure service access points on PE1 and PE2.
  4. Configure the same virtual Anycast VTEP address on PE1 and PE2 as the source NVE interface address to establish a VXLAN tunnel with the CPE. Establish static VXLAN tunnels between the PEs and CPE so that the PEs and CEP can communicate.
  5. Enable the inter-chassis VXLAN function on PE1 and PE2, configure different bypass addresses for PE1 and PE2, and establish a BGP EVPN peer relationship and a bypass VXLAN tunnel between PE1 and PE2 so that PE1 and PE2 can communicate.
  6. Enable auto-FRR in the BGP VPN address family view of PE1 and PE2. When a PE fails, the downstream traffic of the CPE can quickly switch to the other PE.

Procedure

  1. Assign an IP address to each interface on each node, and configure loopback interface addresses.

    For detailed configurations, see Configuration Files.

  2. Configure an IGP on the DCI backbone. In this example, IS-IS is adopted.

    For detailed configurations, see Configuration Files.

  3. Configure EVPN.

    Configure PE1.

    [~PE1] evpn
    [*PE1-evpn] bypass-vxlan enable
    [*PE1-evpn] quit
    [*PE1] commit

    Repeat this step for PE2. For configuration details, see Configuration Files in this section.

  4. Configuring VPN Instances

    Configure PE1.

    [~PE1] ip vpn-instance vpn1
    [*PE1-vpn-instance-vpn1] ipv4-family
    [*PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 1:1
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 import-extcommunity
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 export-extcommunity
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 import-extcommunity evpn
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 export-extcommunity evpn
    [*PE1-vpn-instance-vpn1-af-ipv4] quit
    [*PE1-vpn-instance-vpn1] quit
    [*PE1] commit

    Repeat this step for PE2. For configuration details, see Configuration Files in this section.

  5. Configure BGP and BGP VPN peer relationships.

    # Configure CE1.

    [~CE1] bgp 200
    [*CE1-bgp] peer 192.168.1.1 as-number 100
    [*CE1-bgp] peer 192.168.1.1 ebgp-max-hop 255
    [*CE1-bgp] peer 192.168.2.1 as-number 100
    [*CE1-bgp] peer 192.168.2.1 ebgp-max-hop 255
    [*CE1-bgp] network 5.5.5.5 255.255.255.255
    [*CE1-bgp] quit
    [*CE1] commit

    # Configure PE1.

    [~PE1] bgp 100
    [*PE1-bgp] peer 2.2.2.2 as-number 100
    [*PE1-bgp] peer 2.2.2.2 connect-interface LoopBack 1
    [*PE1-bgp] ipv4-family vpn-instance vpn1
    [*PE1-bgp-vpn1] auto-frr
    [*PE1-bgp-vpn1] peer 192.168.1.2 as-number 200
    [*PE1-bgp-vpn1] peer 192.168.1.2 connect-interface GigabitEthernet0/1/2
    [*PE1-bgp-vpn1] advertise l2vpn evpn
    [*PE1-bgp-vpn1] quit
    [*PE1-bgp] l2vpn-family evpn
    [*PE1-bgp-af-evpn] undo policy vpn-target
    [*PE1-bgp-af-evpn] peer 2.2.2.2 enable
    [*PE1-bgp-af-evpn] peer 2.2.2.2 advertise encap-type vxlan
    [*PE1-bgp-af-evpn] quit
    [*PE1-bgp] quit
    [*PE1] commit

    Repeat this step for PE2. For configuration details, see Configuration Files in this section.

  6. Create static VXLAN tunnels between the CPE and PE1 and between the CPE and PE2 and a bypass VXLAN tunnel between PE1 and PE2.

    # Configure the CPE.

    [*CPE] interface nve 1
    [*CPE-Nve1] source 4.4.4.4
    [*CPE-Nve1] vni 10 head-end peer-list 3.3.3.3
    [*CPE-Nve1] quit
    [*CPE] commit

    # Configure PE1.

    [~PE1] bridge-domain 10
    [*PE1-bd10] vxlan vni 10 split-horizon-mode
    [*PE1-bd10] quit
    [*PE1] interface nve 1
    [*PE1-Nve1] source 3.3.3.3
    [*PE1-Nve1] bypass source 1.1.1.1
    [*PE1-Nve1] mac-address 0009-0009-0009
    [*PE1-Nve1] vni 10 head-end peer-list 4.4.4.4
    [*PE1-Nve1] quit
    [*PE1] commit

    Repeat this step for PE2. For configuration details, see Configuration Files in this section.

  7. Configure VBDIF interfaces and bind them to VPN instances.

    # Configure PE1.

    [~PE1] interface vbdif10
    [*PE1-Vbdif10] ip binding vpn-instance vpn1
    [*PE1-Vbdif10] ip address 10.1.10.1 24
    [*PE1-Vbdif10] arp collect host enable
    [*PE1-Vbdif10] mac-address 0010-0010-0010
    [*PE1-Vbdif10] quit
    [*PE1] commit

    Repeat this step for PE2. For configuration details, see Configuration Files in this section.

  8. Verify the configuration.

    Run the display vxlan tunnel command on PE1 to view VXLAN tunnel information. The following example uses the command output on PE1.

    [~PE1] display vxlan tunnel
    Number of vxlan tunnel : 1
    Tunnel ID   Source           Destination      State  TyPE    Uptime
    -------------------------------------------------------------------
    4026531841  1.1.1.1          2.2.2.2          up     dynamic       0033h12m
    4026531842  3.3.3.3          4.4.4.4          up     dynamic       0033h12m

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    evpn
     bypass-vxlan enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      vpn-target 1:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity evpn
     vxlan vni 100
    #
    bridge-domain 10
     vxlan vni 10 split-horizon-mode
    #
    isis 1
     network-entity 10.0000.0000.0010.00
     frr
    #
    isis 2 vpn-instance vpn1
     network-entity 20.0000.0000.0010.00
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ip address 10.1.10.1 255.255.255.0
     isis enable 2
     mac-address 0010-0010-0010
     arp collect host enable
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.20.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 192.168.1.1 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    interface LoopBack2
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    interface Nve1
     source 3.3.3.3
     bypass source 1.1.1.1
     mac-address 0009-0009-0009
     vni 10 head-end peer-list 4.4.4.4
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpn1
      auto-frr
      peer 192.168.1.2 as-number 200
      peer 192.168.1.2 connect-interface GigabitEthernet0/1/2
      advertise l2vpn evpn
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise encap-type vxlan
    #
    return
    
  • PE2 configuration file

    #
    sysname PE2
    #
    evpn
     bypass-vxlan enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      vpn-target 1:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity evpn
     vxlan vni 100
    #
    bridge-domain 10
     vxlan vni 10 split-horizon-mode
    #
    isis 1
     network-entity 10.0000.0000.0020.00
     frr
    #
    isis 2 vpn-instance vpn1
     network-entity 20.0000.0000.0020.00
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ip address 10.1.10.1 255.255.255.0
     isis enable 2
     mac-address 0010-0010-0010
     arp collect host enable
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.20.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip binding vpn-instance vpn1
     ip address 192.168.2.1 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    interface LoopBack2
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    interface Nve1
     source 3.3.3.3
     bypass source 2.2.2.2
     mac-address 0009-0009-0009
     vni 10 head-end peer-list 4.4.4.4
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance vpn1
      auto-frr
      peer 192.168.2.2 as-number 200
      peer 192.168.2.2 connect-interface GigabitEthernet0/1/2  
      advertise l2vpn evpn
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise encap-type vxlan
    #
    return
    
  • CE1 configuration file

    # 
    sysname CE1
    #
    isis 2
     network-entity 20.0000.0000.0030.00
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 192.168.2.2 255.255.255.2
     isis enable 2
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     #
    bgp 200
     peer 192.168.1.1 as-number 100
     peer 192.168.1.1 ebgp-max-hop 255
     peer 192.168.2.1 as-number 100
     peer 192.168.2.1 ebgp-max-hop 255
    #
     ipv4-family unicast
      network 5.5.5.5 255.255.255.255
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
    #
    return
    
  • CPE configuration file

    #
    sysname CPE
    #
    bridge-domain 10 
     vxlan vni 10 split-horizon-mode
    #
    isis 1
     network-entity 20.0000.0000.0001.00
     frr
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    #
    interface Nve1
     source 4.4.4.4 
     vni 10 head-end peer-list 3.3.3.3
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059440

Views: 29483

Downloads: 21

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next