No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Ethernet Sub-interfaces for Communication Between VLAN Users and Non-VLAN Users

Example for Configuring Ethernet Sub-interfaces for Communication Between VLAN Users and Non-VLAN Users

This example describes how to configure communication between VLAN users and non-VLAN users.

Networking Requirements

Users in a community belong to different network segments. The network administrator in the community adds the users to different VLANs to simplify management. However, users in another community are not added to any VLAN. VLAN users must be able to communicate with non-VLAN users.

On the network shown in Figure 3-5, users in community 1 belong to different VLANs and network segments, and users in community 2 do not belong to any VLAN. It is required that users in VLAN 10 be able to communicate with users in community 2.

Figure 3-5 Networking for configuring Ethernet sub-interfaces for communication between VLAN users and non-VLAN users
NOTE:

The subinterface1.1, interface2 in this example are GE1/0/1.1, GE2/0/1, respectively.



Precautions

  • The IP address assigned to the sub-interface connected to VLAN users must be on the same network segment as IP addresses of VLAN users.
  • The IP address assigned to the interface connected to non-VLAN users must be on the same network segment as IP addresses of non-VLAN users.
  • The default gateway addresses of PCs in VLAN 10 must be the IP address of the sub-interface. Otherwise, VLAN and non-VLAN users cannot communicate with each other.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create sub-interfaces on the PE and associate the sub-interfaces with VLANs so that the sub-interfaces can identify packets carrying VLAN tags.

  2. Assign IP addresses to interfaces for communication at the network layer.

    • Assign an IP address to the sub-interface.
    • Assign an IP address to the interface connecting the PE to non-VLAN users.

Data Preparation

To complete the configuration, you need the following data:

  • VLAN ID associated with the PE sub-interface

  • IP address of the PE sub-interface

Procedure

  1. Create a sub-interface on the PE and associate the sub-interface with a VLAN.

    <HUAWEI> system-view
    [~HUAWEI] syname PE
    [*HUAWEI] commit
    [~PE] interface gigabitethernet 1/0/1
    [~PE-GigabitEthernet1/0/1] undo shutdown
    [*PE] interface gigabitethernet 1/0/1.1
    [*PE-GigabitEthernet1/0/1.1] vlan-type dot1q 10

  2. Configure IP addresses.

    [*PE-GigabitEthernet1/0/1.1] ip address 10.110.2.5 24
    [*PE-GigabitEthernet1/0/1.1] quit
    [*PE] interface gigabitethernet 2/0/1
    [*PE-GigabitEthernet2/0/1] undo shutdown
    [*PE-GigabitEthernet2/0/1] ip address 10.110.3.5 24
    [*PE-GigabitEthernet2/0/1] quit
    [*PE] commit

  3. For the detailed configuration of the switch, see the related Configuration Guide.
  4. Verify the configuration.

    On PCs in VLAN 10, configure the IP address 10.110.2.5/24 of GE 1/0/1.1 as the default gateway address.

    On CE 2, configure the IP address 10.110.3.5 of GE 2/0/1 as the default gateway address.

    After the configurations are complete, users in VLAN 10 and non-VLAN users can ping each other.

PE Configuration File

#
sysname PE
#
interface GigabitEthernet1/0/1
 undo shutdown
#
interface GigabitEthernet1/0/1.1
 vlan-type dot1q 10
 ip address 10.110.2.5 255.255.255.0
#
interface GigabitEthernet2/0/1
 undo shutdown
 ip address 10.110.3.5 255.255.255.0
#
return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059440

Views: 29296

Downloads: 21

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next