No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Sub-interface for QinQ VLAN Tag Termination to Support Proxy ARP

Example for Configuring the Sub-interface for QinQ VLAN Tag Termination to Support Proxy ARP

This example shows how to configure a sub-interface for QinQ VLAN tag termination to support proxy ARP, and how to enable the interworking between users who are on the same network segment but different VLANs.

Networking Requirements

A range of VLANs can connect to a network segment using VLAN tag termination sub-interfaces. However, if users on the same network segment belong to different VLANs, these users cannot communicate at Layer 2, and rely on IP forwarding at Layer 3 to communicate with each other. You can configure VLAN tag termination sub-interfaces to support proxy ARP so that users from different VLANs can communicate.

As shown in Figure 9-20, PE1 connects to CE3 through an Ethernet sub-interface; CE3 connects to CE1 and CE2 which connects to both PC1 and PC2. PC1 and PC2 belong to the same network segment but are on different VLANs. PC1 and PC2 have no default gateway. Packets received by PE1 carry two VLAN tags. In this situation, you can configure GE1/0/1.1 on PE1 as a sub-interface for QinQ VLAN tag termination and enable proxy ARP on the sub-interface so that PC1 and PC2 can communicate.

Figure 9-20 Typical networking for configuring the sub-interface for QinQ VLAN tag termination to support proxy ARP
NOTE:

Interfaces 1 through 3 and subinterface1.1 in this example are GE1/0/1, GE1/0/2, GE1/0/3, GE1/0/1.1, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs on CE1 and CE2 and determine the VLANs to which users belong.

  2. Configure the QinQ function on CE3 so that packets sent by CE3 to PE1 carry two VLAN tags.

  3. Configure a sub-interface for QinQ VLAN tag termination and enable proxy ARP on the sub-interface on PE1 so that users from different VLANs can communicate.

Data Preparation

To complete the configuration, you need the following data:

  • VLAN ID in the outer VLAN tag of packets sent by CE3 to PE1.
  • User VLAN IDs
  • User IP addresses
  • Names of interfaces that connect the CEs
  • Names of interfaces that connect PE1 and CE3
  • Names of interfaces that connect CE1 and CE2 to PCs

Procedure

  1. Create VLANs on CE1 and CE2 and associate the VLANs with Layer 2 interfaces.

    # Configure CE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] vlan 10
    [*CE1-vlan10] quit
    [*CE1] interface gigabitethernet 1/0/1
    [*CE1-GigabitEthernet1/0/1] undo shutdown
    [*CE1-GigabitEthernet1/0/1] portswitch
    [*CE1-GigabitEthernet1/0/1] port link-type access
    [*CE1-GigabitEthernet1/0/1] port default vlan 10
    [*CE1-GigabitEthernet1/0/1] quit
    [*CE1] interface gigabitethernet 1/0/2
    [*CE1-GigabitEthernet1/0/2] undo shutdown
    [*CE1-GigabitEthernet1/0/2] portswitch
    [*CE1-GigabitEthernet1/0/2] port link-type trunk
    [*CE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [*CE1-GigabitEthernet1/0/2] quit
    [*CE1] commit

    # Configure CE2.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE2
    [*HUAWEI] commit
    [~CE2] vlan 20
    [*CE2-vlan20] quit
    [*CE2] interface gigabitethernet 1/0/1
    [*CE2-GigabitEthernet1/0/1] undo shutdown
    [*CE2-GigabitEthernet1/0/1] portswitch
    [*CE2-GigabitEthernet1/0/1] port link-type access
    [*CE2-GigabitEthernet1/0/1] port default vlan 20
    [*CE2-GigabitEthernet1/0/1] quit
    [*CE2] interface gigabitethernet 1/0/2
    [*CE2-GigabitEthernet1/0/2] undo shutdown
    [*CE2-GigabitEthernet1/0/2] portswitch
    [*CE2-GigabitEthernet1/0/2] port link-type trunk
    [*CE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [*CE2-GigabitEthernet1/0/2] quit
    [*CE2] commit
    NOTE:

    If the interface is already a Layer 2 interface, do not run the portswitch command.

  2. Configure the QinQ function on CE3 so that packets sent by CE3 to PE1 carry two VLAN tags.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE3
    [*HUAWEI] commit
    [~CE3] vlan 100
    [*CE3-vlan100] quit
    [*CE3] interface gigabitethernet 1/0/1
    [*CE3-GigabitEthernet1/0/1] undo shutdown
    [*CE3-GigabitEthernet1/0/1] portswitch
    [*CE3-GigabitEthernet1/0/1] port vlan-stacking vlan 10 stack-vlan 100
    [*CE3-GigabitEthernet1/0/1] quit
    [*CE3] interface gigabitethernet 1/0/2
    [*CE3-GigabitEthernet1/0/2] undo shutdown
    [*CE3-GigabitEthernet1/0/2] portswitch
    [*CE3-GigabitEthernet1/0/2] port vlan-stacking vlan 20 stack-vlan 100
    [*CE3-GigabitEthernet1/0/2] quit
    [*CE3] interface gigabitethernet 1/0/3
    [*CE3-GigabitEthernet1/0/3] undo shutdown
    [*CE3-GigabitEthernet1/0/3] portswitch
    [*CE3-GigabitEthernet1/0/3] port link-type trunk
    [*CE3-GigabitEthernet1/0/3] port trunk allow-pass vlan 100
    [*CE3-GigabitEthernet1/0/3] quit
    [*CE3] commit
    NOTE:

    If the device does not support the port vlan-stacking command, you can run the port link-type dot1q-tunnel command and port default vlan command on the interface to configure the QinQ function.

  3. Configure a sub-interface for QinQ VLAN tag termination and enable proxy ARP on PE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface gigabitethernet 1/0/1
    [*PE1-GigabitEthernet1/0/1] undo shutdown
    [*PE1-GigabitEthernet1/0/1] quit
    [*PE1] interface gigabitethernet 1/0/1.1
    [*PE1-GigabitEthernet1/0/1.1] control-vid 1 qinq-termination
    [*PE1-GigabitEthernet1/0/1.1] qinq termination pe-vid 100 ce-vid 10
    [*PE1-GigabitEthernet1/0/1.1] qinq termination pe-vid 100 ce-vid 20
    [*PE1-GigabitEthernet1/0/1.1] ip address 10.1.1.254 24
    [*PE1-GigabitEthernet1/0/1.1] arp-proxy inter-sub-vlan-proxy enable
    [*PE1-GigabitEthernet1/0/1.1] arp broadcast enable
    [*PE1-GigabitEthernet1/0/1.1] quit
    [*PE1] commit
    NOTE:

    When you run the qinq termination command on an interface, if the pe-vid values are the same, make sure that the ce-vid values of the sub-interfaces are different.

  4. Verify the configuration.

    Verify that PC1 can ping PC2.

    Check the ARP table on PC1. If the MAC address of PC1 is the MAC address of GE 1/0/1 on PE1, the configuration is correct.

Configuration Files

  • Configuration file of PE1

    #
     sysname PE1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
    #
    interface GigabitEthernet1/0/1.1
     encapsulation qinq-termination
     qinq termination pe-vid 100 ce-vid 10
     qinq termination pe-vid 100 ce-vid 20
     ip address 10.1.1.254 255.255.255.0
     arp-proxy inter-sub-vlan-proxy enable
     arp broadcast enable
    #
    return
  • Configuration file of CE3

    #
     sysname CE3
    #
     vlan batch 100
    #
    interface GigabitEthernet1/0/1
     portswitch
     undo shutdown
     port vlan-stacking vlan 10 stack-vlan 100
    #
    interface GigabitEthernet1/0/2
     portswitch
     undo shutdown
     port vlan-stacking vlan 20 stack-vlan 100
    #
    interface GigabitEthernet1/0/3
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Configuration file of CE1

    #
     sysname CE1
    #
     vlan batch 10
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     portswitch
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of CE2

    #
     sysname CE2
    #
     vlan batch 20
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     portswitch
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059440

Views: 26367

Downloads: 18

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next