No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is ME60 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring GVRP

Example for Configuring GVRP

Networking Requirements

In Figure 5-2, company A, a branch of company A, and company B are connected using switches. The branch of company A wants to communicate with the headquarters (company A) through Device A and Device B. Company A users in VLANs 101 to 200 want to communicate with company B users in the same VLANs through Device B and Device C. To meet these requirements, GVRP must be enabled to implement dynamic VLAN registration.

Figure 5-2 Configuring GVRP
NOTE:

Interface 1 and interface 2 stand for GE 1/0/1 and GE 1/0/2, respectively.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable GVRP to implement dynamic VLAN registration.

  2. Configure GVRP on all company A switches. Set the GVRP registration mode to Normal for the interfaces of company A switches.

  3. Configure GVRP on all company B switches. Set the GVRP registration mode to Fixed for the interfaces connecting to company A so that only packets in the VLANs to which company B belongs can pass.

Data Preparation

None

Procedure

  1. Configure Device A.

    # Enable GVRP globally.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*Device] commit
    [~DeviceA] gvrp
    [*DeviceA] commit
    

    # Configure interfaces as trunk interfaces and allow packets in all VLANs to pass.

    [~DeviceA] interface gigabitethernet 1/0/1
    [~DeviceA-GigabitEthernet1/0/1] port link-type trunk
    [*DeviceA-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [*DeviceA-GigabitEthernet1/0/1] commit
    [~DeviceA-GigabitEthernet1/0/1] quit
    [~DeviceA] interface gigabitethernet 1/0/2
    [~DeviceA-GigabitEthernet1/0/2] port link-type trunk
    [*DeviceA-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [*DeviceA-GigabitEthernet1/0/2] commit
    [~DeviceA-GigabitEthernet1/0/2] quit
    

    # Enable GVRP on interfaces and set GVRP registration modes for the interfaces.

    [~DeviceA] interface gigabitethernet 1/0/1
    [~DeviceA-GigabitEthernet1/0/1] gvrp
    [*DeviceA-GigabitEthernet1/0/1] gvrp registration normal
    [*DeviceA-GigabitEthernet1/0/1] commit
    [~DeviceA-GigabitEthernet1/0/1] quit
    [~DeviceA] gigabitethernet 1/0/2
    [~DeviceA-GigabitEthernet1/0/2] gvrp
    [*DeviceA-GigabitEthernet1/0/2] gvrp registration normal
    [*DeviceA-GigabitEthernet1/0/2] commit
    [~DeviceA-GigabitEthernet1/0/2] quit
    

  2. Configure Device B.

    # Enable GVRP globally.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*Device] commit
    [~DeviceB] gvrp
    [*DeviceB] commit
    

    # Configure interfaces as trunk interfaces and allow packets in all VLANs to pass.

    [~DeviceB] interface gigabitethernet 1/0/1
    [~DeviceB-GigabitEthernet1/0/1] port link-type trunk
    [*DeviceB-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [*DeviceB-GigabitEthernet1/0/1] commit
    [~DeviceB-GigabitEthernet1/0/1] quit
    [~DeviceB] interface gigabitethernet 1/0/2
    [~DeviceB-GigabitEthernet1/0/2] port link-type trunk
    [*DeviceB-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [*DeviceB-GigabitEthernet1/0/2] commit
    [~DeviceB-GigabitEthernet1/0/2] quit
    

    # Enable GVRP on interfaces and set GVRP registration modes for the interfaces.

    [~DeviceB] interface gigabitethernet 1/0/1
    [~DeviceB-GigabitEthernet1/0/1] gvrp
    [*DeviceB-GigabitEthernet1/0/1] gvrp registration normal
    [*DeviceB-GigabitEthernet1/0/1] commit
    [~DeviceB-GigabitEthernet1/0/1] quit
    [~DeviceB] interface gigabitethernet 1/0/2
    [~DeviceB-GigabitEthernet1/0/2] gvrp
    [*DeviceB-GigabitEthernet1/0/2] gvrp registration normal
    [*DeviceB-GigabitEthernet1/0/2] commit
    [~DeviceB-GigabitEthernet1/0/2] quit
    

  3. Configure Device C.

    # Create VLANs 101 to 200.

    <<HUAWEI> system-view
    [~HUAWEI] sysname DeviceC
    [*Device] commit
    [~DeviceC] vlan batch 101 to 200
    [*Device] commit
    

    # Enable GVRP globally.

    [~DeviceC] gvrp
    

    # Configure interfaces as trunk interfaces and allow packets in all VLANs to pass.

    [~DeviceC] interface gigabitethernet 1/0/1
    [~DeviceC-GigabitEthernet1/0/1] port link-type trunk
    [*DeviceC-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [*DeviceC-GigabitEthernet1/0/1] commit
    [*DeviceC-GigabitEthernet1/0/1] quit
    [~DeviceC] interface gigabitethernet 1/0/2
    [~DeviceC-GigabitEthernet1/0/2] port link-type trunk
    [*DeviceC-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [*DeviceC-GigabitEthernet1/0/2] commit
    [~DeviceC-GigabitEthernet1/0/2] quit
    

    # Enable GVRP on interfaces and set GVRP registration modes for the interfaces.

    [~DeviceC] interface gigabitethernet 1/0/1
    [~DeviceC-GigabitEthernet1/0/1] gvrp
    [*DeviceC-GigabitEthernet1/0/1] gvrp registration fixed
    [*DeviceC-GigabitEthernet1/0/1] commit
    [~DeviceC] quit
    [~DeviceC] interface gigabitethernet 1/0/2
    [~DeviceC-GigabitEthernet1/0/2] gvrp
    [*DeviceC-GigabitEthernet1/0/2] gvrp registration normal
    [*DeviceC-GigabitEthernet1/0/2] commit
    [~DeviceC-GigabitEthernet1/0/2] quit

  4. Verify the configuration.

    After the configuration is complete, the branch of company A can communicate with the headquarters, and company A users in VLANs 101 to 200 can communicate with company B users in the same VLANs.

    Run the display gvrp status command on Device A to check the status of global GVRP. The command output shows that GVRP is enabled globally.

    [~DeviceA] display gvrp status
    GVRP status: enabled.
    

    Run the display gvrp statistics command on Device A to check GVRP information. The command output shows the GVRP status and registration mode of each interface, number of GVRP registration failures, and source MAC address of the last GVRP PDU.

    [~DeviceA] display gvrp statistics
    
      GVRP statistics on port GigabitEthernet1/0/1 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    
      GVRP statistics on port GigabitEthernet1/0/2
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal

    Verify the configurations of Device B and Device C in the same way.

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    vlan batch 101 to 200
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
     gvrp registration fixed
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059440

Views: 26312

Downloads: 18

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next