No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ME60 V800R010C10SPC500 Configuration Guide - Virtual Access 01

This is ME60 V800R010C10SPC500 Configuration Guide - Virtual Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Virtual Access in L3VPN Scenarios

Example for Configuring Virtual Access in L3VPN Scenarios

This section provides an example for deploying the virtual access solution on a MAN and configuring L3VPN to carry services.

Networking Requirements

The virtual access solution is typically used for MAN virtualization, as shown in Figure 2-23. To ensure service reliability, configure Masters 1 and 2 as the primary and secondary masters, respectively. The CE on the access side is connected to the virtual access system over VLAN. To implement E2E service bearing, configure L3VPN on the primary and secondary masters for access to the PE on the core side.
Figure 2-23 Configuring virtual access in L3VPN scenarios
Table 2-3 Interfaces and their IP addresses

Device

Interface

IP Address

CE

GigabitEthernet 1/0/1.1

10.1.1.1/24

Master 1

Loopback 1

1.1.1.1/32

GigabitEthernet 1/0/1

10.2.1.1/24

Master 2

Loopback 1

2.2.2.2/32

GigabitEthernet 1/0/1

10.3.1.1/24

PE

Loopback 1

3.3.3.3/32

GigabitEthernet 1/0/1

10.2.1.2/24

GigabitEthernet 1/0/2

10.3.1.2/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP so that the masters interwork with the PE.

  2. Configure MP-BGP, MPLS LDP, and an L3VPN instance on the masters and PE.

  3. Establish a virtual access system and use the default local authentication mode.

  4. Configure primary and secondary masters.

  5. Configure IP addresses for virtual access interfaces on the primary and secondary masters, and bind the interfaces to an L3VPN instance.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of directly connected interfaces and loopback interface addresses on each node (for details, see Table 2-3); IP addresses of virtual access sub-interfaces on the primary and secondary masters: 10.1.1.2/24

  • Management IP address of Master 1: 1.1.1.9; management IP address of Master 2: 2.2.2.9; management IP address of the AP: 3.3.3.9

  • Internal communication interfaces to the AP on Masters 1 and 2: GigabitEthernet 1/1/0/2

  • AP ID: 1025; AP ESN: 391092269755950; AP's external communication interface: GigabitEthernet 1/0/1

  • User name required for a master to log in to the AP: root1234; password: Root@123; SFTP directory: cfcard:/; name of a user created for the AP on a master: root1234; password: Root@123

  • Master 1's management priority for the AP: 10; Master 2's management priority for the AP: 20

  • Name of an L3VPN instance on the masters and PE: vpna; BGP AS number: 100

Procedure

  1. Assign an IP address to each interface on each node, and configure loopback interface addresses.

    For configuration details, see Configuration Files in this section.

  2. Configure OSPF so that the masters interwork with the PE.

    For configuration details, see Configuration Files in this section.

  3. Configure MP-BGP, MPLS LDP, and an L3VPN instance on the masters and PE.

    For configuration details, see Configuration Files in this section.

  4. Configure basic master functions.

    # Configure Master 1.

    <Master1> system-view
    [~Master1] virtual-access
    [*Master1-virtual-access] role master
    [*Master1-virtual-access] admin 1.1.1.9
    [*Master1-virtual-access] isis authentication-mode hmac-sha256 key-id 1 cipher Huawei-123
    [*Master1-virtual-access] commit
    [~Master1-virtual-access] quit
    [~Master1] interface GigabitEthernet1/1/0/2
    [~Master1-GigabitEthernet1/1/0/2] virtual-access enable
    [*Master1-GigabitEthernet1/1/0/2] commit
    [~Master1-GigabitEthernet1/1/0/2] quit

    # Configure Master 2.

    <Master2> system-view
    [~Master2] virtual-access
    [*Master2-virtual-access] role master
    [*Master2-virtual-access] admin 2.2.2.9
    [*Master2-virtual-access] isis authentication-mode hmac-sha256 key-id 1 cipher Huawei-123
    [*Master2-virtual-access] commit
    [~Master2-virtual-access] quit
    [~Master2] interface GigabitEthernet1/1/0/2
    [~Master2-GigabitEthernet1/1/0/2] virtual-access enable
    [*Master2-GigabitEthernet1/1/0/2] commit
    [~Master2-GigabitEthernet1/1/0/2] quit

  5. Configure basic AP functions on each master.

    # Configure Master 1.

    [~Master1] ap-id 1025
    [*Master1-ap1025] esn 391092269755950
    [*Master1-ap1025] remote-interface GigabitEthernet1/0/1
    [*Master1-ap1025] commit
    [~Master1-ap1025] admin 3.3.3.9
    [~Master1-ap1025] quit

    The configuration of Master 2 is similar to the configuration of Master 1. For configuration details, see Configuration Files in this section.

  6. Configure an authentication scheme for virtual access.

    # Configure Master 1.

    [~Master1] ap-id 1025
    [~Master1-ap1025] login-user root1234 login-password Root@123
    [*Master1-ap1025] login-user root1234 sftp-directory cfcard:/
    [*Master1-ap1025] authentication-mode local
    [*Master1-ap1025] ap-user
    [*Master1-ap1025-ap-user] local-user root1234 password cipher Root@123
    [*Master1-ap1025-ap-user] commit
    [~Master1-ap1025-ap-user] quit
    [~Master1-ap1025] quit

    The configuration of Master 2 is similar to the configuration of Master 1. For configuration details, see Configuration Files in this section.

  7. Configure primary and secondary masters.

    # Configure Master 1.

    [~Master1] ap-id 1025
    [~Master1-ap1025] management priority 10
    [*Master1-ap1025] commit
    [~Master1-ap1025] quit

    # Configure Master 2.

    [~Master2] ap-id 1025
    [~Master2-ap1025] management priority 20
    [*Master2-ap1025] commit
    [~Master2-ap1025] quit

  8. Configure the CE's access to the virtual access system.

    # Configure the CE.

    <CE> system-view
    [~CE] interface GigabitEthernet1/0/1.1
    [*CE-GigabitEthernet1/0/1.1] vlan-type dot1q 1
    [*CE-GigabitEthernet1/0/1.1] ip address 10.1.1.1 24
    [*CE-GigabitEthernet1/0/1.1] commit
    [~CE-GigabitEthernet1/0/1.1] quit
    [~CE] ip route-static 0.0.0.0 0.0.0.0 10.1.1.2
    [*CE] commit

  9. Configure L3VPN on each master.

    # Configure Master 1.

    [~Master1] interface GigabitEthernet1025/1/0/1.1
    [~Master1-GigabitEthernet1025/1/0/1.1] vlan-type dot1q 1
    [*Master1-GigabitEthernet1025/1/0/1.1] ip binding vpn-instance vpna
    [*Master1-GigabitEthernet1025/1/0/1.1] ip address 10.1.1.2 24
    [*Master1-GigabitEthernet1025/1/0/1.1] commit
    [~Master1-GigabitEthernet1025/1/0/1.1] quit
    [~Master1] bgp 100
    [~Master1-bgp] ipv4-family vpn-instance vpna
    [*Master1-bgp-vpna] import-route direct
    [*Master1-bgp-vpna] commit
    [~Master1-bgp-vpna] quit

    The configuration of Master 2 is similar to the configuration of Master 1. For configuration details, see Configuration Files in this section.

  10. Verify the configuration.

    Run the display virtual-access ap command on a master to view basic information about the AP. The following example uses the command output on Master 1.

    [~Master1] display virtual-access ap
                                     AP Information
    Total 1 record(s):                                 
    ---------------------------------------------------------------------------------
     AP Esn               : 391092269755950
     AP ID                : 1025               Admin IP           : 3.3.3.9
     Primary Master       : 1.1.1.9            Secondary Master   : 2.2.2.9
     State                : Online                
     Online Time          : 2015-11-29 21:18:57
    --------------------------------------------------------------------------------

    Run the display virtual-access va-pw command on Master 1 to view vaPW information. block state is unblocked, indicating that Master 1 is the primary master.

    [~Master1] display virtual-access va-pw
     Total PW : 1     1 up       0 down
    
     *client interface       : GigabitEthernet1025/1/0/1 is up
      local AC servicestate  : up
      block state            : unblocked
      PW state               : up
      local VC label         : 32828
      remote VC label        : 17
      control word           : enable
      MTU value              : 1500
      VC tunnel info         : 1 tunnels
        NO.0  TNL type       : va-tunnel   ,  TNL ID : 0x000000003100000001
      VC tunnel linkstatus   : available
      create time            : 0 days, 22 hours, 9 minutes, 27 seconds
      up time                : 0 days, 21 hours, 13 minutes, 48 seconds
      last change time       : 0 days, 21 hours, 13 minutes, 48 seconds
      last up time           : 2015/11/29 21:18:59
      total up time          : 0 days, 21 hours, 13 minutes, 48 seconds
      reroute policy         : delay 30 s
      time of last reroute   : -- days, -- hours, -- minutes, -- seconds
      delay residual time    : 0 s
    

    Run the display virtual-access va-pw command on Master 2 to view vaPW information. block state is blocked, indicating that Master 2 is the secondary master.

    [~Master2] display virtual-access va-pw
     Total PW : 1     1 up       0 down
    
     *client interface       : GigabitEthernet1025/1/0/1 is down
      local AC servicestate  : up
      block state            : blocked
      PW state               : up
      local VC label         : 32828
      remote VC label        : 505
      control word           : enable
      MTU value              : 1500
      VC tunnel info         : 1 tunnels
        NO.0  TNL type       : va-tunnel   ,  TNL ID : 0x000000003100000001
      VC tunnel linkstatus   : available
      create time            : 0 days, 22 hours, 7 minutes, 1 seconds
      up time                : 0 days, 21 hours, 17 minutes, 40 seconds
      last change time       : 0 days, 21 hours, 17 minutes, 40 seconds
      last up time           : 2015/11/29 21:19:00
      total up time          : 0 days, 21 hours, 17 minutes, 40 seconds
      reroute policy         : delay 30 s
      time of last reroute   : -- days, -- hours, -- minutes, -- seconds
      delay residual time    : 0 s
    

    Run the display ip routing-table vpn-instance vpna command on the PE. The command output shows the route to the network segment 10.1.1.0/24.

    <PE> display ip routing-table vpn-instance vpna
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : vpna
             Destinations : 5        Routes : 5         
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/24  IBGP    255  0             RD  1.1.1.1         GigabitEthernet1/0/1
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

Configuration Files

  • CE configuration file

    #
    sysname CE
    #
    interface GigabitEthernet1/0/1
     undo shutdown  
    #               
    interface GigabitEthernet1/0/1.1
     vlan-type dot1q 1
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.1.2
    #
    return  
  • AP configuration file

    #
    sysname AP
    #
    undo user-security-policy enable
    #
    ip dcn vpn-instance __dcn_vpn__
     ipv4-family 
    #
    bfd
    #
    virtual-access
     role ap
     admin 3.3.3.9
     isis authentication-mode hmac-sha256 key-id 1 cipher %#%#;Z4)W1+&+F\Rax>Jr<"TM'(+Sv.2W)s&QLC:JB*H%#%#
     master admin-ip primary 1.1.1.9 secondary 2.2.2.9
    #
    aaa
     local-user root1234 password irreversible-cipher $1a$]X.f&Hixy4$nVid9o&3bKN4;n#oqO$+T/)9H\$KfD3@KI#8<z9$s
     local-user root password irreversible-cipher $1a$6dZgGs\mCV$YO>='scw~!NE!SLguK;BMbMMGw(e/VR:X;Hi&X76$
     local-user root service-type ssh
     local-user root level 15
     local-user root expire 2016-01-01
    #               
    isis 65534      
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-access enable
     network-entity 00.38ba.50aa.f701.00
    #               
    interface GigabitEthernet1/0/1
     undo shutdown  
    #
    interface GigabitEthernet1/0/2
     undo shutdown  
     isis enable 65534
     isis circuit-type p2p
     dcn            
     virtual-access enable 
    #
    interface GigabitEthernet1/0/3
     undo shutdown  
     isis enable 65534
     isis circuit-type p2p
     dcn            
     virtual-access enable 
    #
    interface LoopBack2147483646
     description virtual-access loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 3.3.3.9 255.255.255.255
    #               
    interface LoopBack2147483647
     description DCN loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 128.254.255.253 255.255.0.0
    #               
    interface NULL0 
    #               
    ospf 65534 vpn-instance __dcn_vpn__
     description DCN ospf create by default
     opaque-capability enable
     hostname       
     vpn-instance-capability simple
     area 0.0.0.0   
      network 0.0.0.0 255.255.255.255
    #               
    !The DCN function implements the capability of plug-and-play for this device.
    !A NE IP address based on the unique NE ID is automatically generated in VPN
    !of DCN. It is recommended that the NE IP address be changed to the planned 
    !one by running the ne-ip X.X.X.X <mask> command after the device being online.
    dcn             
     bandwidth ethernet 1024 
     bandwidth pos 1024 
     bandwidth serial 192 
    #
    stelnet server enable
    ssh user root   
    ssh user root authentication-type password
    ssh user root service-type stelnet
    ssh user root1234
    ssh user root1234 authentication-type password
    ssh user root1234 service-type all
    ssh user root1234 sftp-directory cfcard:/
    #               
    user-interface vty 0 4
     authentication-mode aaa
     protocol inbound ssh
    #
    return 
  • Master 1 configuration file

    #
    sysname Master1
    #
    rsa peer-public-key 128.254.255.253 encoding-type der
     public-key-code begin
     3082010A
      02820101
        00BD7CED D35139C7 9E91A927 2A33F790 F472055E C799D616 68497A56 4F13FC0E
        A83C791A 9E2006AD 7421E9A9 9C16C6B9 03384B96 8A99AFF6 A03F92E1 197D5118
        6D6FC8BD 187D67D2 D965B6E7 8CC9CEF8 0BAC38F9 76D6D07E EA840564 FEAE1C88
        DFC31D63 C6E09347 F7EC9698 2C85F367 D5488872 2CC28757 B5E27924 A1C9C8D8
        A57D9047 ADB911AB 88B20E92 CED1DDF3 135E9E3D 0D873FD6 23B9612A ABD1270B
        315D97AD D85BB8C6 A8855247 C158CF32 CCB1038D 5C5EDB4E 72AFD15B 0E6C0779
        E2C4E436 14123607 77BE1227 86B71BC0 C62F402E A744940E 611DEB07 D4C96736
        9C5605AE DCE96A5C 2717D4ED AF7FDA27 B597B364 C8E67EF9 D3CB5A34 754AE928
        A3
      0203
        010001
     public-key-code end
     peer-public-key end
    #
    ip dcn vpn-instance __dcn_vpn__
     ipv4-family    
    #               
    ip vpn-instance vpna
     ipv4-family    
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #               
    bfd             
    #               
    mpls lsr-id 1.1.1.1
    #               
    mpls            
    #               
    mpls ldp        
     #              
     ipv4-family    
    #               
    virtual-access  
     role master    
     admin 1.1.1.9  
     isis authentication-mode hmac-sha256 key-id 1 cipher %#%#uI1~5_^Ru2q)D>Jbo>G~9'76%`G^*=$\33>eQa!X%#%#
    #               
    ap-id 1025      
     esn 391092269755950
     admin 3.3.3.9  
     management priority 10
     remote-interface GigabitEthernet1/0/1
     login-user root1234 login-password %^%#r"],=TrM:!##YxNxPZY4_&t"O@'dG;],:x1W0yhS%^%#
     login-user root1234 sftp-directory cfcard:/
     authentication-mode local
     #
     ap-user
      local-user root1234 password cipher %^%#U>aG(7o+,+hOlK>}:TuA(Q+M%meAc,=a$c-LYXMT%^%#
    #
    isis 65534      
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-access enable
     network-entity 00.38ba.2b87.fe03.00
    #               
    interface GigabitEthernet1/1/0/1
     undo shutdown  
     ip address 10.2.1.1 255.255.255.0
     mpls           
     mpls ldp       
    #
    interface GigabitEthernet1/1/0/2
     undo shutdown
     isis enable 65534
     isis circuit-type p2p
     dcn
     virtual-access enable
    #
    interface GigabitEthernet1025/1/0/1
     undo shutdown
    #
    interface GigabitEthernet1025/1/0/1.1
     vlan-type dot1q 1
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface LoopBack2147483646
     description virtual-access loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 1.1.1.9 255.255.255.255
    #               
    interface LoopBack2147483647
     description DCN loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 128.254.255.251 255.255.0.0
    #               
    bgp 100         
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #              
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #              
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #              
     ipv4-family vpn-instance vpna
      import-route direct  
    #               
    ospf 1 router-id 1.1.1.1
     area 0.0.0.0   
      network 1.1.1.1 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #               
    ospf 65534 vpn-instance __dcn_vpn__
     description DCN ospf create by default
     opaque-capability enable
     hostname       
     vpn-instance-capability simple
     area 0.0.0.0   
      network 0.0.0.0 255.255.255.255
    #               
    !The DCN function implements the capability of plug-and-play for this device.
    !A NE IP address based on the unique NE ID is automatically generated in VPN
    !of DCN. It is recommended that the NE IP address be changed to the planned 
    !one by running the ne-ip X.X.X.X <mask> command after the device being online.
    dcn             
     bandwidth ethernet 1024 
     bandwidth pos 1024 
     bandwidth serial 192 
    #               
    snmp-agent trap type base-trap
    #               
    ssh client first-time enable
    ssh client 128.254.255.253 assign rsa-key 128.254.255.253#
    return 
    
  • Master 2 configuration file

    #
    sysname Master2
    #
    rsa peer-public-key 128.254.255.253 encoding-type der
     public-key-code begin
     3082010A
      02820101
        009D0859 236378F5 11BE0338 BD1C27BA 1B6DCFDA 78283532 C3CE5DFF 2BA19DF6
        D456D3FC 093DE062 7B66386A DCCE8660 3F8D44ED 414DB8B0 C4911497 B1D688D9
        C960C1DB B31BB8D9 2D80B47E 93D7C101 54371722 49120A6F FC5E3504 48AA3CB7
        BE9F094F C29074BA 2304010E 1287FF4D 1B59E4B4 EF1005A4 5E43A8EB A534F46C
        06DA7EE2 A8C4BBF5 4DE3EAC8 F6880579 9C4D1B75 5F0D8401 9A64BE6E 2446C448
        C9BF67F0 6801C928 234B1851 1AD496C0 E3AF2401 E6C3910B BB55A0C1 ED52E2BB
        AD96615D 2437C255 4823276E 841EEF25 352B3A69 65B085CA A0676C01 9F08ED3A
        53C404B5 5353A044 802199FC FCE1AF9D CBDA44B3 7543257E BF349FBD FCE7BB78
        91
      0203
        010001
     public-key-code end
     peer-public-key end
    #
    ip dcn vpn-instance __dcn_vpn__
     ipv4-family    
    #               
    ip vpn-instance vpna
     ipv4-family    
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #               
    bfd             
    #               
    mpls lsr-id 2.2.2.2
    #               
    mpls            
    #               
    mpls ldp        
     #              
     ipv4-family    
    #               
    virtual-access  
     role master    
     admin 2.2.2.9
     isis authentication-mode hmac-sha256 key-id 1 cipher %#%#$J~q[/PGi=)HKEM(4r:K29P`m0N`C55QK<`=/Q=^Q`MAF4<1!!%#%#
    #               
    ap-id 1025      
     esn 391092269755950
     admin 3.3.3.9  
     management priority 20
     remote-interface GigabitEthernet1/0/1
     login-user root1234 login-password %^%#=Xy6Tq+*$:!J$~OYk^J7YK0LD[_HXH01\08'n%E2%^%#
     login-user root1234 sftp-directory cfcard:/
     authentication-mode local
     #
     ap-user
      local-user root1234 password cipher %^%#J:!g;T=Gi;\UnI;xi-+>[n@"WXUvITnHJ8.z$P`O%^%#
    #               
    isis 65534      
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-access enable
     network-entity 00.38ba.264b.4b04.00
    #               
    interface GigabitEthernet1/1/0/1
     undo shutdown  
     ip address 10.3.1.1 255.255.255.0
     mpls           
     mpls ldp       
    #
    interface GigabitEthernet1/1/0/2
     undo shutdown
     isis enable 65534
     isis circuit-type p2p
     dcn
     virtual-access enable
    #
    interface GigabitEthernet1025/1/0/1
     undo shutdown
    #
    interface GigabitEthernet1025/1/0/1.1
     vlan-type dot1q 1
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    interface LoopBack2147483646
     description virtual-access loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 2.2.2.9 255.255.255.255
    #               
    interface LoopBack2147483647
     description DCN loopback interface
     ip binding vpn-instance __dcn_vpn__
     ip address 128.254.255.250 255.255.0.0
    #               
    bgp 100         
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #              
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #              
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #              
     ipv4-family vpn-instance vpna
      import-route direct  
    #               
    ospf 1 router-id 2.2.2.2
     area 0.0.0.0   
      network 2.2.2.2 0.0.0.0
      network 10.3.1.0 0.0.0.255
    #               
    ospf 65534 vpn-instance __dcn_vpn__
     description DCN ospf create by default
     opaque-capability enable
     hostname       
     vpn-instance-capability simple
     area 0.0.0.0   
      network 0.0.0.0 255.255.255.255
    #               
    !The DCN function implements the capability of plug-and-play for this device.
    !A NE IP address based on the unique NE ID is automatically generated in VPN
    !of DCN. It is recommended that the NE IP address be changed to the planned 
    !one by running the ne-ip X.X.X.X <mask> command after the device being online.
    dcn             
     bandwidth ethernet 1024 
     bandwidth pos 1024 
     bandwidth serial 192 
    #               
    snmp-agent trap type base-trap
    #               
    ssh client first-time enable
    ssh client 128.254.255.253 assign rsa-key 128.254.255.253#
    return 
    
  • PE configuration file
    #
    sysname PE
    #
    ip vpn-instance vpna
     ipv4-family 
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface GigabitEthernet1/0/1
     undo shutdown  
     ip address 10.2.1.2 255.255.255.0
     mpls           
     mpls ldp
    #
    interface GigabitEthernet1/0/2
     undo shutdown  
     ip address 10.3.1.2 255.255.255.0
     mpls           
     mpls ldp 
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #               
    bgp 100         
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #              
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #              
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #              
    #               
    ospf 1          
     area 0.0.0.0   
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return 
Translation
Download
Updated: 2019-01-04

Document ID: EDOC1100059451

Views: 4065

Downloads: 22

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next