ALM-37004 Asynchronous or Disconnected Active and Standby DataNode Nodes
Description
This alarm is generated when the active DataNode instance is disconnected from the standby DataNode instance.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
37004 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
ServiceName |
Identifies the service for which the alarm is generated. |
RoleName |
Identifies the role for which the alarm is generated. |
HostName |
Identifies the host for which the alarm is generated. |
Instance |
Identifies the instance for which the alarm is generated. |
Impact on the System
The redo logs of the active DataNode instance are automatically sent to the secondary standby DataNode instance, increasing the network pressure on the physical server running the secondary standby instance.
System Processing
When the active DataNode instance is disconnected from the standby DataNode instance, the redo logs of the active DataNode instance are automatically sent to the secondary standby DataNode instance, ensuring proper service operating.
Possible Causes
The active DataNode instance is disconnected from the standby DataNode instance.
Procedure
Locate the alarm cause.
- Log in to the FusionInsight Manager.
- Log in to the ManageOne OM plane using a browser, then choose Alarms.
- Login address: https://URL for the homepage of the ManageOne OM plane:31943. Example: https://oc.type.com:31943.
- Default username: admin, default password: Huawei12#$.
- In the alarm list, locate and click the target alarm name in the Name column. The Alarm Details and Handling Recommendations dialog box is displayed.
- Locate the value in the IP Address/URL/Domain Name column, which is the float IP address of the FusionInsight Manager.
- Log in to the FusionInsight Manager using a browser.
- Login address: https://float IP address of the FusionInsight Manager:28443/web. Example: https://10.10.192.100:28443/web.
- Default username: admin, default password: obtain it from the system administrator.
- Log in to the ManageOne OM plane using a browser, then choose Alarms.
- Log in to FusionInsight Manager, click Alarms. On the alarm list, locate the alarm and obtain the information about the node and instance for which the alarm is generated from Location in the Alarm Details area.
- Log in to the node where the alarm is generated as the omm user and run the following command to check whether the active and standby DataNode instances of the cluster are normal.
Default user: omm, default password: Bigdata123@.
source ${BIGDATA_HOME}/mppdb/.mppdbgs_profile
gs_om -t status --detail
- Check whether the network of the servers running the active and standby DataNode instances is normal. For example, if the NIC used by the server running the active DataNode instance or standby DataNode instance is eth0, run the following command to check whether the network is normal:
/sbin/ifconfig eth0
- Check whether the alarm persists.
- If yes, go to 6.
- If no, no further action is required.
Collect fault information.
- On FusionInsight Manager, choose .
- Select MPPDB from the Services drop-down list box and click OK.
- Set Start Time for log collection to 1 hour ahead of the alarm generation time and End Time to 1 hour after the alarm generation time, and click Download.
- Contact Technical Support and send the collected logs.
Alarm Clearing
After the fault is rectified, the system automatically clears this alarm.
Related Information
None