ALM-1316003 Incorrect QEMU Version
Description
After the QEMU hot swap patch is installed, this alarm is generated if QEMU of the old version is still used on a VM. This alarm is cleared when all VMs on the host use QEMU of the new version.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
1316003 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Fault Location Info |
host_id: specifies the ID of the host for which the alarm is generated. instance_id: specifies the ID of the VM for which the alarm is generated. |
Additional Info |
|
Impact on the System
The QEMU component on a VM has not been replaced with the one with the new version. The QEMU hot swap patch is used to resolve security vulnerabilities. This exception indicates that the corresponding VM security vulnerabilities are not fixed.
Possible Causes
- The system is abnormal.
- A device that does not support QEMU hot swap is configured on the VM, for example, a vGPU device.
Procedure
- Obtain the VM UUID in the alarm information and locate the host.
- Use PuTTY to log in to the first FusionSphere OpenStack node through the IP address of the External OM plane.
The default user name is fsp. The default password is Huawei@CLOUD8.
The system supports both password and public-private key pair for identity authentication. If the public-private key pair is used for login authentication, see detailed operations in Using PuTTY to Log In to a Node in Key Pair Authentication Mode.
NOTE:
To obtain the IP address of the External OM plane, search for the required parameter on the Tool-generated IP Parameters sheet of the xxx_export_all.xlsm file exported from HUAWEI CLOUD Stack Deploy during software installation. The parameter names in different scenarios are as follows:- Region Type I scenario:
Cascading system: Cascading-ExternalOM-Reverse-Proxy
Cascaded system: Cascaded-ExternalOM-Reverse-Proxy
- Region Type II and Region Type III scenarios: ExternalOM-Reverse-Proxy
- Region Type I scenario:
- Run the following command and enter the password of user root to switch to user root:
su - root
The default password of user root is Huawei@CLOUD8!.
- Run the following command to disable user logout upon system timeout:
TMOUT=0
- Run the following command to import environment variables:
source set_env
Information similar to the following is displayed:
please choose environment variable which you want to import: (1) openstack environment variable (keystone v3) (2) cps environment variable (3) openstack environment variable legacy (keystone v2) (4) openstack environment variable of cloud_admin (keystone v3) please choose:[1|2|3|4]
- Enter 1 to enable Keystone V3 authentication and enter the password of OS_USERNAME as prompted.
Default account format: DCname_admin; default password: FusionSphere123.
- Run the following command to perform hot swap on the VM: This command is used to obtain the VM list on the host and perform QEMU hot swap on VMs whose QEMU version is abnormal one by one.
python /usr/libexec/uvp_hotreplace_upgrade --action=upgradevm | grep -w "Domain"
- If the hot swap is successful, the following key log is displayed:
[ INFO ] ... Domain %s do hot replace success
- Otherwise, the following key log is displayed:
[ ERROR ] ... Domain %s hot replace fail, reason %s
NOTE:
%s indicates the VM name and failure cause.
- If the hot swap is successful, the following key log is displayed:
- Run the following command to query the hot swap result:
python /usr/libexec/uvp_hotreplace_upgrade --action=check_vm_running_at_current_bin 2&>1 > /dev/null
Run the following command to check the return value of the command:
echo $?
- If the return value is 0, the repair is successful. In this case, go to 9.
- If the returned value is not 0, restart the VM whose QEMU version is abnormal to rectify the fault. Then, go to 9.
During VM restart, the VM is shut down and then restarted (the new VM will use the QEMU of the new version). This operation will interrupt services on the VM.
- Check whether the alarm is automatically cleared after the next check period (12 hours).
- If yes, no further action is required.
- If no, go to 10.
- Contact technical support for assistance.