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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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0x20100031000C No Matching CA Certificate Is Available Between Microservice And Database

0x20100031000C No Matching CA Certificate Is Available Between Microservice And Database

Description

No matching CA certificate is available for the connection between microservice ([MicroService_Name]) on server (IP address: [NodeIP]) and database (IP address: [IP_Address]).

Attribute

Alarm ID

Alarm Level

Manually Cleared

0x20100031000C

Warning

No

Parameters

Name

Meaning

NodeIP

Server IP address

MicroService_Name

Microservice name

IP_Address

Database IP address

Impact on the System

The connection to the database has security risks.

Possible Causes

No CA certificate for connecting to the database exists in the system or the CA certificate has expired.

Procedure

  1. Possible cause 1: No CA certificate for connecting to the database exists in the system or the CA certificate has expired.

    1. Contact the administrator to obtain the database certificate file that has not expired and rename it as cacert.pem.
    2. Use WinSCP to copy the cacert.pem file to the /home/hcp directory on the server where the alarm is reported as user hcp.

      Default account: hcp. Default password: PXU9@ctuNov17!.

    3. Use PuTTY to log in to the eBackup server using the IP address of the server that reports the alarm.

      Default account: hcp. Default password: PXU9@ctuNov17!.

    4. Run the su root command. Enter the password of user root to switch to user root.

      The default password of user root is Cloud12#$.

    5. Run the mv /home/hcp/cacert.pem /opt/huawei-data-protection/ebackup/microservice/ebk_xxx/conf command to move the certificate file to the configuration directory of the corresponding microservice. ebk_xxx indicates the microservice name.
    6. Run the cd /opt/huawei-data-protection/ebackup/microservice/ebk_xxx/conf command to go to the directory where the certificate is stored.
    7. Run the chmod 400 cacert.pem command to set the permission on the cacert.pem file to 400.
    8. Run the chown hcpprocess cacert.pem command to change the owner of the cacert.pem file to hcpprocess.
    9. Run the service hcp restart command to restart the service.
    10. Wait for about 3 minutes and check whether the alarm is cleared on the current alarm page.
      • If yes, no further action is required.
      • If no, contact technical support engineers.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 49362

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