ALM-9903 File Synchronization Failure Between Two OpenStack OM Nodes
Description
The system synchronizes the files on the active FusionSphere OpenStack OM node with the standby FusionSphere OpenStack OM node every 5 minutes. This alarm is generated when the synchronization fails.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
9903 |
Warning |
Yes |
Parameters
Name |
Meaning |
---|---|
Fault Location Info |
File Synchronization Failure Between Two OpenStack OM Nodes |
Additional Info |
File Synchronization Failure Between Two OpenStack OM Nodes |
Impact on the System
The file system of the active Service OM node is inconsistent with that of the standby Service OM node. After the active/standby switchover, the standby node serves as the active node, which may cause the loss of the modification to some files on the original active node, and some services configurations become invalid.
Possible Causes
- The file synchronization service on the active node is abnormal.
- Network communication is interrupted.
- The active node is restarted.
Procedure
- Use PuTTY to log in to the active Service OM node. Ensure that the management floating IP address and user galaxmanager are used to establish the connection.
Default username: galaxmanager ; default password: IaaS@OS-CLOUD9!
NOTE:
Log in to the FusionSphere OpenStack web client. For details, see Logging In to the FusionSphere OpenStack Web Client (ManageOne Mode). Choose Cloud Service > FusionSphere OpenStack OM and view VM List to obtain the management floating IP address.
- Run the following command to check whether the HA process status is correct:
QueryHaState om
If information similar to the following is displayed, the HA process status is normal:
LOCAL_HOST=allinonefm0 LOCAL_STATE=standby LOCAL_IP=192.168.61.138 REMOTE_HOST=allinonefm1 REMOTE_STATE=active REMOTE_IP=192.168.61.165
If LOCAL_STATE or REMOTE_STATE is unknow, the HA process status is incorrect.
- Run the following command to restart the HA process:
haStopAll -r;haStartAll -r
- Go to 8.
- Use PuTTY to log in to the standby FusionSphere OpenStack OM node as user galaxmanager.
- Run the following command to restart the HA process:
haStopAll -r;haStartAll -r
- Go to 8.
- After 15 minutes, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 9.
- Contact technical support for assistance.
Related Information
None