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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-70105 Residual Volume Data on Heterogeneous VMware VMs

ALM-70105 Residual Volume Data on Heterogeneous VMware VMs

Description

This alarm is generated when volume attaching times out because vCenter takes a long time to process the volume attaching request or other exceptions occur, leaving residual data on VMs. This alarm is generated only for VMs running in the connected VMware hypervisor.

Attribute

Alarm ID

Alarm Severity

Auto Clear

70105

Major

No

Parameters

Name

Meaning

Fault Location Info

  • instance_id: specifies the ID of the VM for which the alarm is generated.
  • volume_id: specifies the ID of the volume used by the VM for which the alarm is generated.
  • bdm_id: specifies the BDM data ID of the volume for which the alarm is generated.

Additional Info

detail_info: provides detailed information about the alarm.

Impact on the System

Residual volume data on VMs may compromise the accuracy of the data presented to customers and data statistics.

Possible Causes

  • vCenter takes a long time to process the volume attaching request, which causes multiple volumes to be attached to the same VM. As a result, volume attaching times out, leaving residual data on the VMs.
  • Other volume attaching exceptions may also leave residual data on VMs.

Procedure

  1. In the alarm information, obtain the VM ID (instance_id), volume ID (volume_id), and BDM data ID (bdm_id), which will be used in subsequent steps. Log in to the FusionSphere OpenStack system, switch to user root, import environment variables, and run the cinder list --all|grep volume_id command to check whether the volume exists.

    • If yes, run the cinder show volume_id command to query volume information and then run 2.
    • If no, go to 8.
    NOTE:

    bdm_id indicates the internal ID used for volume attaching.

  2. Check whether the status parameter of the volume is an intermediate state, such as attaching or detaching.

    • If yes, no further action is required.
    • If no, go to 8.

  3. Use PuTTY to log in to the first FusionSphere OpenStack node through the IP address of the External OM plane.

    The default user name is fsp. The default password is Huawei@CLOUD8.

    The system supports both password and public-private key pair for identity authentication. If the public-private key pair is used for login authentication, see detailed operations in Using PuTTY to Log In to a Node in Key Pair Authentication Mode.

    NOTE:
    To obtain the IP address of the External OM plane, search for the required parameter on the Tool-generated IP Parameters sheet of the xxx_export_all.xlsm file exported from HUAWEI CLOUD Stack Deploy during software installation. The parameter names in different scenarios are as follows:
    • Region Type I scenario:

      Cascading system: Cascading-ExternalOM-Reverse-Proxy

      Cascaded system: Cascaded-ExternalOM-Reverse-Proxy

    • Region Type II and Region Type III scenarios: ExternalOM-Reverse-Proxy

  4. Run the following command and enter the password of user root to switch to user root:

    su - root

    The default password of user root is Huawei@CLOUD8!.

  5. Run the following command to disable user logout upon system timeout:

    TMOUT=0

  6. Run the following command to import environment variables:

    source set_env

    Information similar to the following is displayed:

      please choose environment variable which you want to import: 
      (1) openstack environment variable (keystone v3) 
      (2) cps environment variable 
      (3) openstack environment variable legacy (keystone v2) 
      (4) openstack environment variable of cloud_admin (keystone v3) 
      please choose:[1|2|3|4] 

  7. Enter 1 to enable Keystone V3 authentication and enter the password of OS_USERNAME as prompted.

    Default account format: DCname_admin; default password: FusionSphere123.

  8. Switch to the node where the active database locates. (You can identify the active node by running the cps template-instance-list --service gaussdb gaussdb command. The node for which the component status is active is the active node.) Log in to the Nova database (by running the su gaussdba -c ';/opt/gaussdb/app/bin/gsql nova' command and enter password FusionSphere123), run the select * from block_device_mapping where id=bdm_id and deleted=0 command (bdm_id in the command is bmd_id in the alarm information), and check whether the command output contains data.

    • If yes, go to 9.
    • If no, no further action is required.

  9. Check whether the connection_info field in the command output has a value.

    • If yes, no further action is required.
    • If no, go to 10.

  10. Log in to the node where the active database locates by performing the operations in 2. Execute the sh /usr/bin/info-collect-script/audit_resume/delete_bdm_byid.sh vm_uuid volume_id bdm_id script, and check whether the command output indicates a successful clearance of the residual data and does not contain error information.

    • If yes, no further action is required.
    • If no, go to 11.

  11. Contact technical support for assistance.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

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