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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-73015 Hugepage Memory Insufficient

ALM-73015 Hugepage Memory Insufficient

Description

The collect-alarm periodically (default interval: 300 seconds) checks the memory difference between the current hugepage memory and the configured hugepage memory. This alarm is generated when the current hugepage memory is less than the configured hugepage memory.

Attribute

Alarm ID

Alarm Severity

Auto Clear

73015

Critical

Yes

Parameters

Name

Meaning

Fault Location Info

host_id: specifies the ID of the host for which the alarm is generated.

Additional Info

  • error_info: The huge page memory is insufficient.
  • host_id: specifies the ID of the host for which the alarm is generated.
  • hostname: specifies the name of the host for which the alarm is generated.

Impact on the System

  • Some service VMs may fail to start properly.
  • VMs with hugepage memory may fail to be created.

Possible Causes

The memory is faulty, and the total memory of the host decreases.

Procedure

  1. Log in to the FusionSphere OpenStack web client.

    For details, see Logging In to the FusionSphere OpenStack Web Client (ManageOne Mode).

  2. Choose Configuration > Kernel Option and check whether Failed is displayed in the Status column of any host group.

    • If yes, go to 3.
    • If no, go to 5.

  3. Click Hugepage Quantity. Check whether the maximum value is less than that configured in the environment.

    • If yes, go to 4.
    • If no, go to 5.

  4. Select Automatic Hugepage or set Hugepage Quantity to the maximum value allowed on the FusionSphere OpenStack web client. Then click Submit. After submission, if the value of Status changes to Effective After Restart, restart the corresponding host. Repeat 3 to 4 to check all host groups that have this problem.
  5. Log in to BMC, switch to Alarm & SEL, and check whether any host hardware memory-related alarm exists on the Current Alarms page.

    • If yes, go to 6.
    • If no, go to 9.

  6. Power off the host and replace the memory. For details, "Replacing a Memory" in HUAWEI CLOUD Stack 6.5.0 Parts Replacement. Then restart the host.
  7. Log in to the host and verify that the restart is successful.

    Run the su - root command to switch to user root.

    The default password of user fsp is Huawei@CLOUD8.

    The default password of user root is Huawei@CLOUD8!.

  8. After 5 to 10 minutes, check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 9.

  9. Contact technical support for assistance.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 48369

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