ALM-2000420 NS Process Does Not Exist
Description
This alarm is generated when the NS process is not running on an NS node.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
2000420 |
Critical |
Yes |
Parameters
Parameter |
Description |
---|---|
Resource name |
Name of the device for which the alarm is generated |
Resource type |
MONITOR |
Monitor type |
NS process monitoring |
Host IP address |
IP address of the host |
Details |
Data in recent periods |
Threshold |
Threshold for generating an alarm |
Impact on the System
The alarmed node cannot provide services.
Possible Causes
- The crontab job is abnormal.
- The Notification Server configuration file is incorrect.
Procedure
- Log in to ManageOne Maintenance Portal using a browser.
- URL: https://Address for accessing the homepage of ManageOne Maintenance Portal:31943, for example, https://oc.type.com:31943
- Default username: admin; default password: Huawei12#$
- On the menu bar in the upper part of the page, choose Alarms > Current Alarms.
- In the alarm list, locate the alarm to be handled, and click
on the left of the alarm. The Details page is displayed.
- Choose Location Info, obtain the host IP address, that is, the IP address of the node where the alarm is generated.
- Use PuTTY to log in to the node for which the alarm is generated. Ensure that the management IP address of the node obtained in 4 is used to establish the connection.
The default username is hermes. The default password is Hermes@123.
- Run the following command to disable user logout upon system timeout:
TMOUT=0
- Run the following command to switch to the root user:
sudo su - root
The default password is Cloud12#$.
- Run the following command to check whether the crontab job is disabled:
cat /etc/crontab | grep notification
[root@SMN-PS-NS-DB-MEM01 config]# cat /etc/crontab | grep notification */1 * * * * root su hermes -c "/opt/hermes/notification-server/bin/ns_monitor.sh check" >/dev/null 2>&1
If # is displayed at the beginning of the command output, the crontab job is disabled.
- If yes, delete # to enable the crontab job.
- If no, go to 9.
- Run the following commands to switch to user hermes and manually start the NS process:
su - hermes
sh /opt/hermes/notification-server/bin/ns_monitor.sh restart
- Run the following command to check whether the NS process is running properly:
ps -ef | grep notification-server |grep -v grep
- If yes, go to 11.
- If no, contact technical support for assistance.
- Ten minutes later, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, contact technical support for assistance.
Reference
None