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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-37001 Redo Logs of the MPPDBServer Instance Are Missing

ALM-37001 Redo Logs of the MPPDBServer Instance Are Missing

Description

This alarm is generated when some xlog logs of the active DataNode instance that are not synchronized to the standby DataNode instance are deleted.

Attribute

Alarm ID

Alarm Severity

Auto Clear

37001

Major

Yes

Parameters

Name

Meaning

ServiceName

Identifies the service for which the alarm is generated.

RoleName

Identifies the role for which the alarm is generated.

HostName

Identifies the host for which the alarm is generated.

Instance

Identifies the instance for which the alarm is generated.

Impact on the System

After the xlog file under the pg_xlog directory of the active DataNode instance is deleted, the xlog logs cannot be synchronized from the active DataNode instance to the corresponding standby DataNode instance. This triggers the reconstruction of the standby instance, increasing the network pressure on the physical server running the standby instance. If the deleted logs are xlog logs that are being used by the active DataNode instance, some data is lost and the active DataNode instance works incorrectly.

Possible Causes

  • The xlog file under the pg_xlog directory is deleted when the active DataNode instance is writing transactions.
  • If the standby DataNode instance works incorrectly when the active DataNode instance is writing transactions, the xlog file under the pg_xlog directory of the active DataNode instance is deleted.

Procedure

NOTE:
  • The cluster automatically triggers the reconstruction of the standby instance. This alarm is automatically cleared after the reconstruction is successful.
  • If the alarm is not cleared for a long time, restart the node.
  1. Log in to the FusionInsight Manager.

    1. Log in to the ManageOne OM plane using a browser, then choose Alarms.
      • Login address: https://URL for the homepage of the ManageOne OM plane:31943. Example: https://oc.type.com:31943.
      • Default username: admin, default password: Huawei12#$.
    2. In the alarm list, locate and click the target alarm name in the Name column. The Alarm Details and Handling Recommendations dialog box is displayed.
    3. Locate the value in the IP Address/URL/Domain Name column, which is the float IP address of the FusionInsight Manager.
    4. Log in to the FusionInsight Manager using a browser.
      • Login address: https://float IP address of the FusionInsight Manager:28443/web. Example: https://10.10.192.100:28443/web.
      • Default username: admin, default password: obtain it from the system administrator.

  2. On FusionInsight Manager, click Alarms. On the alarm list, locate the alarm and obtain the information about the node and instance for which the alarm is generated from Location in the Alarm Details area.
  3. Choose Services > MPPDB > Instances.
  4. Select the node on which the alarm is generated, and choose More Actions > Restart Instance. Wait for 5 minutes and check whether the alarm persists.

    • If yes, go to 5.
    • If no, no further action is required.

Collect fault information.

  1. On FusionInsight Manager, choose System > Log Download.
  2. Select MPPDB from the Services drop-down list box and click OK.
  3. Set Start Time for log collection to 1 hour ahead of the alarm generation time and End Time to 1 hour after the alarm generation time, and click Download.
  4. Contact Technical Support and send the collected logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 46482

Downloads: 33

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