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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-11010 ScaleInstance-Failed

ALM-11010 ScaleInstance-Failed

Description

When conditions for triggering the scaling policy are met, the Policy Engine service calls CFE to scale applications. This alarm is reported when the scale-out/scale-in fails.

Attribute

Alarm ID

Alarm Severity

Alarm Type

11010

Major

Processing error alarm

Parameters

Parameter Name

Parameter Description

group_name

Auto scaling (AS) group name.

policy_name

AS policy name.

deployment_name

Application name.

Impact on the System

  • Scale-out failures may lead to insufficient application resources and slow service access.
  • Scale-in failures may lead to waste of resources, but have no impact on applications.

System Actions

None

Possible Causes

  • Failed to call IAM to obtain the token.
  • Failed to call CFE for scaling.

Procedure

  1. Log in to FusionStage.

    1. Use a browser to log in to ManageOne Operation Portal (ManageOne Tenant Portal in B2B scenarios) as a VDC administrator or VDC operator.
      Login address:
      • Login address in a non-B2B scenario: https://Address for accessing ManageOne Operation Portal, for example, https://console.demo.com.
      • Login address in the B2B scenario: https://Address for accessing ManageOne Tenant Portal, for example, https://tenant.demo.com
    2. Select your region and then project from the drop-down list on the top menu bar.
    3. Choose Console > Application > FusionStage from the main menu.

  2. Choose Application Operations > Application Operations from the main menu.
  3. In the navigation pane, choose Alarm Center > Alarm List.
  4. Check whether the token has been obtained based on the additional alarm information. If it fails to be obtained, check whether the IAM service is available.

    If yes, go to 6.

    If no, contact IAM technical support.

  5. Check whether the CFE API has been called based on the additional alarm information. If it fails to be called, check whether the CFE service is available.

    If yes, go to 6.

    If no, contact CFE technical support.

  6. Use PuTTY to log in to the manage_lb1_ip node.

    The default username is paas, and the default password is QAZ2wsx@123!.

  7. Run the following command and enter the password of the root user to switch to the root user:

    su - root

    Default password: QAZ2wsx@123!

  8. Run the following command to access the pod to view run logs (the log directory is /var/paas/sys/log), and contact technical support:

    kubectl get pod -nfst-manage |grep pe-ats

    kubectl exec -ti -nfst-manage pe-ats-xxx sh

    cd /var/paas/sys/log/policy_engine/

    vi peserver.log

    NOTE:

    pe-ats-xxx indicates the pod name.

Alarm Clearing

The application that failed to be scaled is running properly.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 45292

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