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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-38019 VoltDB Connection Error

ALM-38019 VoltDB Connection Error

Description

This alarm is reported when the service fails to connect to the VoltDB database. This alarm is automatically cleared when the connection recovers.

Attribute

Alarm ID

Alarm Severity

Alarm Type

38019

Major

Communications alarm

Parameters

Parameter Name

Parameter Description

NameSpace

Indicates the namespace of the service for which the alarm is generated.

ServiceName

Indicates the name of the service for which the alarm is generated.

InstanceName

Indicates the name of the service instance for which the alarm is reported.

Impact on the System

The service is affected.

Possible Causes

The VoltDB service is stopped or abnormal.

Procedure

  1. Use PuTTY to log in to the manage_lb1_ip node.

    The default username is paas, and the default password is QAZ2wsx@123!.

  2. Run the following command and enter the password of the root user to switch to the root user:

    su - root

    Default password: QAZ2wsx@123!

  3. Run the following command to check whether the Voltdb status is Running.

    kubectl get pod -n fst-manage -o wide | grep dpa-voltdb

    • If yes, go to Step 4.
    • If no, go to Step 6.

  4. Run the following command to check the listening status of the Voltdb service port.

    1. Run the following command to go to the database instance dpa-voltdb-0, which is used as an example.

      kubectl exec -it -nfst-manage dpa-voltdb-0 bash

    2. Check whether the listening port status is LISTEN.

      netstat -an|grep LISTEN

      • If yes, go to Step 5.

      • If no, go to Step 6.

  5. The alarm is automatically cleared after 1 to 3 minutes. If the alarm persists, go to Step 6.
  6. Contact technical support for assistance.

Alarm Clearing

This alarm is automatically cleared when the service can connect to VoltDB normally.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 34474

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