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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-70086 Certificate Expiration Early Warning

ALM-70086 Certificate Expiration Early Warning

Description

FusionSphere OpenStack periodically (default interval: 7 days) checks the validity of the third-party service certificate and Keystone PKI certificate. This alarm is generated when a certificate has not taken effect, is about to expire, or has expired.

Attribute

Alarm ID

Alarm Severity

Auto Clear

70086

Major/Critical

Yes

Parameters

Name

Meaning

Fault Location Info

service_name: specifies the name of the service for which the alarm is generated.

Additional Info

  • detail_info: provides detailed information about the alarm.
  • host_id: specifies the ID of the host for which the alarm is generated.
  • hostname: specifies the name of the host for which the alarm is generated.

Impact on the System

If the third-party service certificate or Keystone PKI certificate has expired and certificate authentication is enabled, the service and the CLI will become unavailable.

Possible Causes

  • The third-party service certificate or Keystone PKI certificate has not taken effect. The alarm severity is critical.
  • The third-party service certificate or Keystone PKI certificate is about to expire within 30 days. The alarm severity is major.
  • The third-party service certificate or Keystone PKI certificate will expire within 7 days. The alarm severity is critical.
  • The third-party service certificate or Keystone PKI certificate has expired. The alarm severity is critical.

Procedure

  1. Check the certificate for which the alarm is generated based on the alarm details.

    • For a third-party service certificate, go to 2.
    • For a Keystone PKI certificate, go to 3.

  2. Replace the third-party service certificate by referring to section "Replacing the Certificate for Authenticating Third-party Services" in the HUAWEI CLOUD Stack 6.5.0 Security Management Guide.
  3. Rectify the fault according to the alarm details.

  4. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, contact technical support for assistance.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

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