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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-37020 MPPDBServer Connection Authentication Is Abnormal

ALM-37020 MPPDBServer Connection Authentication Is Abnormal

Description

This alarm is generated if a user remotely accesses a Coordinator or DataNode instance in TRUST mode.

Attribute

Alarm ID

Alarm Severity

Auto Clear

37020

Major

Yes

Parameters

Name

Meaning

ServiceName

Identifies the service for which the alarm is generated.

RoleName

Identifies the role for which the alarm is generated.

HostName

Identifies the host for which the alarm is generated.

Instance

Identifies the instance for which the alarm is generated.

Impact on the System

Because the TRUST authentication mode is prohibited in remote access, a user cannot remotely access a Coordinator or DataNode instance in TRUST mode.

Possible Causes

The authentication mode for remote access to a data instance (Coordinator or DataNode instance) is incorrect.

Procedure

Locate the alarm cause.

  1. Log in to the FusionInsight Manager.

    1. Log in to the ManageOne OM plane using a browser, then choose Alarms.
      • Login address: https://URL for the homepage of the ManageOne OM plane:31943. Example: https://oc.type.com:31943.
      • Default username: admin, default password: Huawei12#$.
    2. In the alarm list, locate and click the target alarm name in the Name column. The Alarm Details and Handling Recommendations dialog box is displayed.
    3. Locate the value in the IP Address/URL/Domain Name column, which is the float IP address of the FusionInsight Manager.
    4. Log in to the FusionInsight Manager using a browser.
      • Login address: https://float IP address of the FusionInsight Manager:28443/web. Example: https://10.10.192.100:28443/web.
      • Default username: admin, default password: obtain it from the system administrator.

  2. On FusionInsight Manager, click Alarms. On the alarm list, locate the alarm and obtain the information about the node and instance for which the alarm is generated from Location in the Alarm Details area.
  3. Log in to the node where the alarm is generated as the omm user. In the pg_hba.conf file under the data directory of the involved data instance, check whether the TRUST authentication mode is configured for remote access. If it is configured, change it to the non-TRUST mode. In the following example, the authentication mode for client IP address 10.90.57.224 is changed to sha256.

    Default user: omm, default password: Bigdata123@.
    NOTE:

    The nodes in the cluster uses the TRUST authentication mode, and the sha256 authentication mode needs to be configured for the nodes outside the cluster.

    vim /srv/BigData/mppdb/data1/coordinator/pg_hba.conf

    host    all             all             10.90.57.221/32              trust host    all             all             10.90.57.222/32              trust host    all             all             10.90.57.223/32              trust host    all             all             10.90.57.224/32              sha256

  4. Access the data instance again and check whether the alarm persists.

    • If yes, go to 5.
    • If no, no further action is required.

Collect fault information.

  1. On FusionInsight Manager, choose System > Log Download.
  2. Select MPPDB from the Services drop-down list box and click OK.
  3. Set Start Time for log collection to 1 hour ahead of the alarm generation time and End Time to 1 hour after the alarm generation time, and click Download.
  4. Contact Technical Support and send the collected logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 49174

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