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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
ALM-16005 Abnormal Cluster Host

ALM-16005 Abnormal Cluster Host

Description

This alarm is generated when a cluster host (LVS or Nginx) is abnormal.

Attribute

Alarm ID

Alarm Severity

Alarm Type

16005

Major

Communications alarm

Parameters (for Alarm Locating)

Table 17-12 Parameters

Name

Description

Example

namespace

Namespace to which the Elastic Load Balance (ELB) service belongs.

elb

ServiceName

Name of the service that generates the alarm.

ELB

InstanceName

Name of the microservice that generates the alarm.

elb-svc

LVSAddr

List of LVS node IP addresses.

10.8.154.144,10.8.154.145

NginxAddr

List of Nginx node IP addresses.

10.8.154.146,10.8.154.147

Impact on the System

Services on the data plane may be interrupted.

System Actions

None.

Possible Causes

  • The cluster host is powered off or shut down.
  • The Nginx process is not started or fails to be started.
  • A network exception occurs.

Solution

Perform the following steps:

  1. Log in to the FusionStage tenant management zone console.

    The console address is https://Access address of the console home page, for example, https://console.demo.com.

  2. Choose Application Operations > Application > FusionStage from the main menu.
  3. Choose Application Operations > Application Operations
  4. Choose Alarm Center > Alarm List to query the alarm information about ALM-16005 Abnormal Cluster Host.

    Additional information: Restore the faulty host or the process according to the alarm reference document.

  5. Check whether the cluster host is powered off or shut down.

    • If the host is powered off or shut down, power it on and perform subsequent steps to check whether the Nginx process is running properly.
    • If the host is not powered off or shut down, perform subsequent steps to check whether the Nginx process is running properly.

  6. Use PuTTY to log in to the faulty host (LVS node or Nginx node).

    The default username is paas. The default password is QAZ2wsx@123!.

  7. Run the following command to check whether the Nginx process is running properly:

    ps -ef|grep nginx|grep -v grep

    If information similar to the following is displayed, the Nginx process is running properly. Otherwise, the Nginx process is abnormal. Go to 8.

    • LVS node
      [paas@elb-lvs01 ~]$ ps -ef|grep nginx|grep -v grep
      paas    
      18746     1  0 15:58 ?        00:00:00 nginx: master process
      /usr/local/NSP/sbin/nginx -c /usr/local/NSP/etc/nginx/etcd_proxy.conf
      paas     18747
      18746  0 15:58 ?        00:00:07 nginx: worker process
      paas    
      18953     1  0 15:58 ?        00:00:00 nginx: master process
      /usr/local/NSP/sbin/nginx
      paas     18954
      18953  0 15:58 ?        00:00:37 nginx: worker process
    • Nginx node
      paas     18106     1  0 21:48 ?        00:00:00 nginx: master process /usr/local/NSP/sbin/nginx
      paas     18451     1  0 21:48 ?        00:00:00 nginx: master process /usr/local/NSP/sbin/nginx -c /usr/local/NSP/etc/nginx/manager_nginx.conf
      paas     18452 18451  0 21:48 ?        00:00:00 nginx: worker process
      paas     18953     1  0 21:48 ?        00:00:00 nginx: master process /usr/local/NSP/sbin/nginx -c /usr/local/NSP/etc/nginx/etcd_proxy.conf
      paas     18954 18953  0 21:48 ?        00:00:00 nginx: worker process

  8. Run the following command to restart the Nginx process:

    • LVS node: sh /usr/local/NSP/etc/lua/bin/restart_lvs.sh
    • Nginx node: sh /usr/local/NSP/etc/router/bin/restart_nginx.sh

  9. Check whether the Nginx process is running properly.

    For details, see 7. If the Nginx process is still running abnormally, contact technical support.

Alarm Clearance

After the fault is rectified, the system automatically clears the alarm.

Related Information

None.

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Updated: 2019-08-30

Document ID: EDOC1100062365

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