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HUAWEI CLOUD Stack 6.5.0 Alarm and Event Reference 04

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ALM-70130 VM HA Failed

ALM-70130 VM HA Failed

Description

This alarm is generated when VM HA malfunctions.

  • This alarm is cleared when the status of the VM is restored to the running or stopped state.
  • If HA cannot be complete due to resource insufficiency or VM affinity settings, this alarm cannot be automatically cleared. You can manually clear it or wait for the system to clear it later after troubleshooting the system.

Attribute

Alarm ID

Alarm Severity

Auto Clear

70130

Major

Yes

Parameters

Name

Meaning

Fault Location Info

  • instance_id: specifies the ID of the VM for which the alarm is generated.
  • tenant_id: specifies the ID of the tenant of the VM for which the alarm is generated.

Additional Info

  • availability_zone: specifies the name of the AZ where the VM for which the alarm is generated is located.
  • instance_name: specifies the name of the VM for which the alarm is generated.
  • hostname: specifies the name of the host accommodating VM for which the alarm is generated.
  • host_id: specifies the ID of the host accommodating the VM for which the alarm is generated.

Impact on the System

The HA-triggered VM fails to restore. FusionSphere OpenStack will restore it on the current host or other available hosts.

Possible Causes

  • There are no available resources.
  • VM affinity settings are performed on the VM.

Procedure

  1. Check whether the alarm is cleared automatically.

    This alarm is automatically cleared after the VM is rebuilt.

    • If yes, no further action is required.
    • If no, resources on hosts in the system may be insufficient for rebuilding the VM. Go to 2.

  2. Log in to the Service OM web client.

    For details, see Logging In to and Logging Out of Service OM.

  3. On Service OM, choose Services > Computing > ECS > Hosts and Hypervisors.
  4. Check whether the host on which the VM locates is powered off or a host-related alarm is generated on Service OM.

    • If yes, troubleshoot the host and restart the host. After 10 minutes, check whether the VM is restored.
      • If the host cannot be recovered, replace the host and accessories by referring to "Replacing Hosts and Accessories" in HUAWEI CLOUD Stack 6.5.0 Parts Replacement.
      • If the host is restored but HA cannot be complete due to VM affinity settings, specify a suitable destination host for cold migrating and go to 5.
      • If the VM has been restored, no further action is required.
    • If no, go to 6.

  5. Choose Computing > ECS > Compute Instances, locate the VM, choose More > Cold Migrate in the Operation column, and click OK in the displayed dialog box. On the Cold Migrate page that is displayed, select Specify Host to migrate the VM.

    NOTE:

    VM migration with hosts specified may break affinity rules. Make sure that you select eligible target hosts.

  6. Contact technical support for assistance if the alarm cannot be cleared automatically.

Related Information

None

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Updated: 2019-08-30

Document ID: EDOC1100062365

Views: 44935

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