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HUAWEI CLOUD Stack 6.5.0 Troubleshooting Guide 02

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Service Faults

Service Faults

Symptom

The HDCS Service process breaks down or the process fails to be started.

Possible Causes

  • The user for starting the Service process is not datasight.
  • The GaussDB password ciphertext in the configuration file is incorrect. As a result, the process fails to decrypt the GaussDB password, causing the Service process start failure.

Troubleshooting Process

  1. Check whether the process is started by the datasight user.
  2. Query the /var/log/bigdata/apigateway/api-gateway.log file of the Service node to locate the fault.

Procedure

  1. If the user for starting the process is not datasight, perform the following operations to rectify the fault:

    • Use PuTTY to log in to the HDCS Service node as the datasight user using the IP address of the HDCS Service node.

      Default username: datasight; default password: Cloud12#$

    • Run the ps -ef |grep tomcat command to obtain the ID of the current Tomcat process.
    • Run the kill -9 [tomcat-process-id] command among which [tomcat-process-id] indicates the ID of the current Tomcat process.
    • Run the bash /opt/mrs/tomcat/bin/startup.sh command to start the service. If the service is properly started, the following information is displayed:
    [datasight@MRSAPISvc01 ~]$ ps -ef |grep tomcat 
    datasig+   6800      1  0 Nov27 ?        00:09:17 /usr/local/java/jdk1.8.0_77/jre/bin/java -Dnop -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djdk.tls.ephemeralDHKeySize=2048 -Dorg.apache.catalina.security.SecurityListener.UMASK=0027 -Xms4096m -Xmx4096m -Djava.endorsed.dirs=/opt/mrs/tomcat/endorsed -classpath /opt/mrs/tomcat/bin/bootstrap.jar:/opt/mrs/tomcat/bin/tomcat-juli.jar -Dcatalina.base=/opt/mrs/tomcat -Dcatalina.home=/opt/mrs/tomcat -Djava.io.tmpdir=/opt/mrs/tomcat/temp org.apache.catalina.startup.Bootstrap start
    datasig+ 106277 106183  0 17:47 pts/0    00:00:00 grep --color=auto tomcat

  2. If the GaussDB password ciphertext in the configuration file is incorrect, perform the following operations:

    • Contact the GaussDB administrator to obtain the plaintext password of the database.
    • Contact related personnel to encrypt the password.
    • Replace the original ciphertext of the password item in the /opt/mrs/tomcat/webapps/api-gateway/WEB-INF/classes/jdbc.properties file of the Service node with the new one.
    • Restart the Service service by referring to 1.

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Updated: 2019-06-01

Document ID: EDOC1100062375

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