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HUAWEI CLOUD Stack 6.5.0 Troubleshooting Guide 02

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Failure in Deleting Helm Application of the DaemonSetType

Failure in Deleting Helm Application of the DaemonSetType

Symptom

When a node is unavailable, a Helm application containing DaemonSet is successfully created and installed. However, the DaemonSet resource cannot be deployed and remains in the pending state. Deleting the Helm application at this time will cause request timeout and fail.

Possible Cause

The creation logic of DaemonSet is to deploy a pod on each node. The pod cannot be deployed because the node is unavailable. As a result, the DaemonSet cannot be deployed. Deleting the DaemonSet at this time will cause timeout and fail because the pod has been generated but not deployed on the node.

Troubleshooting Method

  1. Check the cause of the node unavailability and restore the node to the Ready state. For details, see Node in NotReady State

    NOTE:

    Before the node is restored, you can log in to the platform and manually delete the resource. This operation will result in residual pod. Pod deletion is mandatory. Exercise caution.

  2. After the node is restored, go to the page of the resource or Helm application to be deleted and delete the corresponding resource or application.
  3. If the fault persists, contact technical support for assistance.
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Updated: 2019-06-01

Document ID: EDOC1100062375

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