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HUAWEI CLOUD Stack 6.5.0 Troubleshooting Guide 02

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VPC Service Faults

VPC Service Faults

Symptom

The VPC service is unavailable.

Possible Causes

  • The file systems on the service VMs are corrupted.
  • A VPC-Service process exception has occurred.

Troubleshooting Process

Figure 14-2 shows the troubleshooting process.

Figure 14-2 Troubleshooting process

Procedure

  1. Check whether you can normally log in to the VM (PUB-SRV01, PUB-SRV02, or PUB-SRV03) where VPC-Service is deployed.

    • If you can normally log in to the VM, go to 4.
    • If you cannot normally log in to the VM, go to 2.

  2. Contact technical support for assistance to repair the VM OS.

    • If the VM OS is successfully repaired, go to 4.
    • If the VM OS fails to be repaired, go to 3.

  3. Contact technical support for assistance to reinstall VPC-Service.
  4. Use PuTTY to log in to the PUB-SRV01, PUB-SRV02, or PUB-SRV03 VM.

    Username: vpc; default password: Huawei12#$

  5. Run the following command to switch to user root:

    sudo su - root

  6. Run the following command to disable user logout upon system timeout:

    TMOUT=0

  7. Run the following command to check whether the Tomcat process is running:

    ps -ef | grep tomcat

    • If the process is running, no further action is required.
    • If the process is not running, go to 8.

  8. Run the following command as the vpc user to restart the Tomcat process:

    sh /home/vpc/local/tomcat/bin/restart.sh

  9. Check whether the alarm is cleared after the restart.

    • If the alarm is cleared, go to 10.
    • If the alarm is not cleared, contact technical support for assistance to reinstall the service. After the reinstallation, no further action is required.

  10. Run the following command as the vpc user to check whether the Zookeeper process is running:

    cd /home/vpc/zookeeper

    ./bin/zkServer.sh status

    • If the process is running, no further action is required.
    • If the process is not running, go to 11.

  11. Run the following command as the vpc user to restart the Tomcat process:

    sh /home/vpc/local/tomcat/bin/restart.sh

  12. Check whether the alarm is cleared after the restart.

    • If the alarm is cleared, no further action is required.
    • If the alarm is not cleared, contact technical support for assistance to reinstall the service. After the reinstallation, no further action is required.

  13. If multiple VMs are faulty, perform 1 to 12 for each faulty VM.
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Updated: 2019-06-01

Document ID: EDOC1100062375

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