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HUAWEI CLOUD Stack 6.5.0 Troubleshooting Guide 02

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Node in NotReady State

Node in NotReady State

Symptom

A node is in the NotReady state.

Possible Causes

  • Basic processes running on the node are abnormal.
  • The disk space of the node is fully occupied.

Troubleshooting Method

  1. Use PuTTY to log in to the node which is in the NotReady state as the paas user.
  2. Run the monit summary command to check the status of basic processes such as kubelet, kube-proxy, docker, and canal.

    The following figure shows the proper running of the processes.

    If a component is abnormal, restart the monit restart {Process name} process. If the process still fails to be restarted, contact technical support for assistance.

  3. Run the following command to switch to the root user:

    su - root

  4. Run the following command to obtain the IP address for accessing kube-apiserver:

    cat /opt/kube-agent/kubernetes/kubelet/kubeconfig | grep server

    Information similar to the following is displayed:

    server: https://10.22.15.28:4443

    1. Run the curl -k https://IP address for accessing kube-apiserver command to check whether the node can communicate with kube-apiserver.

      If the following information is displayed, the node cannot communicate with kube-apiserver. If the node can communicate with kube-apiserver, go to 5 to check whether the fault is caused by the used-up disk space of the node.

      {
        "kind": "Status",
        "apiVersion": "v1",
        "metadata": {
      
        },
        "status": "Failure",
        "message": "Unauthorized",
        "reason": "Unauthorized",
        "code": 401
      }
    2. If information similar to the following is displayed, the route to the host is not detected. In this case, ping the route. If the ping operation fails, contact technical support for assistance.

      ping 10.120.172.68

      Failed connect to 10.120.172.68:5443; Connection refused
    3. For other network errors, contact technical support for assistance.

  5. Run the df -h/opt command to check whether the disk usage of the node reaches 100%.

    If yes, contact technical support for assistance.

    Filesystem                  Size  Used Avail Use% Mounted on
    /dev/mapper/opt_vg-vol_opt   197G   189G   0G  100% /opt

  6. If the fault persists, contact technical support for assistance.
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Updated: 2019-06-01

Document ID: EDOC1100062375

Views: 2100

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