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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Error 500 Is Displayed When Users View the Node List and Application Pages on the Console After a Restart upon a Power Outage

Error 500 Is Displayed When Users View the Node List and Application Pages on the Console After a Restart upon a Power Outage

Symptom

The 500 Internal Server Error is generated when you access the node list or application management pages on the console after a restart upon a power outage. Error 500 is displayed after you press F12 and click the Network tab to invoke the node and deploy APIs.

Possible Causes

Kube-apiserver is working improperly.

Troubleshooting Method

  1. Use PuTTY to log in to the om_paas_vip node.

    The default username is paas, and the default password is QAZ2wsx@123!.

  1. Run the following command to obtain the pods of kube-apiserver in the management zone:

    kubectl get pod -n manage | grep kube-apiserver

    The following figure shows the command output.

    In the preceding command output, kube-apiserver-2445446721-pm49l indicates the first pod name, and kube-apiserver-2445446721-t3k3n indicates the second pod name.

  2. Run the following commands to delete the pods of kube-apiserver:

    kubectl delete kube-apiserver-2445446721-pm49l -n manage

    kubectl delete kube-apiserver-2445446721-t3k3n -n manage

    Wait for about 5 minutes until the two pods are restarted.

  3. Run the following command to check whether the pods of kube-apiserver are started and whether their status changes to Running:

    kubectl get pod -n manage | grep kube-apiserver

  4. Switch to the node list page again.

    If the page and the node information are displayed, the fault is rectified.

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Updated: 2019-06-10

Document ID: EDOC1100063248

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