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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Abnormal Applications

Abnormal Applications

Symptom

Application deployment fails, and applications are abnormal.

Possible Causes

The node where applications locate is abnormal.

Troubleshooting Method

  1. Log in to the ServiceStage tenant management zone console.

    1. Use a browser to log in to the ManageOne operation plane as a VDC administrator or a VDC operator.
      • Login address in non-B2B scenarios: https://Address for accessing the console homepage, for example, https://console.type.com
      • Login address in B2B scenarios: https://Address to access the tenant portal of the ManageOne operation plane, for example, https://console.type.com
    2. Select your region and then project from the drop-down list on the top menu bar.
    3. On the home page, choose Application > Container Application Platform.

      Alternatively, choose Console > Application > Container Application Platform from the main menu.

  2. Choose AppRelease > App Management..
  3. Access the abnormal application details page and choose the Events tab page on the Instances tab page. View the error information to analyze the cause.
  4. Use the logs to analyze the possible causes.

    • There are abnormal processes on the node.
      1. Use PuTTY to log in to the abnormal node as user paas.
      2. Run the following command to query processes:

        monit summary

        • If there are processes that are not in the Running status, run the following command:

          monit restart {Process name}

        • If there are processes that are not started, contact technical support for assistance.
      3. Locate the cause.

        Use PuTTY to log in to the manage_core1_ip node.

        The default username is paas, and the default password is QAZ2wsx@123!.

        Run the following command to query the error information. Table 23-2 lists the error information.

        kubectl describe pod {Name of pod where abnormal applications locate} -n namespace

        Table 23-2 Error information

        Error Information

        Meaning and Solution

        fit no node

        The scheduling rules are not fulfilled. Modify the affinity rules of the application and redeploy the application.

        Failed to pull image

        Image files or software packages fail to be obtained. Check whether the image address is correct.

        mount volume failed

        Contact technical support for assistance.

    • If the problem persists, contact technical support for assistance.

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Updated: 2019-06-10

Document ID: EDOC1100063248

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