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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Cluster Schedule Service (AS-Schedule) Fault

Cluster Schedule Service (AS-Schedule) Fault

Symptom

The cluster schedule service (AS-Schedule) is faulty. As a result, scheduled and periodic tasks cannot be processed.

Possible Causes

  • The file system of the VM where the service is deployed is corrupted.
  • The service process is abnormal.

Fault demarcation methods

Figure 11-2 shows the fault demarcation methods.

Figure 11-2 Fault demarcation methods

Procedure

  1. Check whether you can log in to the VM where AS-Schedule is deployed.

    • If yes, go to 4.
    • If no, go to 2.

  2. Restore the VM. For details, see Cloud Service Management Plane Fault Diagnosis.
  3. Contact technical support to reinstall AS-Schedule. No further action is required.
  4. Use PuTTY to log in to AS-SCHEDULE-SCHEDULE01 or AS-SCHEDULE-SCHEDULE02.

    Default username: admin; default password: IaaS@OS-CLOUD9!

  5. Run the following command to disable user logout upon system timeout:

    TMOUT=0

  6. Run the following command to check whether the process exists:

    ps -ef|grep autoscaling-schedule

    • If yes, go to 7.
    • If no, go to 8.

  7. Run the following command to stop the process:

    sh /opt/autoscaling/autoscaling-schedule/bin/schedule.sh stop

  8. Run the following command to restart the process:

    sh /opt/autoscaling/autoscaling-schedule/bin/schedule.sh restart

  9. Check whether AS-Schedule is restored.

    • If yes, no further action is required.
    • If no, contact technical support for assistance.

  10. If multiple VMs are faulty, perform 1 to 9 on all the faulty VMs.
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Updated: 2019-06-10

Document ID: EDOC1100063248

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