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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Image Convert Troubleshooting

Image Convert Troubleshooting

Symptom

Combined API and Image Convert are deployed on the CPT-SRV01 and CPT-SRV02 nodes. If Image Convert is unavailable, the VM where Image Convert is located may be faulty or the Image Convert process may be abnormal.

The Tomcat process is faulty. As a result, the VM cannot provide Image Convert.

Possible Causes

The ECS restarts due to a power failure, and an error occurs when Image Convert process is restarted by the monitoring script.

NOTE:

If one of the ECSs where Image Convert is deployed becomes faulty, only tasks already issued to this ECS are affected. If the ECS restores during Combined API task expiration interval, the ECS will continue to execute the tasks already issued to it.

Troubleshooting Process

Figure 10-1 shows the fault demarcation methods.

Figure 10-1 Troubleshooting flowchart

Procedure

  1. Check whether you can log in to the CPT-SRV01 or CPT-SRV02 where Image Convert is deployed.

    • If yes, go to 4.
    • If no, go to 2.

  2. Restore the VM. For details, see Cloud Service Management Plane Fault Diagnosis.
  3. Contact technical support for assistance to reinstall Image Convert. The task is complete.
  4. Use PuTTY to log in to the Image Convert service node CPT-SRV01 or CPT-SRV02 .

    • Login address: management IP address of the node
    • Username: sysadmin
    • Default password: Huawei12#$

  5. Run the following command to disable logout on timeout:

    TMOUT=0

  6. Run the following command to check whether the Tomcat process is running:

    ps -ef | grep tomcat

    • If yes, go to 7.
    • If no, go to 8.

  7. Run the following command to stop the Tomcat process:

    kill -9 $pid

  8. Run the following command to start the Tomcat process:

    sh /opt/imcs/tomcat/bin/startup.sh

  9. Run the following command to query the /var/log/imcs/taskmgr/tomcat.log file to check whether a loading error has occurred:

    vi /var/log/imcs/taskmgr/tomcat.log

    • If yes, contact technical support for assistance.
    • If no, go to 10.

  10. Run the following command to check whether the /var/log/imcs/taskmgr/taskmgr.log file contains error logs to determine whether Image Convert is available:

    vi /var/log/imcs/taskmgr/taskmgr.log
    • If yes, contact technical support for assistance.
    • If no, no further action is required.

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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 22561

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