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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Simple Message Notification Troubleshooting (Full Version)

Simple Message Notification Troubleshooting (Full Version)

Symptom

An SMN process fault is detected on the ManageOne OM plane.

Possible Causes

  • The VM is faulty.
  • The ZooKeeper process is abnormal.
  • The Kafka process is abnormal.

Troubleshooting Process

Figure 21-1 shows the troubleshooting process.

Figure 21-1 Troubleshooting process on nodes

Procedure

  1. Log in to the ManageOne OM plane using a browser.

    • URL: https://Address for the homepage of the ManageOne OM plane:31943. For example: https://oc.type.com:31943.
    • Default username: admin, default password: Huawei12#$.

  2. On the menu bar in the upper part of the page, choose Alarms > Current Alarms.
  3. In the alarm list, locate the alarm to be handled, and click on the left of the alarm. The Details page is displayed.
  4. Choose Location Info, obtain the host IP address, that is, the IP address of the node where the alarm is generated.
  5. Use PuTTY to log in to the node for which the alarm is generated. Ensure that the management IP address of the node obtained in 4 is used to establish the connection.

    The default username is hermes, and the default password is Hermes@123.
    • If yes, go to 6.
    • If no, the VM is faulty. Contact technical support for assistance.

  1. Run the following command to check whether the ZooKeeper process on the node is running properly:

    sh /opt/hermes/service/zookeeper/bin/zkServer.sh status

    Information similar to the following is displayed:

    Mode: follower

    Mode indicates the role of a ZooKeeper node.

  2. Perform one of the following operations based on the value of Mode:

    • If the value is leader or follower, the ZooKeeper process is normal. In this case, go to 10.
    • If any other value is displayed, go to 8.

  3. Run the following command to stop the ZooKeeper process:

    sh /opt/hermes/service/zookeeper/bin/stop_zookeeper.sh

  4. Run the following command to start the ZooKeeper process:

    sh /opt/hermes/service/zookeeper/bin/start_zookeeper.sh

    NOTE:

    If the daemon process is normal, the ZooKeeper process is automatically started. You do not need to start it manually.

  5. Perform operations from 6 to 7 on other nodes in the ZooKeeper cluster. Check whether the ZooKeeper process is running properly on each node in the cluster.

    • If yes, go to 11.
    • If no, contact technical support for assistance.

  6. Run the following command to stop the Kafka process:

    sh /opt/hermes/service/kafka/bin/stop_kafka.sh

  7. Run the following command to start the Kafka process:

    sh /opt/hermes/service/kafka/bin/start_kafka.sh

    NOTE:

    If the daemon process is normal, the Kafka process is automatically started. You do not need to start it manually.

  8. Run the following command to open the Kafka logs:

    vi /var/log/hermes/kafka/server.log

  9. Check whether an error is recorded in the log file.

    • If yes, contact technical support for assistance.
    • If no, the Kafka node is working properly. In this case, go to 15.

  10. Perform operations from 11 to 14 on other nodes in the Kafka cluster.
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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 23024

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