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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Service Node Faults

Service Node Faults

The DBSS Console Is Blank

Symptom

On the ManageOne operation plane, the DBSS Console is blank.

Possible Causes

The Tomcat process of the SCC-Console is abnormal.

Procedure
  1. Use PuTTY to log in to the SCC-Service-FusionGuard01 management VM using the IP address corresponding to SCC-Service01.

    Default username: sccadmin; default password: Scloud12#$

  2. Run the following command and enter the password Cloud12#$ of user root to switch to the root user:

    sudo su - root

  3. Run the following command to disable user logout upon system timeout:

    TMOUT=0

  4. Run the following command to check whether the Tomcat service is running:

    ps -ef | grep tomcat | grep -v grep

    • If yes, contact technical support for assistance.
    • If no, go to 5.

  5. Run the following command to restart the Tomcat process:

    systemctl start systemd-tomcat

  6. Use a browser to log in to the ManageOne operation plane as a VDC administrator or VDC operator.

    Login address: https://Domain name for accessing the console home page. Example: https://console.type.com.

  7. Select a region and a project from the drop-down box in the upper left corner of the page.
  8. Check whether the DBSS service can be accessed.

    • If yes, no further action is required.
    • If no, contact technical support for assistance.

The "Background maintenance is in progress. Please try again later." Message Is Displayed on the DBSS Console

Symptom

On the ManageOne operation plane, the "Background maintenance is in progress. Please try again later." message is displayed on the DBSS Console.

Possible Causes
  • The Nginx process of SCC-LB is abnormal.
  • The Tomcat process of SCC-Service is abnormal.
Procedure
  1. Log in to the SCC-LB node and check whether the Nginx process is normal.

    1. Use PuTTY to log in to the SCC-LB-FusionGuard01 management VM using the IP address corresponding to SCC-LB01.

      Default username: sccadmin; default password: Scloud12#$

    2. Run the following command and enter the password Cloud12#$ of user root to switch to the root user:

      sudo su - root

    3. Run the following command to disable user logout upon system timeout:

      TMOUT=0

    4. Run the following command to check whether the Nginx service is running:

      ps -ef | grep nginx | grep -v grep

      • If yes, go to 2.
      • If no, go to 1.e.
    5. Run the following command to restart the Nginx service:

      service nginxd start

    6. Use a browser to log in to the ManageOne operation plane as a VDC administrator or VDC operator.

      Login address: https://Domain name for accessing the console home page. Example: https://console.type.com.

    7. Select a region and a project from the drop-down box in the upper left corner of the page.
    8. Check whether the DBSS service can be accessed.
      • If yes, no further action is required.
      • If no, go to 2.

  2. Log in to the SCC-Service node and check whether the Tomcat process is normal.

    1. Use PuTTY to log in to the SCC-Service-FusionGuard01 management VM using the IP address corresponding to SCC-Service01.

      Default username: sccadmin; default password: Scloud12#$

    2. Run the following command and enter the password Cloud12#$ of user root to switch to the root user:

      sudo su - root

    3. Run the following command to disable user logout upon system timeout:

      TMOUT=0

    4. Run the following command to check whether the Tomcat service is running:

      ps -ef | grep tomcat | grep -v grep

      • If yes, go to 2.e.
      • If no, run the following command to restart the Tomcat service and perform 2.d again. If the fault persists, contact technical support for assistance.

        systemctl start systemd-tomcat

    5. Run the following command to check whether DBSS is configured properly.

      vim /opt/tomcat/conf/server.xml

      • If yes, go to 2.f.
      • If no, configure the DBSS service, run the following command to restart the Tomcat service and perform 2.e again. If the fault persists, contact technical support for assistance.
        systemctl restart systemd-tomcat
        NOTE:

        The Tomcat configuration for DBSS is as follows:

        <Context path="/dbss" docBase="/opt/onframework/scc/scc_services_dbss/" reloadable="false"/>

    6. Run the following command to check whether the directory where the DBSS service is deployed exists:

      cd /opt/onframework/scc/scc_services_dbss

    7. Run the following command to check whether any file permission is abnormal:

      ll -R /opt/onframework/scc/scc_services_dbss/ | grep -v "tomcat cloudgrp"

      • If yes, run the following commands in sequence to restart the Tomcat service and perform 2.g again. If the fault persists, contact technical support for assistance.
        • chown tomcat:cloudgrp -R /opt/onframework/scc/scc_services_dbss/
        • systemctl restart systemd-tomcat
      • If no, go to 2.h.
    8. Run the following command to check whether the DBSS service is running properly:

      tailf /var/log/scc/dbss/dbss-service.log

      • If yes, go to 2.i.
      • If no, run the following command to restart the Tomcat service and perform 2.h again. If the fault persists, contact technical support for assistance.

        systemctl restart systemd-tomcat

    9. Use a browser to log in to the ManageOne operation plane as a VDC administrator or VDC operator.

      Login address: https://Domain name for accessing the console home page. Example: https://console.type.com.

    10. Select a region and a project from the drop-down box in the upper left corner of the page.
    11. Check whether the DBSS service can be accessed.
      • If yes, no further action is required.
      • If no, contact technical support for assistance.

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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 23313

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