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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Simple Message Notification Troubleshooting (Simplified Version)

Simple Message Notification Troubleshooting (Simplified Version)

Symptom

The SMN service is abnormal.

Possible Causes

  • The VM is faulty.
  • The Publish Server process is abnormal.
  • The Keepalived process is abnormal.
  • The HAProxy process is abnormal.

Troubleshooting Process

Figure 22-1 shows the troubleshooting process.

Figure 22-1 Troubleshooting process on nodes

Procedure

  1. Log in to the ManageOne OM plane using a browser.

    • URL: https://Address for the homepage of the ManageOne OM plane:31943. For example: https://oc.type.com:31943.
    • Default username: admin, default password: Huawei12#$.

  2. On the menu bar in the upper part of the page, choose Alarms > Current Alarms.
  3. In the alarm list, locate the alarm to be handled, and click on the left of the alarm. The Details page is displayed.
  4. Choose Location Info, obtain the host IP address, that is, the IP address of the node where the alarm is generated.
  5. Use PuTTY to log in to the node for which the alarm is generated. Ensure that the management IP address of the node obtained in 4 is used to establish the connection.

    The default username is hermes, and the default password is Hermes@123.
    • If yes, go to 6.
    • If no, the VM is faulty. Contact technical support for assistance.

  6. Run the following command to check whether the Publish Server process is running properly:

    ps -ef |grep -v grep | grep PublishServerMain | wc -l

    The process is running properly if the following information is displayed:
    1
    • If yes, go to 7.
    • If no, go to 9.

  7. Run the following command to check the HAProxy process:

    ps -ef |grep -v grep | grep haproxy | wc -l

    The process is running properly if the following information is displayed:
    1
    • If yes, go to 8.
    • If no, contact technical support for assistance.

  8. Run the following command to check the Keepalived process:

    ps -ef |grep -v grep | grep keepalived | wc -l

    The process is running properly if the following information is displayed:
    3
    • If yes, go to 9.
    • If no, contact technical support for assistance.

  9. Run the following command to check whether ERROR is displayed in the Publish Server logs:

    vi /var/log/hermes/publishServer/publishServer.log

    • If no, no further action is required.
    • If yes, collect error logs and contact technical support for assistance.

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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 22550

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