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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Service Deployment Faults

Service Deployment Faults

Service Deployment Failure

Symptom

A user fails to deploy the service.

Figure 19-2 Example of service deployment failure
Possible Causes
  1. Console node installation fails because the console node process fails to be started.
  2. The HDS VM fails to be created because the IP address has been occupied.
Procedure

Procedure for troubleshooting the failure of installing the console node

  1. Use PuTTY to log in to HDS-Console1 and HDS-Console2 to manage VMs.

    Default account: dbs; default password: Cloud12#$

  2. Run the following command to disable user logout upon session timeout:

    TMOUT=0

  3. Run the cd /opt/dbs/hds-console/bin command to switch to the /opt/dbs/hds-console/bin directory.
  4. Stop the HDS Console process.

    kill -9 {id}

  5. Run the following command to start the HDS Console process.

    /opt/dbs/hds-console/bin/startup.sh

  6. Log in to FusionCloud Deploy again and continue the automatic deployment.
  7. After the deployment is complete, check whether the deployment is successful on ManageOne.

Procedure for troubleshooting the failure of creating an HDS VM

  1. Log in to FusionCloud Deploy and view the HDS service project.
  2. In the Operation column of the failed step, click Details to view the failure details.
  3. View the deployment log path in the log details.
  4. Log in to the FusionCloud Deploy background node as the FusionCloud Deploy user, and switch to user root.
  5. Switch to the path identified in 7 and check the deployment log to see whether a message is displayed indicating that the port exists.
  6. If the message is displayed, the IP address has been occupied.
  7. Re-plan the IP address, upload parameter information to FusionCloud Deploy, and deploy the HDS service again.
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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 23025

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