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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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HAProxy Troubleshooting

HAProxy Troubleshooting

Symptom

The alarm generated by the ManageOne OM plane indicates that the HAProxy management node is faulty and needs to be recovered.

Possible Causes

  • The VM is faulty.
  • A keepalived process exception occurs.
  • An haproxy process exception occurs.

Fault Demarcation Methods

Figure 24-3 shows the troubleshooting flowchart for a management node fault.

Figure 24-3 Troubleshooting flowchart for a management node fault

Procedure

  1. Identify the IP address of the node where the process is abnormal based on the IP address in the alarm email on the ManageOne OM plane.
  2. Check whether you can use PuTTY to log in to the faulty node.

    The default username is ulb. The default password is cnp200@HW.
    • If yes, go to step 3.
    • If no, the VM is faulty. Contact technical support for assistance.

  3. Run the following command and enter the password of user root to switch to user root:

    sudo su - root

    The default password is Cloud12#$.

  4. Run the cd/etc/init.d command to access the directory where the process is located.
  5. Run the following command to check whether the keepalived process is running properly:

    service keepalived status

    NOTE:

    If the command output contains running, the process is running properly. If the command output does not contain running, the process is abnormal.

  6. Run the following command to restart the keepalived process:

    service keepalived restart

  7. Run the following command to check whether the keepalived process is running properly:

    service keepalived status

    • If yes, go to step 8.
    • If no, contact technical support for assistance.

  8. Run the following command to check whether the haproxy process is running properly:

    service haproxy status

    • If yes, contact technical support for assistance.
    • If no, go to step 9.

  9. Run the following command to restart the haproxy process:

    service haproxy restart

  10. Run the following command to check whether the haproxy process is running properly:

    service haproxy status

    • If yes, no further action is required.
    • If no, contact technical support for assistance.

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Updated: 2019-06-10

Document ID: EDOC1100063248

Views: 23090

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