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FusionCloud 6.3.1.1 Troubleshooting Guide 02

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Node in NotReady State

Node in NotReady State

Symptom

A node is in the NotReady state.

Possible Causes

  • Basic processes running on the node are abnormal.
  • The disk space of the node is fully occupied.

Troubleshooting Method

  1. Use PuTTY to log in to the node which is in the NotReady state as the paas user.
  2. Run the monit summary command to check the status of basic processes such as kubelet, kube-proxy, docker, and canal.

    The following figure shows the proper running of the processes.

    If a component is abnormal, restart the monit restart {Process name} process. If the process still fails to be restarted, contact technical support for assistance.

  3. Run the ps -ef | grep kubelet command on the node which is in the NotReady state to obtain the IP address of kube-apiserver. As shown in the following figure, 10.120.172.68 in https://10.120.172.68:5443 is the IP address for connecting Kubelet to kube-apiserver.

    1. Run the curl -k https://10.120.172.68:5443 command to confirm that the node can communicate with kube-apiserver.

      If information similar to the following is displayed, the network communication fails. You can go to 4 after ensuring that the communication is normal.

    2. If information similar to the following is displayed, the route to the host is not detected. In this case, ping the route. If the ping operation fails, contact technical support for assistance.

      ping 10.120.172.68

    3. For other network errors, contact technical support for assistance.

  4. Run the df -h/opt command to check whether the disk usage of the node reaches 100%.

    If yes, contact technical support for assistance.

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Updated: 2019-06-10

Document ID: EDOC1100063248

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