No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R013C00 Configuration Guide - Basic Configuration

This document describes the configurations of Basic, including CLI Overview, EasyDeploy Configuration, USB-based Deployment Configuration, Logging In to a Device for the First Time, CLI Login Configuration, Web System Login Configuration, File Management, Configuring System Startup, ISSU Configuration, BootLoad Menu Operation.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Deploying Zero Touch Devices Using the Commander (with Network Topology Collection Enabled)

Example for Deploying Zero Touch Devices Using the Commander (with Network Topology Collection Enabled)

Networking Requirements

Figure 3-13 shows a network of an enterprise on which the file server, DHCP server, and SwitchA have reachable routes to each other. New devices SwitchC, SwitchD, and SwitchE need to be deployed on the enterprise network. The new devices are located on a different network segment from the DHCP server. To reduce labor costs and save time on device deployment, the enterprise wants to realize automatic batch configuration and maintenance of the new devices. Network topology information collection is configured because the client MAC addresses or ESNs are not reported by the hardware installation engineer.

The address of VLANIF 20 on SwitchA is 192.168.4.2/24 and its peer address is 192.168.4.1/24.

The address of VLANIF 30 on SwitchB is 192.168.3.2/24 and its peer address is 192.168.3.1/24.

Table 3-6 lists information about the new devices to be configured.

Table 3-6  Device information
New Device Device Model Files to Be Loaded
SwitchC S5700-HI

s5700-hi.cfg

User-defined file header1.txt

SwitchD S5700-HI

s5700-hi.cfg

User-defined file header1.txt

SwitchE S5700-X-LI

s5700-x-li.cfg

User-defined file header2.txt

Figure 3-13  Networking diagram for zero touch device deployment using the commander

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the file server and save the files to be loaded on the file server.
  2. Configure the DHCP server function based on the global address pool on SwitchB and configure DHCP relay on SwitchA, so that the new devices can obtain IP addresses of their own and the Commander.
  3. Configure the Commander on SwitchA so that the new devices can be configured using the Commander.

    • Enable automatic configuration backup on the Commander to facilitate replacement of faulty devices in future maintenance.
    • Configure information about files to be downloaded for each client based on the network topology.
    • SwitchE is connected to SwitchC in cascading networking. Therefore, an appropriate global file activation delay time needs to be configured on the Commander to ensure that SwitchE has enough time to download the required files.

Procedure

  1. Configure the file server according to the server manual.

    After completing the configuration, save the required files on the file server.

  2. Configure the DHCP service.

    # Configure a DHCP server based on the global address pool.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] dhcp enable
    [SwitchB] vlan batch 30
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] ip address 192.168.3.2 24
    [SwitchB-Vlanif30] dhcp select global
    [SwitchB-Vlanif30] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 30
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 30
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] ip pool easy-operation
    [SwitchB-ip-pool-easy-operation] network 192.168.1.0 mask 255.255.255.0
    [SwitchB-ip-pool-easy-operation] gateway-list 192.168.1.6
    [SwitchB-ip-pool-easy-operation] option 148 ascii ipaddr=192.168.1.6;
    [SwitchB-ip-pool-easy-operation] quit
    

    # Configure a default route on SwitchB.

    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
    

    # Configure DHCP relay on SwitchA (Commander).

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] dhcp enable
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.6 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.4.2 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 20
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 20
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] dhcp select relay
    [SwitchA-Vlanif10] dhcp relay server-ip 192.168.3.2
    [SwitchA-Vlanif10] quit

    # Configure a default route on SwitchA.

    [SwitchA] ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
    

  3. Configure basic functions for the Commander.

    [SwitchA] easy-operation commander ip-address 192.168.1.6
    [SwitchA] easy-operation commander enable
    

  4. Configure file server information.

    [SwitchA] easy-operation
    [SwitchA-easyoperation] sftp-server 192.168.2.2 username admin password EasyOperation
    [SwitchA-easyoperation] quit

  5. Configure network topology collection.

    [SwitchA] ndp enable
    [SwitchA] ntdp enable
    [SwitchA] ntdp timer 5
    [SwitchA] easy-operation
    [SwitchA-easyoperation] topology enable
    [SwitchA-easyoperation] client auto-join enable
    [SwitchA-easyoperation] quit

  6. Enable the cluster function and configure a cluster management VLAN.

    [SwitchA] cluster enable
    [SwitchA] cluster
    [SwitchA-cluster] mngvlanid 10
    [SwitchA-cluster] quit

  7. Configure information about files to be downloaded.

    # Check network topology information collected on the Commander.

    [SwitchA] display easy-operation topology
    <-->:normal device         <??>:lost device
    Total topology node number: 3
    ------------------------------------------------------------------------------
    [SwitchA: 4CB1-6C8F-0447](Commander)
    |-(GE1/0/1)<-->(GE0/0/1)[HUAWEI: 00E0-FC34-3190](Client 1)
    |-(GE1/0/2)<-->(GE0/0/1)[HUAWEI: 00E0-FC12-A34B](Client 2)
    | |-(GE0/0/2)<-->(GE0/0/1)[HUAWEI: 5489-9875-edff] (Client 3)

    Based on the network planning and topology information, you can see that SwitchD, SwitchC, and SwitchE are Client1, Client2, and Client3 respectively.

    # Specify information about the files to be downloaded to Client1.

    [SwitchA] easy-operation
    [SwitchA-easyoperation] client 1 configuration-file s5700-hi.cfg custom-file header1.txt

    # Specify information about the files to be downloaded to Client2.

    [SwitchA-easyoperation] client 2 configuration-file s5700-hi.cfg custom-file header1.txt

    # Specify information about the files to be downloaded to Client3.

    [SwitchA-easyoperation] client 3 configuration-file s5700-x-li.cfg custom-file header2.txt

    # In the Easy-Operation view of the Commander, set the file activation delay time to 15 minutes (900 seconds) based on the size of files that Client3 needs to download.

    [SwitchA-easyoperation] activate-file delay 900

  8. Configure SwitchA to automatically back up configuration files.

    [SwitchA-easyoperation] backup configuration interval 2
    [SwitchA-easyoperation] quit

  9. Verify the configuration.

    # Check global configuration of the Commander.

    [SwitchA] display easy-operation configuration                             
    ---------------------------------------------------------------------------     
     Role                            : Commander                                     
     Commander IP address            : 192.168.1.6                               
     Commander UDP port              : 60000                                         
     IP address of file server       : 192.168.2.2                                
     Type of file server             : SFTP                                          
     Username of file server         : admin                                         
     Default system-software file    : -                                             
     Default system-software version : -                                             
     Default configuration file      : -                                             
     Default patch file              : -                                             
     Default WEB file                : -                                             
     Default license file            : -                                             
     Default custom file 1           : -                                             
     Default custom file 2           : -                                             
     Default custom file 3           : -   
     Auto clear up                   : Disable                                       
     Auto join in                    : Enable  
     Topology collection             : Enable
     Activating file time            : Delay 900s                                   
     Activating file method          : Default 
     Aging time of lost client(hours): - 
     Backup configuration file mode  : Default                                       
     Backup configuration file interval(hours): 2                                   
    ---------------------------------------------------------------------------

    # Check the file downloading progress on each client after the zero touch device deployment process starts.

    [SwitchA] display easy-operation download-status             
    The total number of client in downloading files is : 3                          
                                                                                    
    ---------------------------------------------------------------------------- 
      ID     Mac address    IP address      Method      Phase         Status     
    ---------------------------------------------------------------------------- 
      1      00E0-FC12-A34B 192.168.1.254   Zero-touch  Config-file  Upgrading  
      2      00E0-FC34-3190 192.168.1.253   Zero-touch  Config-file  Upgrading  
      3      5489-9875-edff 192.168.1.252   Zero-touch  Config-file  Upgrading  
    

Configuration File

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 10 20
#
cluster enable
#
ntdp enable
ntdp timer 5
ndp enable
#
dhcp enable
#
interface Vlanif10
 ip address 192.168.1.6 255.255.255.0
 dhcp select relay
 dhcp relay server-ip 192.168.3.2
#
interface Vlanif20
 ip address 192.168.4.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet1/0/3
 port link-type hybrid
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
#
cluster
 mngvlanid 10
#
ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
#
easy-operation commander ip-address 192.168.1.6
easy-operation commander enable
# 
easy-operation
 client auto-join enable
 topology enable
 sftp-server 192.168.2.2 username admin password %^%#=.X8C_TN##%&9P>3RK503O@w-=Fr%>naT#E3P4{0%^%#
 backup configuration interval 2
 activate-file delay 900
 client 1 configuration-file s5700-hi.cfg
 client 1 custom-file header1.txt
 client 2 configuration-file s5700-hi.cfg
 client 2 custom-file header1.txt
 client 3 configuration-file s5700-x-li.cfg
 client 3 custom-file header2.txt
#
return

SwitchB configuration file

#
sysname SwitchB
#
vlan batch 30
#
dhcp enable
#
ip pool easy-operation
 gateway-list 192.168.1.6
 network 192.168.1.0 mask 255.255.255.0
 option 148 ascii ipaddr=192.168.1.6;
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
 dhcp select global
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 30
 port hybrid untagged vlan 30
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
# 
return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065643

Views: 10953

Downloads: 35

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next