No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R013C00 Configuration Guide - QoS

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, ACL-based simplified traffic policy, and HQoS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an ACL-based Simplified Traffic Policy to Implement Priority Mapping

Example for Configuring an ACL-based Simplified Traffic Policy to Implement Priority Mapping

Networking Requirements

As shown in Figure 9-4, GE2/0/1 on the Switch connects to the router. Enterprise departments 1 and 2 access the Internet through the switch and router. Enterprise departments 1 and 2 belong to VLAN 100 and VLAN 200 respectively.

Enterprise department 1 requires better QoS guarantee. 802.1p priorities of packets from enterprise departments 1 and 2 are both 0. Priority mapping needs to be configured to map priorities of packets from enterprise departments 1 and 2 to 4 and 2 respectively so that differentiated services are provided.

Figure 9-4  Networking of priority mapping



Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces so that users can connect to the Internet through the Switch.
  2. Configure ACLs to differentiate packets from different departments based on the VLAN ID.
  3. Configure priority mapping on inbound interfaces GE1/0/1 and GE1/0/2 of the Switch.

Procedure

  1. Create VLANs and configure interfaces.

    # Create VLAN 100 and VLAN 200.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200
    

    # Configure GE1/0/1, GE1/0/2, and GE2/0/1 as trunk interfaces, add GE1/0/1 and GE1/0/2 to VLAN 100 and VLAN 200, and add GE2/0/1 to VLAN 100 and VLAN 200.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet2/0/1] quit

  2. Configure priority mapping.

    # Configure ACL 4001 and 4002 on the Switch to differentiate packets from enterprise departments based on the VLAN ID.

    [Switch] acl 4001
    [Switch-acl-L2-4001] rule permit vlan-id 100
    [Switch-acl-L2-4001] quit
    [Switch] acl 4002
    [Switch-acl-L2-4002] rule permit vlan-id 200
    [Switch-acl-L2-4002] quit
    

  3. Configure priority mapping on inbound interfaces GE1/0/1 and GE1/0/2 of the Switch.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-remark inbound acl 4001 8021p 4 
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] traffic-remark inbound acl 4002 8021p 2 
    [Switch-GigabitEthernet1/0/2] quit
    

  4. Verify the configuration.

    # Check information about ACL rules and actions on the interface in the inbound direction.

    [Switch] display traffic-applied interface gigabitethernet 1/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/1                             
                                                                                    
    ACL 4001                                                                        
     rule 5 permit vlan-id 100                                                      
    ACTIONS:                                                                        
     remark 8021p 4                                                                 
    -----------------------------------------------------------  
    [Switch] display traffic-applied interface gigabitethernet 1/0/2 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/2
                                                                                    
    ACL 4002                                                                        
     rule 5 permit vlan-id 200                                                      
    ACTIONS:                                                                        
     remark 8021p 2                                                                 
    -----------------------------------------------------------
    

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 200
    # 
    acl number 4001                                                                                                                  
     rule 5 permit vlan-id 100                                                                                                      
    acl number 4002                                                                                                          
     rule 5 permit vlan-id 200            
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     traffic-remark inbound acl 4001 8021p 4   
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     traffic-remark inbound acl 4002 8021p 2   
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065653

Views: 18173

Downloads: 45

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next