No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R013C00 Configuration Guide - QoS

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, ACL-based simplified traffic policy, and HQoS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Priority Mapping

Example for Configuring Priority Mapping

Networking Requirements

As shown in Figure 3-6, GE2/0/1 on the Switch connects to the router. Departments 1 and 2 access the Internet through the Switch and router. Department 1 belongs to VLAN 100 and department 2 belongs to VLAN 200.

Department 1 requires better QoS guarantee. 802.1p priorities of packets from departments 1 and 2 are both 0. A DiffServ domain needs to be defined to map priorities of packets from departments 1 and 2 to 4 and 2 respectively so that differentiated services are provided.

Figure 3-6  Networking diagram of priority mapping

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces so that departments 1 and 2 can connect to the Internet through the Switch.
  2. Create DiffServ domains, and map 802.1p priorities to PHBs and colors.
  3. Bind DiffServ domains to GE1/0/1 and GE1/0/2 on the Switch respectively.

Procedure

  1. Create VLANs and configure interfaces.

    # Create VLAN 100 and VLAN 200.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200
    

    # Configure GE1/0/1, GE1/0/2, and GE2/0/1 as trunk interfaces, add GE1/0/1 and GE1/0/2 to VLAN 100 and VLAN 200, and add GE2/0/1 to VLAN 100 and VLAN 200.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet2/0/1] quit

  2. Create and configure DiffServ domains.

    # Create DiffServ domains ds1 and ds2 on the Switch and map 802.1p priorities of packets from departments 1 and 2 to different CoS.

    [Switch] diffserv domain ds1
    [Switch-dsdomain-ds1] 8021p-inbound 0 phb af4 green
    [Switch-dsdomain-ds1] quit
    [Switch] diffserv domain ds2
    [Switch-dsdomain-ds2] 8021p-inbound 0 phb af2 green
    [Switch-dsdomain-ds2] quit
    

  3. Bind DiffServ domains to interfaces.

    # Bind DiffServ domains ds1 and ds2 to interfaces GE1/0/1 and GE1/0/2, respectively.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] trust upstream ds1
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] trust upstream ds2
    [Switch-GigabitEthernet1/0/2] quit
    

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 200
    #
    diffserv domain ds1
     8021p-inbound 0 phb af4 green
    diffserv domain ds2
     8021p-inbound 0 phb af2 green
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     trust upstream ds1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     trust upstream ds2
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065653

Views: 18546

Downloads: 45

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next