No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Device Management

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Device Management, including device status query, hardware management, Stack, SVF, cloud-based management, PoE, monitoring interface, OPS, energy-saving management, information center, fault management, NTP, synchronous ethernet, PTP.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring SVF to Deploy a Wired and Wireless Converged Campus Network Access Layer (S5720HI as the Parent)

Example for Configuring SVF to Deploy a Wired and Wireless Converged Campus Network Access Layer (S5720HI as the Parent)

Networking Requirements

A new campus network has a large number of wired and wireless access devices. The widely distributed access devices complicate management and configuration of the access layer. Unified management and configuration of wired and wireless access devices are required to reduce the management cost.

In Figure 4-15, two aggregation switches set up a stack system and function as the parent to connect to multiple ASs and APs.

In this example, the S5720HI functions as the parent, the S5720-28P-PWR-LI-AC functions as an AS, and the AP5010DN-AGN functions as an AP.

Figure 4-15  Configuring a wired and wireless converged campus network access layer

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure wired access devices to enable ASs to connect to the SVF system successfully.

  2. Configure the ports that connect ASs to APs to enable wireless access devices to connect to the SVF system successfully.

Procedure

  1. Connect ASs to the parent.
    1. Configure the two switches in the parent to set up a stack. For the procedure and notes for configuring a stack, see "Stack Configuration" in the Configuration Guide - Device Management Configuration of fixed switches.
    2. Log in to the stack and enable the SVF function.

      # Configure the management VLAN in the SVF system and enable the SVF function on the parent.

      <HUAWEI> system-view
      [HUAWEI] vlan batch 11
      [HUAWEI] dhcp enable
      [HUAWEI] interface vlanif 11
      [HUAWEI-Vlanif11] ip address 192.168.11.1 24
      [HUAWEI-Vlanif11] dhcp select interface
      [HUAWEI-Vlanif11] dhcp server option 43 ip-address 192.168.11.1
      [HUAWEI-Vlanif11] quit
      [HUAWEI] capwap source interface vlanif 11
      [HUAWEI] stp mode rstp
      [HUAWEI] uni-mng
      Warning: This operation will enable the uni-mng mode and disconnect all ASs. STP calculation may be triggered and service traffic will be affected. Continue? [Y/N]:y

    3. Configure AS access parameters.

      # (Optional) Configure a name for each AS.
      NOTE:
      • If you do not perform this step, the system will generate AS device information when ASs connect to the SVF system. An AS name is in the format of system default name-system MAC address.
      • If you need to perform this step, ensure that the configured model and mac-address parameters are consistent with the actual AS information. The value of mac-address must be the AS management MAC address or system MAC address. To view the AS management MAC address, run the display as access configuration command on the AS. If the management MAC displays --, the value of mac-address is the system MAC address. If the configured parameters are inconsistent with the actual AS information, the AS cannot go online.
      [HUAWEI-um] as name as1 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0011
      [HUAWEI-um-as-as1] quit
      [HUAWEI-um] as name as2 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0022
      [HUAWEI-um-as-as2] quit
      [HUAWEI-um] as name as3 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0033
      [HUAWEI-um-as-as3] quit
      

      # Configure fabric ports that connect the parent to level-1 ASs. The following uses fabric port 1 that connects the parent to AS 1 as an example.

      [HUAWEI-um] interface fabric-port 1
      [HUAWEI-um-fabric-port-1] port member-group interface eth-trunk 1
      [HUAWEI-um-fabric-port-1] quit
      [HUAWEI-um] quit
      [HUAWEI] interface gigabitethernet 1/0/1
      [HUAWEI-GigabitEthernet1/0/1] eth-trunk 1
      [HUAWEI-GigabitEthernet1/0/1] quit
      [HUAWEI] interface gigabitethernet 2/0/1
      [HUAWEI-GigabitEthernet2/0/1] eth-trunk 1
      [HUAWEI-GigabitEthernet2/0/1] quit
      

      The configurations of fabric ports 2 and 3 that connect the parent to AS 2 and AS 3 respectively are similar to the configuration of fabric port 1, and are not mentioned here.

      # Configure ASs to be authenticated using a whitelist when they connect to the SVF system.

      To view the AS management MAC address, run the display as access configuration command on the AS. If the management MAC displays --, the MAC address configured in the whitelist is the AS system MAC address. Otherwise, the MAC address configured in the whitelist is the AS management MAC address.

      [HUAWEI] as-auth
      [HUAWEI-as-auth] undo auth-mode
      [HUAWEI-as-auth] whitelist mac-address 00e0-0001-0011
      [HUAWEI-as-auth] whitelist mac-address 00e0-0001-0022
      [HUAWEI-as-auth] whitelist mac-address 00e0-0001-0033
      [HUAWEI-as-auth] quit
      

    4. Connect ASs to the parent using cables.

      # Run the reset saved-configuration command to clear the configurations of ASs, restart the ASs, and then connect ASs to the parent using cables. Subsequently, an SVF system is set up.

      NOTE:
      • Before restarting an AS, check whether the port that connects this AS to the parent is a downlink port. You can run the display port connection-type access all command on this AS to view all downlink ports on it. If this port is a downlink port, run the uni-mng up-direction fabric-port command on this AS to configure this port as an uplink port before restarting this AS. Otherwise, this AS cannot go online.
      • Before connecting an AS to the parent, ensure that the AS has no configuration file and no input on the console port.

      # After connecting cables, run the display as all command to check whether ASs have connected to the SVF system.

      [HUAWEI] display as all
      Total: 3, Normal: 3, Fault: 0, Idle: 0, Version mismatch: 0
      --------------------------------------------------------------------------------
      No.  Type           MAC            IP              State        Name
      --------------------------------------------------------------------------------
      0    S5720-P-LI     00e0-0001-0011 192.168.11.254  normal      as1
      1    S5720-P-LI     00e0-0001-0022 192.168.11.253  normal      as2
      2    S5720-P-LI     00e0-0001-0033 192.168.11.252  normal      as3
      --------------------------------------------------------------------------------
      

  2. Connect APs to ASs.
    1. Configure the ports that connect ASs to APs.

      # Add the ports that connect ASs to APs to an AP port group.

      [HUAWEI] uni-mng
      [HUAWEI-um] port-group connect-ap name ap
      [HUAWEI-um-portgroup-ap-ap] as name as1 interface gigabitethernet 0/0/24
      [HUAWEI-um-portgroup-ap-ap] as name as3 interface gigabitethernet 0/0/24
      [HUAWEI-um-portgroup-ap-ap] quit
      [HUAWEI-um] commit as all
      Warning: Committing the configuration will take a long time. Continue?[Y/N]: y
      [HUAWEI-um] quit
      

    2. Configure AP access parameters.

      # Configure ID for each AP.

      [HUAWEI] wlan
      [HUAWEI-wlan-view] ap-id 1 ap-type ap5010dn-agn ap-mac 00e0-0001-0005
      [HUAWEI-wlan-ap-1] ap-name ap-1
      [HUAWEI-wlan-ap-1] quit
      [HUAWEI-wlan-view] ap-id 2 ap-type ap5010dn-agn ap-mac 00e0-0001-0006
      [HUAWEI-wlan-ap-2] ap-name ap-2
      [HUAWEI-wlan-ap-2] quit
      

      # Configure no authentication for APs to connect to an SVF system.

      [HUAWEI-wlan-view] ap auth-mode no-auth
      [HUAWEI-wlan-view] quit
      

    3. Power on APs and connect APs to ASs using cables.

      # After connecting cables, run the display ap all command to check whether APs have connected to the SVF system.

      [HUAWEI] display ap all
      Total AP information:
      nor  : normal          [2]
      -----------------------------------------------------------------------------------------
      ID   MAC            Name   Group     IP              Type            State STA Uptime
      -----------------------------------------------------------------------------------------
      1    00e0-0001-0005 ap-1   default   192.168.11.251  AP5010DN-AGN    nor   0   4H:49M:11S
      2    00e0-0001-0006 ap-2   default   192.168.11.250  AP5010DN-AGN    nor   0   6H:3M:40S
      -----------------------------------------------------------------------------------------
      Total: 2

Configuration Files

  • SVF system configuration file

    #
    vlan batch 11
    #
    stp mode rstp
    stp instance 0 priority 28672
    #
    lldp enable
    #
    dhcp enable
    #
    interface Vlanif11
     ip address 192.168.11.1 255.255.255.0
     dhcp select interface
     dhcp server option 43 ip-address 192.168.11.1
    #
    interface Eth-Trunk1
     port link-type hybrid
     port hybrid tagged vlan 1 11
     stp root-protection
     stp edged-port disable
     mode lacp
     mad relay
    #
    interface Eth-Trunk2
     port link-type hybrid
     port hybrid tagged vlan 1 11
     stp root-protection
     stp edged-port disable
     mode lacp
     mad relay
    #
    interface Eth-Trunk3
     port link-type hybrid
     port hybrid tagged vlan 1 11
     stp root-protection
     stp edged-port disable
     mode lacp
     mad relay
    #
    interface GigabitEthernet1/0/1
     eth-trunk 1
    #
    interface GigabitEthernet1/0/2
     eth-trunk 2
    #
    interface GigabitEthernet1/0/3
     eth-trunk 3
    #
    interface GigabitEthernet2/0/1
     eth-trunk 1
    #
    interface GigabitEthernet2/0/2
     eth-trunk 2
    #
    interface GigabitEthernet2/0/3
     eth-trunk 3
    #
    capwap source interface vlanif11
    #
    wlan
     wlan ap lldp enable
     ap auth-mode no-auth
     ap-group name default
     ap-id 1 type-id 30 ap-mac 00e0-0001-0005 ap-sn 2102355547W0E3000316
      ap-name ap-1
     ap-id 2 type-id 30 ap-mac 00e0-0001-0006 ap-sn 2102355547W0E1232287
      ap-name ap-2
    #
    as-auth
     whitelist mac-address 00e0-0001-0011
     whitelist mac-address 00e0-0001-0022
     whitelist mac-address 00e0-0001-0033
    #
    uni-mng
     as name as1 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0011
     as name as2 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0022
     as name as3 model S5720-28P-PWR-LI-AC mac-address 00e0-0001-0033
     interface fabric-port 1
      port member-group interface Eth-Trunk 1
     interface fabric-port 2
      port member-group interface Eth-Trunk 2
     interface fabric-port 3
      port member-group interface Eth-Trunk 3
     port-group connect-ap name ap
      as name as1 interface GigabitEthernet 0/0/24
      as name as3 interface GigabitEthernet 0/0/24
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065674

Views: 34459

Downloads: 289

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next